I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

Recommended reading: Library management in KiCad version 5

KiCad does not automatically discover libs. Nor does it update the list of libraries on update.

If you had KiCad 4.0.x installed previously then i would bet you still have parts of its configuration surviving. Most importantly the fp-lib-table. This file controls which footprint libs you use. If this is the case then you probably still run the on demand online footprint libs originally “distributed” with KiCad 4.0.x installations. The installer for the KiCad 5.0.0 however replaced the local symbol and 3d model files. This means your lib is now inconsistent. (There was a rather large reorganization in the library between these two releases)

How you know you are affected by this.

If your fp-lib-table uses the github plugin to serve libs (instead of legacy) then you have the version 4 library (plugin type is github, KIGITHUB is in the path)

But you could also have local libs still surviving from v4.
It is easy to discover if this is the case. Open the library manager in pcb_new and check if you have any lib with the prefix Housings (example Housings_DIP) if this is the case you run the version 4 footprint libs. (These libs have been renamed to the better fitting suffix Package in the version 5 library)
Generally any library with plural name is a dead giveaway that you are using version 4 libraries.


How to fix it

Short version: you need to get all your libs to the same version (either all libs to how they were at version 4 or all of them from version 5.)

Option 1: Update the library setup to use version 5 footprint libs (recommended)

This will mean that old projects are harder to work with. (You no longer have the same lib as you had back when you designed the project.) It might be worth the extra effort as the new lib has some major improvements. (The quality of both footprints and symbols did increase. The organization scheme is now easier to understand, …)

For this you need to update the fp-lib-table to use version 5 libs. The libraries should already be installed locally. The libs should be found under C:\Program Files\KiCad\share\kicad\modules for windows users and /usr/share/kicad/modules for linux users. If they are not installed read this post

Sadly there is no KiCad inbuild way to reset the library tables to the version 5 default. (See feature request for “Reset lib tables to default”. Which means we need to manually do this.

The safest way is to use the library manager and add the libs manually. (Has the downside of not getting library descriptions.)

  • Open the lib manager found in the preferences menu of the footpritn editor (In v5.1 this will also be found in the preferences menu of the kicad main window)
  • Delete all old libs from the lib table (the ones starting with ${KIGITHUB})
  • Use the browse button to add the new libs
    • It opens a tool similar to the file browser.
    • Navigate to the location of the libs and select the ones you want to add. (You can use shift left click and crtl left click to select multiple libs at once. Only select .pretty directories.)

The second option (explaind in great detail in the Appendix section of Library management in KiCad version 5) is to delete your old fp-lib-table from your config directory (under windows found in C:\Users\ …\AppData\Roaming\kicad for linux users it is found in ~/.config/kicad. For OSX it is found under /Users/[your user name]/Library/Preferences/kicad).
When you then start pcb_new from the project manager kicad should ask you if it should create the default library table. After this step you will need to manually add your personal libs again. (As you deleted the file pointing to them.)

Option 2: Downgrade all libs to version 4 libraries.

This option allow you to work with old projects easily but locks you in the old lib that is no longer maintained.

  • Replace the symbol and 3d models that where installed with version 5 of kicad. (Download the 4.0.x release of your choice from: https://github.com/KiCad/kicad-library/releases or clone the git repository and checkout the version you want.)
    • You can place the downloaded files anywhere. The safest option is to use some place inside your home directory.
  • Point your sym-lib-table to this installation.
    • Use the library manager found in the preference menu of the symbol editor (In v5.1 the manager is also available from the kicad main menu)
    • Remove all current libs from the table (Right now the setup will point to v5 libs. You decided to use version 4 libs)
    • Use the browse button to add the libs
      • This opens a file browser like tool
      • Navigate to the place where you put your libs and select the ones you want to add to kicad. (Use the shift and crtl keys to select multiple libs)
  • If necessary also point the KISYS3DMOD path to the place where you put the 3d models. (The path variables are managed with the path setup tool found in the preferences menu of the kicad main window.)

With your current setup you already point to online footprint libs of version 4. ( In more detail you use the current master of the git repository.) As the libs are no longer developed this will unnecessarily use up your data. It is therefore suggested to install the libs locally. Having the libs locally also allows you to install a specific release of the footprints. Read the FAQ article How can i install a specific version of the footprint library? for more details.

Option 3: run both versions of the lib in parallel

The third option is to run both library setups in parallel (or even KiCad 4 and KiCad 5 in parallel) Depending on your operating system this might not be very easily accomplished. (The safest route for a novice is still to run either KiCad 4 or KiCad 5 inside a virtual machine. Everything else requires tampering with system environment variables or startup scripts.)


Additional Information

A detailed description of how the update process could look like can be found in this post (click the link or the arrow to see the full text)

7 Likes
3D models not working
3D models do not show, name inconsistency in packages3d folder
[Possible bug?] Default library: incorrect footprints associated with symbols
Kicad 4 tht inductors footprint .mod
Cannot assign correct footprint
Defining top or bottom layer for components in schematic
Problem with GitHub libraries
Fresh Kicad 5 installation, most 3D models are missing (SOLVED)
Start from scratch with V5.1.5
Help adding Terminal Blocks to KiCad 5.1.5
Hierarchical sheets tricks
Moving from 4.07 to 5.01
Manage Footprint Libraries causes Kicad to crash
Schematics are all question marks
Trying to open Footprint editor from Eeschema
Dead Links on KiCad 3D Models
Create new power symbol from a existing one
Footprints and 3D Models are not visible in 5.1.4
Assigning footprint question
Libraries not found, 2019
Wrl file vs step file for 3D model of part
Frequent error while moving to new project and using few footprint
Can't set an active Library
Errors were encountered loading footprints: kicad_plugin.cpp : FootprintEnumerate() : line 1786
Don't see any PCB symbol in D_Bridge symbol
Libraries Confusion
Footprints in Kicad 5
Connecting wire on top layer removes the one on the bottom - can I stop this?
Footprint library path dont exist
Upgrading from 4 to 5: any hints and tips
Error loading footprint
No "Global spread and place" option, and "Place footprints Automatically" does nothing
No symbols in Eeschema
cvPcb pin filter (mostly) broken for me?
Library names mismatch
Help with Eeschema & second / after modules
Footprint libraries wrong? Me wrong?
How to use the footprints present locally, instead of Cvpcb making rounds to Github every time [Help with fp-lib-table]
All paths 3d paths are wrong
Crosshair tracks follow cursor everywhere, and ... Hello!
How do I choose the right footprint?
Problems when reading netlist in Pcbnew
Pcbnew not finding footprints
Housing_LCC PLCC-44_THT-Socket is not usable in 5.x
Pin headers are rotated
Fighting for weeks around libraries
PcbNew doesn't find footprints I just assigned in CvPcb
Cap Libraries have GONE!
RJ45 will not connect
No components on board images (3D view)
Problem changing hole size in pcbnew
Pin headers are misplaced
Pin headers are misplaced
Upgrading from 5.0 to 5.1 - any issues foreseen?
Library paths get broken
Dealing with library shakedown
After update to 5.1.0 no 3D models are shown
Load Error on CvPcb 5.0.2
3D view of pin headers is skewed
Library incompatibility V4 - V5
Failed: GET command from GitHub KiCad libraries
Major issues with upgrade to version 5
SOLVED: Some components don't show up in 3D view
KiCad 5 on my Mac can't find footprints
Upgrading to Kicad 5.0.2
[Solved] How to do a completely clean install on macOS?
Parts Chooser So slow to load, can it stay open?
Confusion about which library to contribute to
3D rendering not working reliably
Kicad 5.01- Installation- can't locate libraries
Problems with KiCAD v5 on Mac
Just upgraded from 4.0.7 to 5.0.2 and I love it!
Kicad Footprint Library Issues
Kicad Footprint Library Issues
Upgrading KiCad 4.07 to Kicad 5 missing all symbols
[solved] Songle Power Relay 3d library
Standard-symbols missing in KiCAD5.0.2 on LINUX-Mint
[Solved] KiCad Crashing Ubuntu
3D Empty header (just holes) array?
Footprint libraries not found on debian (kicad 5.0.2 ; from stretch-backports)
Footprint Assignment Page (CvPcb) Hanging Up ADDITIONAL PROBLEMS
Read Netlist (not responding)
Noob Here - Just starting with KiCad - bom problems - possibly due to my ignorance
KiCAD Crashes Rebuilding Board Connectivity
Noob Here - Just starting with KiCad - bom problems - possibly due to my ignorance
Library does not exist
KiCad 5 - 3D file paths
Getting re-started with KiCad
Specifying a Library Symbol
Set 3D shape to STEP or WRL file
Libraries are empty
Libraries are empty
Errors were encountered loading footprints:
Mounting holes, can't find any
Download Footprints?
Github footprint libraries missing in KiCad 5
3D models not showing
Error trying to save custom footprint
Mac OS Sierra and Footprints
Fixing footprint library path 4.0.0-rc2?
How to make 3D modeling work in Kicad 5.0.0?
Kicad 5 new symbols load error?
Kicad 5 Fresh Install most footprints missing?
3D models under OSX
CVPCB - Error, component not found in any library
Global Footprints Lost in Upgrade form 4 to 5.0 on OSX
Which option to use when running version 5 first time?
3D models not showing
CvPcb error reading zip
Its looking for deleted lib location
All pcb footprints missing from all libraries
Not all Footprint Libraries are found
Cursor freezing in schematic
Looking for various footprints (ATMega)
Weirdness with SMD resistor footprints (New KiCAD user)
Kicad5 using old footprints?
KiCad 5.0 should I upgrade from 4.07?
KiCad 5.0 should I upgrade from 4.07?
Updating Library
KiCad 5 Framebuffer Error & Question
How to assign JST footprint to connector
2 important issue plz support PCBnew kicad 5.0
Help to source, install and manage libraries?
Assign footprints is crazy slow
Remap symbol do not fully compatible with 4.0.7
Footprint viewer is empty
Footprint Libraries misspelled?
SOLVED (Human error): Missing / wrong net allocation from Eeschema to Pcbnew
3D Models - Issue
Error in loading footprint
Older Schematics doesn't show any Sympols at all anymore all of a sudden!
My journey to get my first symbol and footprint accepted in the official library on arch linux
KiCAD LIBRARIES
Annoying cache issue
Sometimes footprint libraries are empty
Splitting nets for different trace widths
Schematic vanished
Environment Variable Issue
Problems with PCBnew adding footprint which is valid in CvPCB and library paths
3D viewer displays garbage
No footprint selected
(Start Here) Frequently Asked Questions
Kicad Missing Footprint - v4 vs v5?
Some footprint libraries not appearing? (help?)
Can't assign footprints
Problem with ERC in hierarchical sheets (pin not driven)
New install of 5.1.6 - CvPCB does not work
Module and 3-d name changes with 5.1.6
Cursed cursor trail!
Undo symbol library upgrade to 5?
[Possible bug?] Default library: incorrect footprints associated with symbols
The latest version of KICAD does not work good