3D models not showing

Search your system for the libs I pointed too. If they aren’t on your system you need to put them on. Again, I don’t know much about Ubuntu’s packaging but you might want to look at this.

How do I point to libs. I believe all the necessary libs are installed by default by using this approach to install kicad on my system:

sudo add-apt-repository --yes ppa:js-reynaud/kicad-5
sudo apt update
sudo apt install kicad

an this is my configuration variable

Have a look on this thread on my question and the following answers:

The user solved the issue with KiCad 3D plugins.

do you mean these plugins:

These faq articles might be of help here:

3d models are not managed in a library table. Footprints directly point to a file.

The footprints of the official lib use the path variable KISYS3DMOD as the path. (Seems to be setup correctly as shown in your screenshot. So make sure there are 3d models in there.)

For your personal libs you can use the absolute file system path to make live easier fir you. (At least for now. I suggest to use path variables here to future proof your work and to make it portable.)

HI ogahslab,
I mean 3D plugin files that are installed with KiCad instalation.
When you go to add a new 3D shape to a Footprint, what file formats the dialog allows you to select?

Also, on your previous post, the /usr/share/kicad/modules are not the 3D libraries, they are the footprint libraries.
As from your environment configuration, it should be /usr/share/kicad/modules/package3d/

Check his screenshots again. KISYS3DMOD points to the correct location :wink:

True, sorry, I mean the first one:
“for me i thought the 3d libraries are install by default because the 3d modules are available as show”

this is the libraries

in my case i have the 3d libraries installed my default. but instead of 3d component showing at the 3d viewer, i only see pads

Did you check that the 3d model exists for your particular footprint?

yes it does looking at this footprint. if i try to view the component with 3d viewer this is what shows. cap%20foot . and this is the view:

but after routing, when i tried to view it , i got only the pads without components on it

From that we can conclude that the 3d plugin works. (Meaning the stuff suggested by @kammutierspule does not apply to you.)

Now we need to find out why your pcb does not render. Did you use the exact same footprint as you used for creating the screenshots above in your pcb?

When importing a footprint into the pcb it stores its 3d settings in the pcb_new file. So it could be that you had placed a footprint with different settings. (Meaning you would need to update the footprint)
If it is an older project than it might be that it has the footprints from version 4. These had slightly different names. (So they search for a differently named 3d model than you have.)

To test this you can insert the footprint manually. On the right side of pcb_new there is a button for adding footprints (looks like a small SOIC package with green leads) This will allow you to add the footprint you just checked to the pcb. After that check the 3d view.
If you do not see it in this test then i would guess you turned of the visibility of 3d models inside the 3d viewer. (I don’t have access to kicad right now so i can not check how the menu settings are called. My guess is that this would be under the view or preferences menu.)


ok. the project was copied from my own old computer of 32 bit though it is kicad 5.0.1 but the support of opengl is low. that is why i got a new system with high support for opengl. i will start the project afresh and see if there will be changes and i will update the house.
thanks for now

Check your display options in the 3D viewer. 3D models can be turned off, you may need to turn them on. See:

THANK YOU @ Rene_Poschl. It is up and running


Hi, similar problem with my KiCad 5.0.1 installation on win10.

I recently stepped over KiCad as a replacement for EAGLE (old version 5…)
And I’m really happy with KiCad!

Now to the problem:

The 3D model referenced here does not show because there exists no such file in the package!
I checked https://kicad.github.io/packages3d/Fuse - no such file there too …

Same with some other 3D models referenced to footprints: The files do not exist in the corresponding packages.
What happened to these files - and where can one get the missing files?

There is no 3D model because the librarians have not found a model for this component or the one they have found has not enough quality.
The path is there ready for the future, when someone make the model.