3D models not showing


#1

Hello everyone,

3D models are not working for me since KiCad 5. I looked around a lot but nobody seems to be having the same problem that I have.

I will explain the problem with an example :

The wrl/step models doesn’t show up in KiCad. “Select 3D Model” is unable to even show a preview of the 3D model. The path ${KISYS3DMOD} is configured correctly - ‘/usr/share/kicad/modules/packages3d/’, and the package3d folder with all the 3D files exist in that location. The 3D models used to work fine till KiCad 4.x.x.

Also these 3D models work fine when I open them in other programs (like FreeCad).

Does anybody know what could be the issue?

System information :
OS : OpenSuse Tumbleweed.
Graphics driver : nVidia proprietary.
KiCad version : 5.0.0-1.1 from Opensuse Tumbleweed repository.

Let me know if any other information is required.

Thank you very much in advance.

Best regards,
Arjun


How to make 3D modeling work in Kicad 5.0.0?
#2

It is also helpful About kicad->show verion info


#3

I have the feeling you might be affected by this (click the link or the arrow on the top right to see the full post)


#4

Yes.

Application: kicad
Version: 5.0.0, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.0 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.8.2/openssl/zlib nghttp2/1.32.0
Platform: Linux 4.18.5-1-default x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8) GTK+ 2.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.0
Compiler: GCC 8.2.1 with C++ ABI 1013
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=OFF
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#5

You have KICAD_USE_OCE=ON, what is alright.

Have you tried a full hard path, without KISYS3DMOD?


#6

Dear Rene,

Thanks for the reply. I did see your post earlier.

I deleted the files in “~/.config/kicad” and any remaining file from the KiCad 4 installation and then tried to install KiCad 5.

Another point is that I do not use any of the official libraries for my development. I didn’t even bother downloading them (or remove them from the global libraries instantly) until this issue. I noticed the 3D issue happening with my personal library, so, I removed and reinstalled KiCad to try to fix the problem. If I can find a fix to the issue using the official library then I can easily move to my own.

Regards,
Arjun


#7

Dear Pedro,

Yes. I did try using the absolute path. Here’s a screenshot.

Regards,
Arjun


#8

I launched KiCad from Konsole to check if there is any useful text output. This is the output.

I got the warnings.warn("wxPython/wxWidgets release number mismatch") when I launched the footprint editor. Is it relevant to this issue?


#9

I don’t know if this mismatch has something to do with this issue.
I don’t see why 3d viewer must be related to wxPython, but who knows.

My version has KICAD_SCRIPTING_WXPYTHON=OFF, that should only concern the python scripting tool.

Both the footprint and the 3d model are OK (My official libraries have been moved under /home). I’m sorry I can’t help you with this problem.


#10

Alright. Thanks for having a look :slight_smile:

I need to boot Windows just to use Altium. I just hope that I don’t have to boot Windows to use Altium and KiCad now :smile:


#11

in the “Select 3D file” are you able to choose the .wrl and .step file formats? ( instead of * . * )


#12

No. The drop down menu does not have any other options.


#13

So there is some problem with the KiCad instalation of your distro. It is not installing or place the 3D import plug-ins on a place that KiCad is able to find it. I heard this plugins are from the responsibility of the packager creator, since there are some differences between Linux distros related with this paths. If your installed it from a package for your distro can you rise a bug to the creator of that package?


#14

OK Thank you. I have submitted a bug report at : https://bugzilla.opensuse.org/show_bug.cgi?id=1107776


#15

13,000 hits on that string on Google,all sorts of applications getting broken by distribution packaging errors.


#16

From the bug report, I got this solution :

Looks like the problem is due to KiCad looking for 3D plugins in /usr/usr/lib64/kicad
A temporary fix would be to create a link to /usr/lib64/kicad in the above path.


#17

Please house, I have similar issue. I am running kicad 5.0 on Ubuntu 18.04. When I tried to render PCB on 3d viewer only the pads and traces shows. The 3d components does not show on the board


#18

I’m not familiar with the packages in Ubuntu but the first thing to check is to make sure the libraries were installed. Just installing Kicad usually will not do that. I just checked my Debian package manager and the 3D libs are separate from the rest.

Quick edit. They also are not included in the ‘meta package’ because of the size.


#19

i am new to kicad. for me i thought the 3d libraries are install by default because the 3d modules are available as show:

.

below is the version info

. thanks for your anticipating response


#20

Pretty is the footprint libraries. I know. I made that mistake too. :wink:

drwxr-xr-x 2 hermit hermit  4096 Aug 29 22:32 Battery.3dshapes
drwxr-xr-x 2 hermit hermit  4096 Aug 29 22:32 Button_Switch_SMD.3dshapes
drwxr-xr-x 2 hermit hermit  4096 Aug 29 22:32 Button_Switch_THT.3dshapes
drwxr-xr-x 2 hermit hermit  4096 Aug 29 22:32 Capacitor_SMD.3dshapes
drwxr-xr-x 2 hermit hermit  4096 Aug 29 22:32