3D models not showing


#41

There is no 3D model because the librarians have not found a model for this component or the one they have found has not enough quality.
The path is there ready for the future, when someone make the model.


#42

Thanks for the info.


#44

I have same problem after upgrade from kicad v4 to kicat v4 on ubuntu 18.04. There was problem with local kicad configuration stored in /home//.config/kicad/ in my case.
3D components were named in plural in version 4, but from version 5 components names are in singular form (like Resistors vs. Resistor). Here is configuration greped by string “Resistors”:

@bobek:~/.config/kicad$ grep Resistors *
fp-lib-table: (lib (name Resistors_SMD)(type Github)(uri ${KIGITHUB}/Resistors_SMD.pretty)(options “”)(descr “Resistors, surface mount”))
fp-lib-table: (lib (name Resistors_THT)(type Github)(uri ${KIGITHUB}/Resistors_THT.pretty)(options “”)(descr “Resistors, through hole”))
fp-lib-table: (lib (name Resistors_Universal)(type Github)(uri ${KIGITHUB}/Resistors_Universal.pretty)(options “”)(descr Experimental))

So, my solution was to remove/backup old configuration and new one was created at next kicad application start.

Next problem is with existing projects, because symbols are assigned to footprints with plural names (like “Resistors_SMD:R0805”), so I reasigned all symbols to non plural footprint in dialog “Assigning BCP footprints to schematic symbols” (like “Resistor_SMD:R0805_2012Metric”).

From that moment were components visible in 3D view.