Github footprint libraries missing in KiCad 5

Hi all, I just updated to Ubuntu 18.04 and KiCad 5.0.1 and I’m having trouble getting a few of the Github-based footprint libraries to work. Most of them are fine, but for example Jumpers.pretty doesn’t show up in my footprints library browser and attempts to add it have been unsucessful:

My KiCad’s default KIGITHUB path seems to be “” and to be fair, “” does not exist, but when I change the KIGITHUB path to “” or append “” by itself, I get a pop-up saying, “error reading zip local header.”

For the record I did go through the migration-from-kicad-4 process described here: and I also tried upgrading kicad-libraries and kicad-footprints from the command line.

I see in this post How can i install a specific version of the footprint library? that the migration to the kicad-footprints repo in KiCad 5 breaks the github plugin–does this mean I HAVE to download the whole library now? What am I missing?

The use of the github libs is deprecated for the official lib. The Jumpers lib is also one of the version 4 libs not one of the version 5 ones. (plural vs singular name)

You might want to read this: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

For linux you might also have not installed the library packages. Read this for instructions on how to fix that: I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled)

Thank you! The procedure in your first link to add the new libraries solved the issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.