Github footprints problem


#1

Kicad 4.0.1-3 (6198) on Ubuntu 14.04.1 from the PPA

trying to add a component in pcbnew and the footprint browser gives:
"
Errors were encountered loading footprints
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Crystals_Oscillators_SMD.pretty/zip/master
for library path: ‘https://github.com/KiCad/Crystals_Oscillators_SMD.pretty’.
Reason: ‘Not found’
from /build/kicad-zrsXpt/kicad-4.0.1/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584
"

Looking in library manager I have KIGITHUB = https://github.com/KiCad
is that reference to “codeload” right??

perhaps for the same reason, CvPcb completely hangs and never recovers (windows greyed out) when trying to open it?

Anders


Cant find libraries in CVPCB
#2

on another machine I get:

Errors were encountered loading footprints
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Housings_TO-50.pretty/zip/master
for library path: ‘https://github.com/KiCad/Housings_TO-50.pretty’.
Reason: ‘Not found’
from /build/kicad-zrsXpt/kicad-4.0.1/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Muonde.pretty/zip/master
for library path: ‘https://github.com/KiCad/Muonde.pretty’.
Reason: ‘Not found’
from /build/kicad-zrsXpt/kicad-4.0.1/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Transistors_SMD.pretty/zip/master
for library path: ‘https://github.com/KiCad/Transistors_SMD.pretty’.
Reason: ‘Not found’
from /build/kicad-zrsXpt/kicad-4.0.1/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Sockets_PGA.pretty/zip/master
for library path: ‘https://github.com/KiCad/Sockets_PGA.pretty’.
Reason: ‘Not found’
from /build/kicad-zrsXpt/kicad-4.0.1/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Housings_TO-78.pretty/zip/master
for library path: ‘https://github.com/KiCad/Housings_TO-78.pretty’.
Reason: ‘Not found’
from /build/kicad-zrsXpt/kicad-4.0.1/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Transistors_TO-220.pretty/zip/master
for library path: ‘https://github.com/KiCad/Transistors_TO-220.pretty’.
Reason: ‘Not found’


#3

#4

Please make sure the libraries you added to kicad actually still exist on github! Sometimes libraries get deleted or renamed there.


#5

I get this all the time now, and I have not installed any custom libraries… this is just the standard Kicad libraries.


#6

Ugh!

This seems to be a really old issue :frowning: The libraries have been reorganized, see e.g.:


That page links to a google-spreadsheet with old deprecated libraries and new ones.

It seems that the standard fp-lib-table is hopelessly outdated :frowning: here:

this is causing a lot of confusion now so hopefully will be fixed soon…


Launch of Cvpcb shows component count but center window is blank
#7

I just uninstalled and installed new nightly build to see if that would work…

I cant actually get any work done now.


#8

Ok I found a work around on Windows

Goto the c:\users[YourUserName]\AppData\Roaming\Kicad, open in a text editor and replace the contents with
https://raw.githubusercontent.com/KiCad/kicad-library/master/template/fp-lib-table.for-github

I think what is happening is they are not updating this file when you upgrade from old Kicad versions.


#9

Yes! Many thanks for figuring this out!
On Ubuntu the file is at: /home/UserName/.config/kicad

I re-named the old file and replaced it with the one from github, and now I don’t get any errors :smile:


#10

Indeed, the installer does not update user config files from previous versions, so if you installed one of the “new” Kicads that uses github libraries then you will get this problem. There are a number of ways to solve the problem, but ultimately you need to have your footprint library table match the actual github repos.

We could really do with a sticky/FAQ on this!


#11

I think that instead of this solution you should remove all references to kicad github libraries from your fp-lib-table and use only libraries stored on your hdd or your own github. The reason is that the footprint libraries stored on kicad github may change at aby time and break your design (eg the footprint you’ve assigned with cvpcb may be different than the one you get on a board).


#12

Well, the idea is that you always get up to date footprints, if there is an error in a footprint it gets fixed. But the execution of the idea is flawed, if the user is not a) informed of a change, b) allowed to choose whether to install the update. Kicad currently lacks both of those features, so I think I would tend to agree that local libraries are the preferred way.

If I was confident that the kicad-libs would ensure backward compatibility then I might think differently, but experience shows that the github libs can change at will and users are not adequately informed. I wonder how many people are familiar with all the lib changes, such as diodes.

I am thinking of creating a library tool, which can present changes in a more friendly way.


#13

Hi @bobc, I’d be very interested in that. Having some kind of external tool that you could run to check your local library against the GitHub one would be nice. Have a list of diffs and then also be able to show how the footprint physically changed.


#14

I have a footprint-problem, too.
I have replaced the fp-lib-table with the fp-lib-table.for-github, as written here, but that did not help.
Here is the Error Message:

Error loading netlist.
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘https://codeload.github.com/KiCad/Transformers_SMPS_ThroughHole.pretty/zip/master
for library path 'https://github.com/KiCad/Transformers_SMPS_ThroughHole.prety.
Reason: ‘End of file’
from /build/kicad-WeUYPs/kicad-4.0.0/kicad/pcbnew/github/github_plugin.cpp:remote_get_zip():line 584

I am totaly new to kicad, this is my first try to “design” something with kicad, so I do know nothing about the principles behind all that “magic” thats going on in kicad.

Could someone please tell me, what the reason of this error is and how to avoid it?

Thanx in advance


#15

with the correct spelling that is a valid library path:

if you are on linux you can compare your actual fp-lib-table against the one on github with something like

$ diff <(cat .config/kicad/fp-lib-table) <(curl -s https://raw.githubusercontent.com/KiCad/kicad-library/master/template/fp-lib-table.for-github)


#16

@Anders_Wallin: Thank you very much for your answer.
The wrong spelling was a typo made by me, because I had to type the popup-message by hand…

I meanwhile have seen, that there is a footprint-library-wizzard and I have used it :wink:
It seems, that it has checked footprints on Github and has importetd them (all but one [ something like “Label” or so])

So it seems to work now, after a while, I found all footprints and learned how to get them into the pcbnew … its hard to understand that all, but seems to be possible :wink:


#17

Hi there. How do I link to a local library. I’ve managed to check them out, but how do I change the KIGITHUB environment variable?


#18

KiCAD main window > Preferences > Configure Paths


#19

I’m not seeing that. Under preferences I see: Set Text Editor, PDF Viewer and Language. Can’t seem to find anywhere in the app to change this. Am on Mac, Kicad 2014-10-31 BZR 5247


#20

Hm… that was on Win7 with KiCAD BZR6097 (current is something around BZR64xx)… is there not a more recent version of KiCAD for OS.X?