CVPCB Error Loading Footprints


#1

Something happened and I now get a very large error message when loading CVPCB, saying that a variety of footprint libraries are unable to retrieved from GitHub. The end result is that, while the libraries appear in CVPCB to be selected, none of the footprints inside the library actually appear for selection (and this is with only the 'library" filter selected). For example, when I have I have an LM555N as the only component in the schematic and want to associated it with an SOIC8 footprint, the HOUSINGS_SOIC library appears, but there are no footprints inside of it to be selected.

When I open the footprint editor, all the libraries are there, and all the footprints are available and can be loaded. My library table seems to be clean. I’ve attempted deleting all the KIGITHUB libraries and re-adding them. I’ve attempted caching those libraries locally. None of this has changed the problem.

The error message is generally this…

Errors were encountered loading footprints
IO_ERROR: http GET command failed
Cannot get/download Zip archive: 'https://codeload.github.com/KiCad/Housings_SOT.pretty/zip/master'
for library path: 'https://github.com/KiCad/Housings_SOT.pretty'
Reason: 'Not Found'
form C:/Jenkins/workspace/windows-kicad-msys2-stable/src/kicad-4.0.0-rc1/pcbnew/github/github_plugin.cpp:remote_get_zip():line 584

… repeated for a variety of library names until the error message box simply runs out of room.

As this is preventing me from using any of the default libraries, I’m somewhat stuck in my workflow, which is bad for business.

Any suggestions on how to fix this? My personal thought is to finally bite the bullet and ditch every single default footprint library and go back to making them myself. I haven’t liked the new footprints anyway, and this new wrinkle is absolutely maddening.


Github footprints problem
(Solved) - As of yet undefined CvPCB trouble
#2

Probably the same as Fixing footprint library path 4.0.0-rc2? ?


#3

Yeah, I had read that and tried removing and re-adding all the global KiCad GITHUB libraries, which didn’t solve the problem.

Here’s what I just tried…

  1. Remove all global libraries.
  2. Save and Close and Reopen KiCad entirely.
  3. Create a dummy schematic with a single 555 and NC’s on all pins.
  4. Save project and open CVPCB. Confirmed that all error messages were gone.
  5. Close EESCHEMA and open footprint editor.
  6. Add the cached github folders i had downloaded earlier as individual libraries, ie: housings_soic.

Now the footprints show up, but obviously they are entirely disconnected from any form of GitHub updates, which I never relied on anyway so not a big deal.

Not sure this is really a solution so much as a work around… or rather an abandonment of how it was supposed to work.


#4

-> run Cvpcb > preference > footprint libraries

-> remove all global libraries

-> then click Append the Wizard > tick gitup repository > make sure tick on “Save a local copy to” and set local path like “C:\Users****\Documents”

-> download all libraries and save new libraries in your local machine

-> Now you configure your footprints


#5

I’m having a similar problem. I followed the procedure above, deleting all the global libraries found under CvPcb > Preferences > Footprint Libraries. I closed CvPcb and reopened, still got the error and lots of libraries are appearing in the right most column. I check the Footprint Libraries, none are listed. So I searched for all the fp-lib-table on my computer, made sure they were all empty. Restarted CvPcb but still the same error message and lots of libraries listed on the left most column.

I opened the Footprint Editor > PCB Libraries Table. Even though the file listed next to “Table:” is C:\Users\username\AppData\Roaming\kicad\fp-lib-table and is empty, the pop up window still lists all the old global libraries. So I remove them there, click OK, close out and go back to CvPcb and voila, no error or libraries listed in leftmost column.

Either KiCad keeps a record in memory that it only checks on start or it isn’t using the fp-lib-table under AppData as stated. And also, removing the libraries through CvPcb > Preferences > Footprint Libraries doesn’t erase the copy used by both CvPcb or the copy used by Footprint Editor > PCB Libraries Table.

Once I reimported all the github libraries, I didn’t get any errors upon opening CvPcb and all the libraries were listed in the left-most column.


#6

Is there a clear explanation somewhere about this mahusive cock up in the software ? This is why I stopped using it because it became unsable and it sees nothing has changed. I am a circuit designer not a programmer and I don’t give a flying **** how much development has gone into the PCB part of KiCAD if I can’t get into it because the library situation is still as trashed as it was 2 years ago!!! I work between 3 conputers on my projects. Any chance this screw up will just stop me from using the software ???

why does this not work out of the box ? why do we ALL have to fix it ? can’t we ust go back to the days when the footprints were stored on our machines end of. I DON’T WANT MY FOOTPRINTS TO COME FROM AN ONLINE LIBRARY THAT CAN CHANGE AT ANY TIME!!!


#7

I am treading very carefully with v4, tbh it’s more like a 3.5 beta. I had hopes that the devs would spend some time polishing the UI, but that was not to be. Let’s just say improving the user experience for non-expert users is not high on their list of priorities.

I’ve seen some scripts floating around to copy files locally, I haven’t tried them yet. When I have figured things out a bit better I am hoping to write some guides.

BTW, Kicad does have a session cache, I’ve noticed that sometimes I need to close and restart the project manager to pick up changes.


#8

@Sparky-Labs
Stop the screaming - any rep you have/had after such behavior is down the drain.

And it’s no wizardy to get KiCAD to use local libs only, you have to do 2 modifications:

  1. In KiCAD project module, change Module and 3DShape path under preferences
  2. In EEschema/SymbolEditor remove all libraries under preferences

Have fun.


#9

That works if you want to use only user-supplied libs, but that is not what was asked for. If you want to use the default libs, but stored locally, you need to download the .pretty repos.


#10

I was addressing Sparky_Labs, not the OP or any other people in this particular thread :wink:

But you’re naturally right… that one needs to then adjust the settings to load the local libs, but this should be pretty straight forward going from what I wrote there.


#11

It’s a public forum Joan, otherwise send a PM if you want to talk privately :wink:

I guess you haven’t tried downloading the footprint libs, because it is hardly straightforward !


#12

As installed the software does not work, it’s that simple. It seems to be trying to access online libs that are not there, end of. If it is known that this is a problem and is it due to multiple threads about it why is a method known to not work being used ? are the libraries that it’s trying to find even there ? if they are not as the program reports why not ?

There was a time when this all worked fine, why does it not now ? if the way it works is to change then can we at least make sure it still works. The new “better” way is not better because it brings no benefit and further fails to work out of the box, the old method did work. So I argue that we have made no progress at all and have just made reasons for people not to use kicad.

As for my “rep” I care not for it. and if bringng up valid points hurts my “rep” then this is indeed a sorry way to try and develop a software isn’t it. We go backwards in the name of going forwards and those who point it out are “bad people”. Apparently I have a disk full of libraries that I have to manually import, whats the point of supplying them if they are not needed ? ah yes of course it does not work, but we pretend it does while each individual user manually fixing it on each install they have.

I would love to regularly donate to the project as i think it is worthwhile, but when we have these sorts of problems that as far as i remember are 2 years old and never used to be a problem I wonder if it’s a valid use of any of my money, are we going forwards with a more stable software or are we rolling our half cocked solutions to benefit developers ego’s ?.


#13

The problem is that you’ve used unstable releases that installed default fp-lib-table (that is outdated) that contains the “online” libraries. I’ve installed stable kicad on fresh installation of windows and linux and it’s all right - no error messages. Don’t expect everything working out of box if you use unstable releases.
To configure the fp-lib-table RTFM: http://docs.kicad-pcb.org/en/cvpcb.html#_footprint_libraries_management


#14

OK guys, this may be really simple. I’ve been using KiCAD for about a week now. Got my first netlist sorted and wanted to run CvPCB, got the same error, very confusing. By the third time I decided to read that file and realized it may be a net connection issue. No Downloads. Checked my wireless internet dongle and sure no blue light showing 3G connection. Connected, started over. No big file. Profiles all there. CvPCB runs happily. The dongle has the habit of dropping the net connection.


#15

I downloaded them some time ago for tests… not using them though, nor are they still loaded.
I admit, it’s not easypeasy to find https://github.com/KiCad, but once there, one can download all the .pretty repos (footprints) + the kicad-library repo (which also contains the 3d models).
Just copy them to a user accessible part of your system, tell KiCAD where they are (see above locations for preference settings) and you’re good to go.

There is way worse usability screwups in KiCAD than this.

I just pointed out the unnecessary screaming… no one has got a problem if users/donators point out bugs or argue.
Also, there is a bugtracker you can use to tell the devs directly of your findings and get their input on your POV, but I doubt that screaming will get you anywhere.

I know I know… you’re just a layouter/engineer who wants to use the software and not be hindered by bugs - good luck with that attitude.


#16

#17

Closing this topic as I believe it’s getting off track. If anyone has solutions to the additional problem, please start a new thread.