Symbols fields are twice displayed in edit symbol field

Hi all,

I have some issue with symbol field that appear two times in symbol field edit chart, and when I edit symbol properties (E) .For example I have two times Footprint field
I don’t really know when it happened, maybe when I changed preference from to english <-> french.
Never mind, I would like to kill those fields .
There is a button to add field ,not to kill one.
How can I do ?
is it possible to directly edit the file that manages fields and do some cleaning ?
BR

my kicad version : (5.1.8)-1

The best would of course be to restore a backup from just before *&^%$#@! happened.
Second best is to make a backup now before you *&^%$#@! more.

Just for clarity:
These duplicated fields are showing up in schematic symbols and not in Footprints?
… and you see them in an extra column in: Eeschema / Tools / Edit Symbol Fields ?

Just for fun I created the field “Asdf_field” and gave it the value “Asdf_Asdf_value.”

Which also shows up as an extra column in “Edit Symbol Fields”:

If you can’t repair it by editing the "Symbol Properties*, by selecting the field and clicking on the garbage can, then the next thing to try is to close kicad, open the schematic in a text editor, identify the offending lines and delete them there:

Can you post a screen capture?

Is there a chance you have 2 components sitting on top of each other? Annotate and see how it looks.

Hi iabarry and paulvdh,

here are some screenshots of symbol properties and symbol field :


As you can see Footprint field appears 2 times. I tried to delete the second one in one reference (first is the reserved field by kicad) in symbol propertie. It is deleted but when I go to symbol field , both field are here, and field erased is here with the footprint value.
So I think that there is only one field , but it is displayed twice.
I will try to edit the .sch file (I use a temp project copy… :slight_smile:) as proposed by Paul.
I’ll keep you informed.
Last question : I’m a little bit confused with fields because there are several place where you can manage them (sym propertie, symbol field ,preferences,…).
I tried to find some explanation about how to well create,modify delete fields in EEschema but I didn’t find anyething.
If you have some informatio or link…
Tanks by advance,

It should not matter in which dialog you enter or change these additional fields.
In Eeschema / Tools / Edit symbol Fields you have an overview of all fields of all symbols, and information can be quickly copied from one symbol to another. But clicking on a schematic symbol and then pressing e to edit it’s properties is also a valid way, and those (and other) methods can be used at will. You just use the method that is the easiest for your current job.

There is some info about creating and managing fields in schematic symbols in the FAQ. For example:

I am however also a bit confused by this. Some of the information is kept in the schematic file, but there is also a [library-name].dcm file with additional info about schematic symbols.

For more info, have look at the file file_formats.pdf. This file used to be part of the official documentation on the KiCad website, but it has been moved a few times. There are multiple copies floating around on this forum though.

This is a problem wherever the structure is defined for all components. I don’t immediately know where that is located. Some digging is required.

Have a look at this. If the Tool shows 2 fields, delete 1

So I did some tests. First I had a look in .sch file :


F 2 is kicad reserved field
F 9 is the one I want to remove
In symbol field , I have selected all the footprint from the second field and deleted them.
But they are also automatically deleted in the other field.
I watched in the .sch file and I saw that it was F 2 line was deleted not F 9.
I restored my copy from the original project and tried to delete the other field first.
But I got the same result.
Done a new restore.
In symbol field , if I modifiy one of the footprint field the other one is automatically updated with the new value
In symbol propertie , if i delete the content of the second footprint, the first one (kicad reserved) stay the same .
I deleted the second field ,the first stay alive.
In the .sch file F 2 is still present but F 9 is empty but present (normal?)

So my conclusions are :
If I want to remove the second footprint in symbol field I must modify the file that manages that window. (but it is really not necessary because I only have to uncheck the field to not see it)
if I want to remove the real second footprint field, I must delete every F9 line of each part.
But I have almost 800 parts… If you have any idea to do it in a fast way…

BR

I want to be VERY SPECIFIC here.

You say that all the SYMBOLS have an extra (duplicate) field. That means the SCHEMATIC has the extra field. NOT the symbol.

In the schematic editor, look at the Preferences. Select the duplicate and click the Wastebasket icon.

See this entry where someone wants to add a field.

Symbols are clean because I didn’t add field to them. All fields have been added using preference-> field name template, or symbol field
Only symbols in schematics have duplicate field…
I cannot erase the field in Preference because it doesn’t exist …

Regarding the creation of new field , the result is not the same wether you create it with preference->field name template, symbol field or symbol property.

if you add a field in field name template it is created and displayed for all parts
if you add it in symbol field, it is created only if it has at least one part that has this field not void. And this field is displayed in symbol properties only for part where it is not void.
if you add a field in symbol propertie ,it is displayed only for this part (not displayed if you use symbol properties of another part)

I had a look to the entry. It is the normal behaviour and display when you add a field.
For me it is different because I think that something happened and now it is a little bit lost (I think that it is when I have switched from French to english language , but I’m not sure).

And as I told in a previous message : “In symbol field , if I modifiy one of the symbol field, the other one is automatically updated with this value” ->> it is not a normal behaviour. A field cannot modify the content of another one…

So I have found a solution .Maybe it can help someone who has got the same problem.
I have used a text editor and opened all .sch file in my project. Using replace command, I have replaced all words “Empreinte” with “xx” (whatever you want but Empreinte).
I have re opened my project and seen that now footprint has a single column and is displayed only one time.
I have erased all parts in xx field but I haven’t been able to remove the “xx” field .but i don’t care , I can deal with it.
That’s all …