Issues with identifier 'reference' and 'value' colliding with german configuration 'Referenz' and 'Wert'


I have some trouble with my KiCAD configuration. Since I upgraded from the last built of KiCAD 6 in some cases some data loss can be seen. If I start a new project everything works fine. When the schematic is done, the footprints, the order numbers are assigned in the collective processing table and the project is saved, the problem occurs when this project is reopened again. In the table then the footprints and values are lost for the german identifiers. What makes me curious is that in the collective processing table the identifiers ‘reference’, ‘value’ and ‘Referenz’, ‘Wert’ are present (normally only one language should be present). In the english identifiers the correct values are stored. But the footprints are still lost. If I open the schematic in a text editor the definitions of the parts are done in english. It seems to be an internal problem of KiCAD.

Someone could give me a hint?

Best regards,


I’ve seen some similar behavior before, a bit of digging found the link below (but it wont help you much).

I think there is also already an issue opened for this bug on Gitlab, but I’m not really in the mood to search for it now.

I’ve never worked with translated versions of KiCad myself, but translating the names of those keywords probably opens a lot of windows to let in nasty bugs.

Seems to be a problem caused by different things:

I am using a lot of hierarchical sheets, which could be also the problem. The problem should be fixed in 6.0.5. Thank you for your help.

You can already download v6. 0.5 from the official website, let us known if the issue has been solved. Have fun.

The corrupted data are not working under 6.0.5 too. I did the same schematic again with the new version, till now everything is fine. One more thing I recognized was that in the plane schematic text of the corrupted data the word ‘Referenz’ appears in a definition which is not a column identifier. Maybe this leads to a collision (this case I will avoid in the future).

#some news:

Application: KiCad Schaltplan-Editor

Version: 6.0.5-a6ca702e91~116~ubuntu20.04.1, release build

wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.13.0-40-generic x86_64, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
Date: May 4 2022 07:55:51
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.83.0
ngspice: 36
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

There is still a bug which can be tested by the following minimal example:

  1. Configure KiCAD 6.0.5 in German
  2. Create at least two hierarchical sheets
  3. Put some parts in the sheets
  4. Do a annotation
  5. Assign some footprints in the bulk-edit fields table
  6. Delete annotation and create a new one
  7. Value, reference and Wert, Referenz are coexisting in the bulk-edit fields table which leads to data loss of some footprints and identifier problems

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.