Pcbnew window problem (MacOS)

Hi, as in this topic PCBnew got broken :frowning:
I’ve exactly the same problem. The screen is entirely gray and I tried with different projects. But the difference is that I’m on macOS and I can open the window and put in full screen.

Does anyone have any idea what the problem is?

I try to uninstall, the reinstall kicad.
I’m on MacOS 10.15.7, and I use sometimes an external screen. Until 4-5 days it always works perfectly.

Thanks :slight_smile:

Found ! The problem is solved when I change this parameter to “Legacy Toolset” or “Modern Toolset (Accelerated)”
Screenshot 2020-11-19 at 10.05.58

So what is the option which doesn’t work? Basically Fallback should work always, and Legacy is deprecated and will be removed completely in the next major version. It’s very worrying if only Legacy works, and strange if Fallback doesn’t work but Accelerated works.

So in my case, Legacy and Accelerated work. I have the gray screen with the option “Modern Toolset (Fallback)” so yes it’s strange…