Pcbnew window issue (macOS Big Sur)

Hi,
I am on macOS 11.1 (Big Sur) running KiCad 5.1.9.

I have precisely the issue described in Pcbnew window problem (MacOS) . eeschema seems to work fine, but pcbnew only shows a grey canvas. Files load fine, and even pcbnew’s 3D viewer works.

Unfortunately, the solution posted in the post linked above does not apply to me as the selection between Accelerated, Fallback and Legacy seems to have been removed.

Before upgrading to 5.1.9, I was on 5.1.0 which exhibited the same issue. The problem only came up when I upgraded from Catalina to Big Sur.

Is there currently a solution to this issue? Thanks for your help!

Just tested again on 5.1.0. Modern Toolset (Accelerated) and Legacy Toolset both work fine. Modern Toolset (Fallback) doesn’t work (i.e. leads to a grey canvas), and was selected by default.

This still doesn’t solve the issue on 5.1.9, though. It seems that macOS 11.1 makes the toolset default to Fallback, which doesn’t work and can’t be changed manually (at least I haven’t discovered the option yet).

You should still be able to select accelerated toolset in 5.1.9. Maybe it moved in the mac menu?

@JeffYoung Do you remember?

The fallback canvas hasn’t worked for some time on Mac, but I’d be very surprised if it was the default.

We removed the switch at some point (since it didn’t work anyway), but I’m pretty sure that’s in 5.99. I could be wrong, though…