One aspect of the Footprint Editor is confusing me [SOLVED] and [SOLVED a better way!]

50mil (1.27mm) grid with the pins on a 100mil (2.54mm) pitch and the top row is offset by 1.27mm. Need to check the hole size necessary.

Try measuring it with a micrometer.

Thank you, John, but as I stated… Placing the pads is not a problem. Getting rid of that background image afterward is what’s throwing me.

I managed to edit the .kicad_mod file with a text editor and removed all F.Silk blocks.

Odd thing, though…
I saved the edited file with the same name as the original, then re-loaded the footprint.
Just like before, all pads were no longer there, and the F.Silk image remained. I then saved the edited file as a different file name, loaded it, and the pads were there and the F.Silk was not. Footprint editor must be reloading itself from cache instead of reloading the actual changed file.


I think I may have found a possible situation. I was only able to do this in the OpenGL canvas (well, I didn’t try Cairo…)

Turn off the copper layers. Now window selecting will grab the silkscreen graphic but not the pads. Select it all and press delete. Hold on… By just turning off the front copper this also works. I can’t select the pads if only front copper is off. I can select the pads if only back copper is off. (Stable 4.0.6 Win64)

I was trying this in the default canvas. Copper layers cannot be selected there.

I believe the standard KiCAD installation includes project templates for several of the Arduino boards. Look in {KiCAD_Installation_Directory}\share\kicad\template

If this is a version of the Arduino Pro Mini, those pins are probably NOT on a 50 mil grid. Furthermore, the Arduino Pro Mini modules you get from various manufacturers are NOT mechanically interchangeable due to footprint variations. See threads at Help with importing arduino pro mini, and Meanwell LDD700h schematics and at Arduino Blank Shield Available?


1 Like

Yes, Dale, you are absolutely correct.

This board is from DFRobot (I bought 3 of them). They are not the same as the true Arduino boards, and the ProMini template included with KiCad is not a match.

Just loads of fun !!

Well, OF COURSE I am correct!! That, and my humility, are my best qualities!


1 Like

He’s not conceited… He’s CONVINCED !!

1 Like

Ok… Solved.

It required hand-editing the .kicad_mod file and saving it as a different file name, loading it into the footprint editor, and over-writing the original file from there:

For those that suggested using the ProMini template that is packaged with KiCad, if you’ll take a good look at it, it’s only a board outline with pin headers… It’s not a true footprint.

Now… How do I change the title of this to “solved” ??

The only problem I have there is how do you know if the model is mechanically accurate? It might be better to nag DFRobot to provide mechanical drawings so there is no confusion.

Hi, cbernado.

I somewhat agree with you. All the information available on it is here, about halfway down the page. All I could go by was the board dimensions. I’ll just have to print it out and see if the pads line up.


By the way…

Here’s my first attempt at wiring one by hand. It was successful, but I’d really rather not have to go down that time-consuming path again.

I also did a footprint for Arduino Mini, they are a bit of a nightmare, lots of different versions. The ebay ones I bought have a second set of 4 pads.

Is that I2C or SPI broken out separately ?


Each manufacturer’s Arduinos are a bit different. On one hand, it’s what’s good about Open Source… With a working schematic, they can lay out the boards any way they want. On the other hand, it basically requires a different footprint for each manufacturer, and that can also vary with each version they release.

Ah sorry, my brain wasn’t working, I remember what happened now, I found two types of boards, so I did a footprint to cater for both types. The “second set” is actually A4,A5,A6,A7 in an alternative place.

Type 1

Type 2

There are almost too many variations to catalog!

Exactly. That top one is a Sparkfun board. Bottom one China ?

Most of the Chinese seem to copy one of the Sparkfun variants.

I think the second is marked “Baite”, not sure whether they are designer or just add the brand. Of course, there are now copies of that board…


Anyway, we’ve drifted off-topic here. Trying to get back to the original topic…

It just strikes me as odd that the footprint editor doesn’t seem to allow direct manipulation of an item created with bitmap2component… Can’t directly select it, rotate it, move it, delete it… Or at least I didn’t find a way.