Where are the D-SUB DB9 gone?


#1

Hi all,

I can’t find any DB9 connector in the last libraries nor any footprint…

Where are they gone ? Or am i missing something ?

Thanks,


How do you search for a footprint in Ver 5
#2

I would assume you search for these?

The symbols are in conn.lib Example: DB15_Female at line 29672


#3

Yes, sorry…
I have them in the library but can’t find any footprint or 3d package…

Thanks,


#4

Just run the fp-lib wizard found in pcb_new.

  • add github lib (choose save local copy if you want the lib to be local otherwise don’t)
  • select connectors_dsub in the list of suggestions (or select all)
  • finish dialog and select add to global table at the last page

#5

Thanks !

You made my day !!
I have to dig a bit more into the library usage, i’m a bit confused with it.

Cheers,


#6

Everybody is.
The current system is a bit messed up. But it will get better. (v5 will at least have a similar system for symbols and for footprints. And hopefully something better than the github plugin will be used as the default option for footprints.)


#7

Hello!
I try to add this library using the option “Add Footprint libraries wizard” but there is no Footprints to add. What can I do to solve it? Thanks you!


#8

I have found that I have the DB footprint libraries in /usr/share/Kicad/modules, but when I try to load the footprint libraries in “Library Browser” they don’t appear.

Do I have something wrong configured?


#9

You might need to tell us which version of Kicad you are using and what OS. If it doesn’t show up you may need to use the ‘wizard’ to add it to the project.


#10

Could you show us the fp-lib-table line corresponding to the Connectors lib? (pcb_new->preferences->footprint library manager. Search this for the entry for the Connectors lib)

If you have kicad setup in the default manner, then i would guess it will use on demand github libs via the github plugin. Not local libs. (so simply copying stuff into the local .pretty directory will not add them to your installation.)

Also: Do not modify kicad system libs!!! Use your personal libs for that.
(The system libs are located in write protected system directories for a reason.)


I am also a bit confused why you would add these footprints to some random system lib instead of simply adding the complete Connectors_DSUB lib via the library manager or wizard.


#11

Hi everybody and thanks for the soon answer. My kicad version is:

Version: 4.0.7+e2-6376~58~ubuntu16.04.1
wxWidgets 3.0.2 Unicode and Boost 1.58.0
Platform: Linux 4.4.0-104-generic x86_64, 64 bit

And my fp-lib-table is: (only the connectors)
(fp_lib_table

 (lib (name Connectors_Harwin)(type Github)(uri ${KIGITHUB}/Connectors_Harwin.pretty)(options "")(descr "Harwin connector footprints www.harwin.com"))
  (lib (name Connectors_Hirose)(type Github)(uri ${KIGITHUB}/Connectors_Hirose.pretty)(options "")(descr "Hirose connector footprints www.hirose.com"))
  (lib (name Connectors_JAE)(type Github)(uri ${KIGITHUB}/Connectors_JAE.pretty)(options "")(descr "JAE connector footprints http://www.jae.com/jccom/en/connectors"))
  (lib (name Connectors_JST)(type Github)(uri ${KIGITHUB}/Connectors_JST.pretty)(options "")(descr "JST connector footprints www.jst.com"))
  (lib (name Connectors_Mini-Universal)(type Github)(uri ${KIGITHUB}/Connectors_Mini-Universal.pretty)(options "")(descr Mate-N-Lok))
  (lib (name Connectors_Molex)(type Github)(uri ${KIGITHUB}/Connectors_Molex.pretty)(options "")(descr "Molex connector foottprints www.molex.com"))
  (lib (name Connectors_Multicomp)(type Github)(uri ${KIGITHUB}/Connectors_Multicomp.pretty)(options "")(descr "Multicomp connector footprints"))
  (lib (name Connectors_Phoenix)(type Github)(uri ${KIGITHUB}/Connectors_Phoenix.pretty)(options "")(descr "Phoenix connector footprints"))
  (lib (name Connectors_Samtec)(type Github)(uri ${KIGITHUB}/Connectors_Samtec.pretty)(options "")(descr "Samtec connector footprints"))
  (lib (name Connectors_TE-Connectivity)(type Github)(uri ${KIGITHUB}/Connectors_TE-Connectivity.pretty)(options "")(descr "TE Connectivity connector footprints www.te.com"))
  (lib (name Connectors_Terminal_Blocks)(type Github)(uri ${KIGITHUB}/Connectors_Terminal_Blocks.pretty)(options "")(descr "Terminal block connectors"))
  (lib (name Connectors_WAGO)(type Github)(uri ${KIGITHUB}/Connectors_WAGO.pretty)(options "")(descr "WAGO connector footprints www.wago.com"))
  (lib (name Connectors)(type Github)(uri ${KIGITHUB}/Connectors.pretty)(options "")(descr "Assorted connector footprints"))

I don’t know why I can see the DB conectors by default, but I solve it creating a new pcb library.
I copied all the “DB*.Kicad_mod” files from the folder “/usr/share/kicad/modules/Connectors.pretty” to a new folder and I added the folder in “pcb_new->preferences->footprint library manager”. et Voila! I can see the DB pcb conectors!


#12

You can not see stuff you added to the original lib because it was never added according to your fp lib table.

The clue is in:
(lib (name Connectors)(type Github)(uri ${KIGITHUB}/Connectors.pretty)(options “”)(descr “Assorted connector footprints”))

This means kicad does not use local files for this library but downloads it directly from github on demand. (It is not stored on disk. At least not permanently. The downloaded footprints are lost once you close kicad.)


I would suggest you follow this new FAQ entry to install the library of version 4.0.7 instead of using the github plugin.


#13

Then, it means that in the github libraries there is not DB connectors? Why I can see the rest of the components?


#14

One more time. It is a separate library! (Connectors_DSub)
I linked the library in my first response of this tread!

To add it with the library manager as a github lib do the following:

  • open the library wizard (found in pcb_new preferences menu)
  • select github library (if you want it locally, select save local copy too and give a location where you have write access)
  • press next
  • you will be presented with a list of possible libs. Scroll down until you find the lib called Connectors_DSub
  • click on the empty square next to it (it should get ticked)
  • press next and await the result of the validation process. (This lib should be valid for all kicad 4 versions)
  • press next
  • select global (I don’t remember the exact wording. but the options are global or local)
  • press finish

If this does not work then there might be a problem with your internet connection. Follow the instructions i gave in the post you answered.


#15

Hi Rene!
I had done all of this, but in the fourth step there is no list of possible libs, it is just empty.

Are you sure that the link is https://github.com/KiCad/Connectors_DSub.pretty?


#16

Did you ensure that the url field was filled with https://github.com/KiCad?
Are you behind a proxy? (The github plugin does not seem to work with a proxy)

Yes. It should link you to an archived repository that holds the old version 4 library.
The download link is found under the green button with the text Clone or download. (Like with all github repos)

Can you reach any github repository? If not you have some problem with your internet setup. (Maybe some it guy setup a filter wrong. Or there is a problem between your country of origin and the location of the github servers.)

(Other download links are in the FAQ post i linked yesterday)


Alternatively you can download the newer lib intended for kicad 5 here:
https://kicad.github.io/footprints/Connector_Dsub
This lib is not guaranteed to work with version 4


#17

I’m not behind a proxy because I can access without problems to github and download the file manually.
In my computer the “library wizard” doesn’t work with any githuh link. But l will try Kicad in the windows partition to ensure my answer.


#18

Your kicad version might be compiled without github support.


#19

That doesn’t prove you are not behind a proxy, since web browsers can detect the proxy automatically.

What is the error? I bet it is “Error (7): couldn’t connect to host”


#20

My compiled version of Kicad:
Application: kicad
Version: 4.0.7-e2-6376~58~ubuntu16.04.1 release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.4.0,wx containers,compatible with 2.8)
Platform: Linux 4.4.0-104-generic x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.58.0
Curl version: libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
USE_FP_LIB_TABLE=HARD_CODED_ON
BUILD_GITHUB_PLUGIN=ON

Doesn’t work means that there is no lib to choose.
But I can see the library components ( and select it) in a windows version of Kicad