Unable to import graphic file

I’m getting ‘no images found in file’. It worked well enough in an earlier release. I’m using 5.1.1 (latest in Fedora stable repo).

What I’ve done - simplified the object and exported from Freecad (file attached). Ran it through Librecad and exported as R12 (also tried all the others). Outcome is always the same.

from_freecad.dxf (15.9 KB) from_librecad.dxf (1.7 KB) Untitled

Could you add this information (including the files) to https://gitlab.com/kicad/code/kicad/-/issues/2614 ? However, you should test the files with the latest KiCad version if at all possible.

Fedora 30/31/32 all have the most recent version 5.1.5 available if you do an update.

1 Like

Have done. Same with 5.1.5. :frowning:

Unsure how I can measure the PCB size at present.

If you are already using freecad then you can use stepup to directly push your board outline to a pcb file. Kicad StepUp: The Sketcher for Getting to Blinky

1 Like

The same error on 5.1.6rc1 for Windows 64 bit

The issue is with the contents. If I add my drawings to the same file, KiCad imports my drawings without issues.
LO Draw does not like this file either.

You forgot to explode the dxf and save it exploded…
Here a link to the manual (search to DXF)

  1. Open a copy of the DXF file.
  2. Select the board shape (selected shapes are shown with dashed lines).
  3. In the Modify menu, select Explode .
  4. Press ENTER.
  5. In the File menu, use Save As…​
  6. In the Save Drawing As dialog, there is a Save as type: selection near the bottom of the dialog. Select the option Drawing Exchange DXF R12 .
  7. Optionally enter a file name in the File name: field.
  8. Click Save

Your DXF file is now ready for import into KiCad.
Importing the DXF file into KiCad

KiCAD ATM cannot import DXF shapes not exploded to simple entities.
You could open an issue at gitlab


Ah, the old KiCad does not support DXF polylines feature

the same for kicad 5.99

Exploding the file allows import, so it must be polylines
I commented to the bug report that @eelik gave

1 Like

this has been ‘warp speed’ fixed by Charras


I added to the gitlab page referenced earlier.

Kicad should come up with a meaningful error then, not just say that ‘nothing is there’.

Exactly. It’s really confusing and it makes it harder to fix when we aren’t sure of what really is the issue.

Fixed in the latest 5.1 Testing (5.1.6rc1-3).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.