(Solved) - As of yet undefined CvPCB trouble

How to cure the “cvpcb” which “hangs” or gives “errors” when run. U had written these two points below:-

  1. In KiCAD project module, change Module and 3DShape path under preferences.
  2. In EEschema/SymbolEditor remove all libraries under preferences.

Now kindly. also explain, the above 1st. point: As when I click on menu > preference > the “name” and “Path” box is displayed. It shows “four names” & paths: 1. KICAD_PTEMPLATES… 2. KIGTUB 3. KISYS3DMOD 4. KISYSMOD
There is an “ADD button”, a “DELETE button” & an “OK button”. There is no “change path button”.but I suppose a path when clicked gets highlighted and selected. I hope I am on the correct box here.
Now which path to select, & which button to click, to make a change in path?

& in your 2nd. point above: When I click on “preference” then “component library” option is seen next. & when I click on that, the “list of library” box appears, which has “ADD” & “REMOVE” buttons, and also some “three paths” are shown in the lower part (“current search path”) of this dialogue box. So what to do with these 3-paths? Do I select each path and click “REMOVE” button? & then the OK button?

So, Pl. also help me remove this trouble above, as when I run “cvpcb”, the program takes a long time to open up, and usually it “hangs”, or shows errors after searching for a long time. My net connection is OK also, though not very fast at times, here in this, a bit backward country.
Thank you for giving Ur precious time to me in this regard.

Can you please post a link to the topic ‘that is now closed?’ in question please?

under each post are these icons:
click on the chain, copy the link and post it here please

Next thing, to help you correctly, what EXACT problem do you have with CvPCB?
Can you please post a copy of the error message?

Also, so we know what you got in front of you - as KiCAD varies a bit over versions and systems - can you please go here and copy&paste the KiCAD version info for us to read please?

(the button circled in green might not actually exist in your KiCAD version)

Overall your description sounds like you have problems with the github online library setup and rather want to run local copies of the libraries.
@bobc had a topic linked somewhere about the steps to do that and will surely chime in pretty soon.

1 Like

He has a wiki entry in his fork of the kicad documentation on github that describes exactly this:

1 Like

That above is the “link” to the closed thread, dealing with cvpcb problems.

My specific problem is: When I run “cvpcb” the KiCad hangs, & after a long time, when I try to close it, the top Title bar says “KiCad.exe (not responding)”.

(this happens, even though, I have performed Annotate, ERC check is ok, & net-list is also generated)

It seems to me, that KiCad is searching the net for all the libraries in the world, but it is still not being able to find any. It could be a previous path left there, that leads it to nothing. :Please help. Thanks.

Open PCBnew and in there click on

Preferences>Footprint Libraries Manager

Then take a screenshot of that window (in windows: [Ctrl]+[PrintScreen]) and paste it into the reply box on this forum please [Ctrl]+[V]…

Also, you didn’t tell us your KiCAD version yet.
The ‘KiCad.exe (not responding)’ tells me you’re on windows though…

1 Like

Again what kicad version are you using?

Have you ever opened the footprint editor or pcb_new? If not try that because i think opening these programms for the first time triggers the setup of the footprint library table. (I’m not sure if opening cvpcb triggers this settup.)
Can you reach github in your browser while your problem occurs?
What is the content of your footprint library table? (go to pcb_new: preferences->footprint library manager and have a look)
Can you open any footprint using the footprint editor?

Just in case a bit of information on how kicad handles footprints (compared to how symbols are handled):
How are symbol libs handled?
As you might already know symbols are “installed” during the installation of kicad. This means you have all symbols stored locally. (somewhere in the kicad installation directory. In linux under /usr/share/kicad/…)
What symbol libraries are available is decided by the project settings. When creating a new project the standard template is used for this project. (Adding symbol libs permanently needs to be done in this template project. It is also located in the installation directory)

How are footprint libs handled?
Footprint libraries are not installed on your computer. (At least not out of the box)
The footprint libraries are downloaded every time kicad needs them. (This happens when opening cvpcb, the footprint editor, importing a netlist with new footprints in pcb_new, …)
What footprints are available is decided by the footprint library tables. There is a global library table situated in your user profile. (linux: ~/.config/kicad/)
If your project is setup this way it also uses a local library table located in the project folder. (Again not if you do not tell kicad that you want this.)

1 Like

My KiCad version is: “KiCad 4.0.6”

Brief History may help you to locate the trouble:-
I switched over to KiCad from Eagle, only a month or so back. But still, I have made two PCB’s in KiCad since then, with the (PCB new) with full copper pour & I even converted pcb design to a PDF file. Then I got the PDF design printed on glossy “Toner Paper” via a Laser printer, and then transferred the pcb design on a copper clad board, & using a heated electric iron, and so I made about two PCB’s at home, which I also assembled and are working fine.

But, the problem started, now, after I had made a “new local library”, and put my new created component in it. And this, my new component, also was seen in the component device library. Then I also make my own new relay “foot-print” & put it in the footprint library. I could also see it there with its 3D view etc. very nicely, & also edited it to a few times, to make it perfect.

But then, after all this success, the “cvpcb” started mis-behaving, and not opening & causing the KiCad.exe to hang (not respond) - this message started coming often. Twice I also “uninstalled” KiCad" and all my project KiCad files were also deleted. KiCad was down loaded again fresh, same version 4.0.6,

Because once, the error had showed “my new library” name, as an error.in the list of errors. So I thought that I must Uninstall and again download KiCad, which will set the KiCad library as it was at default, and my error giving library will be removed from KiCad.

But to my horror and amazement,… I still found my “new created component” very much there in the component library…! Only my new “footprint” was not found again in the footprint library.

But after even this, once I fiddled with the “path dialogue box” on the launcher window under preferences, and then, also did something on the eeschema by clicking the paths under the dialogue box that comes after “preferences”, and I clicked “REMOVE” button there.

Then, after this, my “cvpcb” again worked (though it took 3 minutes to load my list). But I am not sure what I really did in those 2-dialogue boxes as given above. So I am not sure what to exactly to do next time when this problem comes back?

So in light of the above actions, please help Sir.

Thank you for precious reply & enquiry.
My KiCad version is: “KiCad 4.0.6”

Sir you asked: (“Have you ever opened the footprint editor or pcb_new? If not try that because i think opening these programs for the first time triggers the setup of the footprint library table. (I’m not sure if opening cvpcb triggers this setup.)…”

Yes Sir,… I have done plenty. You can perhaps see the “DETAILS” of my “actions” as written in my reply to Sir “Joan_Sparky”, - that may give you an idea of where I might have created a bad path, or changed the default library, so now it goes out of sync, when “cvpcb” is run.

Sir, that is my pcb library table, it seems different than yours?

Sir, Joan_Sparky,

Yes, You are right I am on windows 7, and I noticed that in your library table, the “plugin type” column shows “KiCad”
But in my library table, the “plugin type” shows “Github”. Does that mean my component has to be fetched from the net every time, and it is not there on my computer with KiCad? Or, simply the path is wrong?

Yes your libs are fetched from github everytime.
Read the explanation by @bobc on how to setup the footprint libs as local. (I already posted the link above, but to make it easy here it is again.)

I’m not sure if the plugin type will change but the path should not start with $KIGITHUB for local libs.

Thanks. Yes, it is must be a lot better & faster, if I put the footprint libs as local.
I think, we may be closing-in to my “cvpcb” hanging problem? As the problem seems
to be related to “footprints” that are far away on github, & a slow net may add to this trouble.

About the only way to find why cvpcb is hanging is to wait and see what error messages are produced.


Yes, but lately, the hanging continued for over 10 minutes, & so no error list was seen. But once before, I did happen to see the “name” of my newly created library, which appeared as one of the cause of the errors.
So that is how I know this cvpcb trouble could still be related to the library.

Try to remove your library from the fp-lib-table and test if this solves the problem. If not, the problem is with the online libs.

So leave it running, go away and come back later? Overnight? If you suspect a specific library, then remove that library and see if you still get the hang.

@Rene_Poschl, - OK, Thanks, I will delete the lib. and see.

@bobc , - ok, next time I will leave it for longer time, & see if the “error list” is produced.

However, FIRST: I had clicked on the “path box” that comes after “preferences” in launch window. & perhaps that had changed the path (I’m not sure what I really did there).

SECOND: In “eeschema”, under “preferences” I had also clicked on the “component library” & in that
ADD / REMOVE dialogue box, I had clicked on each of the “current search path” that were visible there, & then each time also I had clicked on “remove button”

:airplane: - Joan_Sparky , - The above two steps I had found in your post (that thread is now closed). That temporarily stopped the hanging problem, but I did it w/o
understanding. So next time, this problem re-occurs, I may not get it right.
So, if you remember, and can give these two steps in more details, I
would be happy to add that to my KiCad “error solving list”. Thanks.

[quote=“explore, post:18, topic:6163”]
That temporarily stopped the hanging problem, but I did it w/o understanding. So next time, this problem re-occurs, I may not get it right.[/quote]

It might have stopped the symptoms, but not solved anything.

Please go to this location with the file browser…


Then copy/paste the fp-lib-table file (has no extension) into the answer box here or into a private message to me.
Your file looks pretty bloated and you probably want an offline setup anyway.
I’ll get you through the steps to set up your system as I have mine - if you want to that is?.

Do you have just that one C: harddrive in your computer or is there something like a drive/partition (like D: or E:) where you store user data on?

1 Like

Besides C: drive, I also have New Volume (E:) (where I store large extra files / videos etc., actually a “partition” was done in the hard disk when windows was installed, & so an extra (E:) drive was produced to keep important data from being lost in case of C: drive crash)
I have Windows 8, on my “hp make Laptop”.

But I’m afraid to say: I find no way to browse and get to the the “fv-lib-table” file.
I can only reach this (Library Tables by Scope), via “pcb new” .> preferences > footprint library manager > (pcb library table opens) (via KiCad).

If I use file explorer & go thru’ (C:) > Users > hp > (I end up here, as now I can’t find “AppData\Roaming” (so “kicad\fp-lib-table” folders are also not found either, by this method)

This above, is searching thru’ folders in C: drive.

I don’t think I have ever seen a “file browser” as such, except like when, the program / or KiCad itself produces a browser, then it works fine, and then I can browse to any file. Please advise what is wrong here?