Program freezes - virtual VM Hyper-V

Hi, I have installed the Kicad on virtual machine, seems it works, it opens a project, but when I tend to open for example schematic file, it keeps loading forever - freezes. Is there a way how to make it work under virtual enviroment (OS Server 2012, VM virtualized in Hyper-V Win 2012) …I wanted to publish this great app through Remote apps to our virtual terminal , but it keeps freezing. GPU in server is not present, as most of the programms could not use the synthetic driver provided through Hyper-V virtual enviroment anyway.We are using other GPU intensive software, and it works just fine in this scenario, hope this Kicad can too.

KiCad isn’t very GPU intensive. You can try switching to non-GPU-accelerated canvas, see e.g. PCBNEW shows only white screen then eventually Shows as not responding and Eeschema not responding when opening Schematicac.

Hi, thanks. Just to clarify : PCB design App works OK, the only part that doesnt work is Schematic design App. No matter if I open file, or if I click open empty schematic app…always it freezes. I could not find any file named “eeshema” on location " \AppData\Roaming\kicad\eeschema" - however I have found the “PCBNew” file which belongs to PCB design app (this one works OK) Any idea where to find it or how to create it if really needed?

eeschema will be created the very first time that you close Eeschema, if it always crashes, it won’t be created, but it is only one text file, you can try to create one “eeschema” file yourself with only the following text line inside

canvas_type=2

then try to open Eeschema again.

1 Like

HI, thanks…did not help. still the same. I tried even run as administrator, or desable high DPI settings, or compatibility mode for all settings - no change.
any more idea?..any error log to check? windows event viewer shows only error “app hanging”.

I just packed my user settings for KiCAD v5.1.5-3 (Help->About KiCAD) if you want to give them a try, just unpack them in your %APP_DATA%/kicad directory.

kicad_v5_1_5-3_Fallback.zip (19.4 KB)

hi, thanks, , it helped. great. do you have any solution “newly connected users” in future…as this settings is to be created once the programm runs OK, I feel like the same problem will have all other users in future (the settings I have I can not share, as it is stored under my own Appdata folder)
??

Sorry I don’t know more, but maybe @Seth_h can help a bit more, AFAIK the issue is solved in the nighties and it may make it to the next stable release before v6, with which version are you testing? Maybe you could give it a shot with the nighties to see if the issue is solved for you.

Issue report in Gitlab:

Hello,

I posted a similar problem yesterday, “First Time User Cannot Open New Project” and unpacking your user settings appears to have solved my problem too! There must be a bug in KiCAD v5.1-3 on Windows (in my case the 64 bit version). I am new here, so I don’t know how to escalate this, but the problem is extremely easy to reproduce (see if my post helps) and I’d file a bug report if I knew how. Thanks again.

Hi Jake,

the post above you has a link to the bug report related to this bug, it is meant to be fixed in v5.1.6 due to be released in a couple of weeks (no fixed date yet available).

In general, if you find a bug report that affects you, you should give it a thumbs up, to add your vote to the bug report, it doesn’t guarantee that it is going to be fixed faster or at all, but it tells the developers that the is “more” interest on it, besides the reporter.

image

Glad you could solve it!