Eeschema not responding when opening Schematicac

When I go to open a schemtic from a project eeschema window opens but become non responsive and has to be force closed. All other aspects of the program will open. I have tried:
-deleting settings files
-uninstalling and re installing
-uninstalling 5.1.5_3 and installing 5.1.5_2

It is happening with all projects and the projects will load on a different machine running KiCad 5.1.5_3.

Any help would be appreciated.

Vesrion Info
Application: KiCad
Version: (5.1.5)-2, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.66.0
Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Update, I changed the canvas type in \AppData\Roaming\kicad\eeschema from 1 to 2 and it will now load. I have no idea why this fixed the issue. Is anyone able to provide some insight.

1 Like

canvas_type 1 is OpenGL. If that is not loading on your system, then there may be a driver issue. canvas_type 2 is Cairo, which is software-only so it does not have the same dependencies but it much slower.

4 Likes

I have this same issue. I’ve searched for OpenGL drivers and have only found that they are usually bundled with your drivers for video card. If there is a OpenGL standalone driver that can be used to fix this I haven’t found it. I’ve also had this issue with PCBnew.

I’m having the same problem, and I’ve looked in my \AppData\Roaming\kicad\ directory for an eeschema file with no luck. What else can I do to make the application run correctly?

Have you tried the canvas type 2 suggestion from a few post above?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.