Ngspice Simulation Error


I’m new to KiCad and ngspice, and was following this tutorail KiCad Eeschema as GUI for ngspice, tutorial for setting up the simulation and others on youtube.
I’m runing KiCad 6 on ubuntu, and although ngspice simulator works fine for the basic elements (R, C, L), when I tried to simulate an opamp I got this error:

Compatibility modes selected: ps lt
Circuit: KiCad schematic
Error on line 0 :
a$poly$e.xu1.eos %vd [ xu1.16 xu1.49 ] %vd ( xu1.7 vin ) a$poly$e.xu1.eos
MIF-ERROR - unable to find definition of model a$poly$e.xu1.eos
Background thread stopped with timeout = 0
Error: circuit not parsed.

I tried several attempts while changing opamps, using different pspice models from different manufacturers, assigning the pins’ right order in eeschema, but each time I got the same error.

Your help would be very much appreciated.

This is an installation or package bug.

Unfortunately the KiCad package is not complete to run the simulator.

Please install in addition plain ngspice. This should deliver the missing files (the code models).

Actually, I think it’s enough installing libngspice-kicad.
I don’t have ngspice installed by itself.

Maybe yes.
But see also Simulation Error - how to debug? - #6 by holger

I re-installed KiCad from this source Install on Ubuntu | KiCad EDA using the shell commands.
I could find libngspice-kicad the following folder ./usr/share/doc but I still got the same problem.
It was fixed by installing plain ngspice (sudo apt install ngspice).
Thank you very much.

Well, it could just be that this might solve some of my issues as well. I’ve installed plain ngspice now (nothing much happened, very little feedback from the installer). If you don’t get any more questions from me on the subject, it helped. :slight_smile:

Does that indicate “solved”? Didn’t know that.