New EEschema symbol library management - what a mess!


#1

So today I tried to open an older schematic, which previously was opening without any issues. It pops up Project Rescue Helper offering me to “rescue” all my “legacy” symbols by saving them with a different name. For example symbol “+5V” becomes"+5V-RESCUE_Project_Name" etc. If i choose OK the next window pops up offering to remap symbols, if i choose to do it every symbol comes back with a warning “no symbol found in symbol library table” and all symbols in the schematic become squares.

Ok, at this point I try to backpedal. I quit without saving and open it by hitting cancel in every dialog. The schematic opens normally, however every symbol is opened from the project cache. Looking into the library manager I find that all my libraries have been replaced with the default libraries and my environmental variable have been replaced as well. That’s shouldn’t be a problem to fix. I guess that’s my own fault for choosing update environmental variables when I installed a new nightly build. Anyhow, I close the EEschema, edit environmental variable KICAD_SYMBOL_DIR to point to my symbol libraries stored locally and open the schematic without rescuing and remapping. All the right libraries come up now, however all the symbols are still being loaded from cache and there is nothing I can do to make them load from the library. Another strange thing, Project Specific Libraries list all my global symbol libraries with a “1” at the end. I removed them and them after exiting EESchema without saving and loading the schematic again Project Specific Libraries tab remained empty.

Any ideas on how to deal with this royal mess and rescue the schematic?


#2

See Wayne Stambaugh last comment.


#3

The Curse of the Nightly Build strikes again!


#4

This comes with the territory. That’s the purpose of the nightly builds, to help find bugs. I’m ok with it. It just seems that the whole library manager is kind of raw to be included into the build. I just discovered that you can’t really edit any of the symbols which are loaded from the cache. Gives an error: “Error occured loading symbol “XXXX” from library “”. sym-lib-table files contain no library with nickname”" " Seems like somebody jumped the gun on this long overdue manager. We’ve been waiting years for a new library manager. We could’ve waited a bit more.


#5

Nope! That is the point of nightly builds. They are test builds. For testing.

Right, so wait for the next stable release…


#6

Which part of my statement are you finding disagreeable? You don’t think it is raw or you think that raw and unfinished code should be included in the build?

They are not builds to test if it is going to build. It is build to test functionality. Nobody is going to be using nightly builds if they just turn into a “stream of consciousness”


#7

Yes of course. How else will the code get beta tested? Nightly builds are test builds for beta testing. They are not releases.

I can’t parse that…


#8

Well, I rest my case then. It doesn’t have to be a release to possess a certain level of functionality to qualify for beta testing.


#9

Nightly build users are software testers. (Maybe this should be made more clear on the download pages.)
Sometimes you are late stage testers. This is the case if there have not been large features added for a long time.
Recently a lot of new large features have been added. These features have not yet seen a lot of testing by normal KiCad users. This means the developers have not had a lot of feedback on them.


Your input is valuable to the further development of kicad. But it should be done on the appropriate channels and using respectful language.

This means please post bug reports over at the bug tracker. Try to include as much information as possible.

  • Include a detailed explanation what you think is wrong.
  • Include your version information. (and operating system)
  • If you found a bug maybe attach a minimal project that demonstrates it.
    • In your case the project before remapping started.
    • Explain what steps are necessary to get the same result as you got. (How can your bug be reproduced in a reliable manner.)
    • Make sure there is not a newer nightly version out there that could have already fixed your bug.
  • If you have suggestions on how to make the user interface better include modified screenshots that showcase what you think would be a better solution.
  • And maybe choose a title that is a bit less provocative. (I understand the need for ranting. But a discussion is easily derailed if somebody feels attacked.) Instead it should describe the problem at hand in a short way.

I guess there are already similar bugs reported over at the bugtracker.
If this is the case, don’t open a new bug report. Add your voice to the old bug report. (Add more information if you think this will help the developers. Otherwise simply click: affects me as well.)

Today wayne also merged a major fix for a problem with windows nightly builds. (It seems windows nightlies did have a major bug that screwed up projects when remapping.)


Another tip for nightly users: Follow the mailing list. Read every blog post. Follow the bug tracker. (This allows you to gauge if it is a good idea to install the current nightly build version.)


#10

Thank you for the primer on submitting bug reports. The purpose of this thread however is not to bring a bug to anybody’s attention. I just needed opinions on how I can open my schematic with symbols loading from my actual library and not from the cache.

From what I’ve seen so far the problems (plural) with the symbol manager go beyond “screwed up projects when remapping”. I will wait for the next build to draw conclusion, but right now there is not a single bug report that could describe all the issues I’m seeing. All I could report, if I was reporting anything, would be that it needs more work.


#12

That’s easy, just edit the files. Since this bug has literally just happened, very few people are likely to have a canned solution. If anything, you should be finding the fix and telling us.


#13

Schematic? By hand? Why didn’t I think about it?! Who needs EEschema when you’ve got the Notepad!

Besides the files are fine, it is the EEschema that’s can’t process the symbols properly.

How literal are you? When was this bug actually introduced? Currently I’m using a nightly build from Dec 26th.


#14

Ok so now you’re the expert, you tell us how you fixed it:) We can’t wave a magic wand and fix the code for you!

I think you are not really asking for help, you just want to rant a little about the state of KiCad, which seems to be the main reason you post here. You seem to be quite impervious to practical advice.


#15

If it is the bug that was fixed today, then it was introduced within the last few days. If it is something else it might be there a bit longer. (The longest it can be in nightly is the day sym lib stuff has been merged.)

To determine that we would need a bit more details about your exact workflow, your project setup, …
Most importantly:

  • Is the cache lib valid. (Are all used symbols in this lib?)
  • Are all symbols that are used in the schematic in the libs that are available to the current version of kicad. (Are they in the libs that are in the symbol lib.)
  • If you have a backup from before you tried to remap the schematic. You can try to open it with the stable version. Does it ask you to rescue anything? Are any symbols replaced by a question mark? Does the cache lib change if you save the schematic without adding a new symbol?

#16

I’m sorry, my bad! I thought you were making an attempt at humor. The practicality of your advice haven’t quite settled in. Ok, serious now. I don’t know what kind of schematics you are dealing with (if any at all), but my BOM is several hundreds of distinct components.

Now I don’t think you really need to be an expert to come to a conclusion that there might be something wrong with the current version of the software, seeing that the schematic opens just fine with a previous version of the same software.

You might be on to something here. I was really asking for help… preferably from somebody who’s got something …well practical to say on the subject, not just claim that it is practical. Hope you can parse that.


#17

It is like you guys don’t even bother to read the original post


#18

The real cause of this is that the Windows build server was out of action for some time and therefore software changes were not tested properly on Windows.


#19

I tested the conversion taking the advice in the announcement thread into account to make good preparations and had this working with 100% success and all my libraries (including older versions of the projects) converted in early December. Although we had had the problems with the certificates, and another temporary lapse, there has been no reason not to be able to test this in a safe VM if one really wanted to, we have had almost a month now, although one of course could have wished for more time (I did not think about retesting this before now with all the problem reports coming in).

Yes, right now at least the last nightly has the conversion broken, and one should not try to convert, but a fix has already been announced and should be available to test already late tonight (I am on GMT-9 time zone in Alaska) according to @stambaughw.

@ArtG, there might be one other thing that is messing things up for you: There was mention that you had accidentally installed the system environmental variables. (By my opinion these should not have been checked as default in the installer as they are intended for the developers to make it easy to test things and will override the settings in the paths menu. I have accidentally forgot to uncheck these several times and had to clean up.)

You might already know this, I mention it anyway: The problem is that it is hard to clean up after this; a reinstall with these unchecked does not work alone: If using Windows, you need to first get into the registry, search for the path to the KiCad shared folder in the program folder (typically “C:\Program Files\KiCad\share” for a 64-bit Windows version) and delete all the system environment variable entries in the registry belonging to KiCad.*[Edit: It safer to use the Control Panel, or right click Computer-Properties to delete environment variables, see details further down the thread for directions] Then restart the computer. I have also then made another KiCad install with environment variables unchecked just to be sure, but I am not sure that is needed.

This is likely not the solution to all problems, but if it is overriding your settings, pointing KiCad to different paths than you specified under Configure Paths, it is certainly one thing that has to fixed.


#20

It’s a shame this thread has so much of people sniping at each other because there are lots of valid points on both sides. We should all probably aim to be a bit less needlessly harsh-tongued while trying to help each other. Titling the thread “what a mess” probably wasn’t the best start though, to be honest.


#21

I agree, so I changed the title to something a bit more positive.
Finding bugs and helping the developers get it right is the way forward