Library symbol loses reference after a nightly version update


#1

Hello,

After updating the nightly version of kicad I’ve came across a slight problem while working with eschema, after a few crashes after saving and preforming a few operation with it it suddenly lost reference of all the symbols after trying various version of the software and can’t get out of it here is the result:


New EEschema symbol library management - what a mess!
#2

I believe it’s the discussed issue on the dev mail list with the symbol remapping. Can you please post your .pro file?


#3

Were there solutions for that?


#4

I assume something went wrong during the remap process. The process that converts old schematics (version 4) to the new style where the symbol lib name is included in the symbol reference (version 5).

If you have a backup you might want to have another go at the remapping process. Maybe read the explanation by the developer:


#5

It seems the symbol remapping has some serious issues and is causing a lot of people problems. I would exercise extra cause when using nightly builds. For example, just opening a project to view it can cause the .pro file to be written and the project corrupted, even if you cancel the remapping.

I expect the problems will get resolved, but it’s inevitable with any large code or interface change that it takes some time to find and fix all the corner cases. (Which is why my estimates for release dates err on the side of later rather than sooner).


#6

I found that the file sym-lib-table in C:\Users\Me\AppData\Roaming\kicad\ was getting wiped


#7

There is a bug that was introduced recently which broke the remapping on windows builds. I just pushed the fix for this so it should be available shortly in the daily builds. Sorry about the issues.


#8

Anyway untill this gets fixed it realy seems to corrupt over sketches the same way no matter what and as for the current situation is there anything to do with this broken schematic if I don’t have any backup for it? In other words could it be fixed?

Thanks.


#9

Backups of the original files are make with a .v4 extension in the project folder so you should be able to rename (remove the .v4) these files to get back to where you started.


#10

@stambaughw , I noticed this last night (2018-01-02 revision b1b3a89f7) when testing some projects backup versions that previously was prepared for conversion and subsequently converted with 100% success; when tested now I had 0% success. I was prepared to confirm and try to pinpoint the appearance of this bug before reporting it today, so your message saved me some work. Is there a bug# we can use to report confirmation that the fix works? I have some good test cases I can try with the next nightly.

The description of my previously successful conversion procedure that was based on your initial recommendations was posted here:

I should add that all the projects I previously converted on that occasion are still working very well this far, and since I then in an attack of perfectionism also converted all the older project versions - thus I do not have anything that is not converted (except for the pre-conversion backups of everything that can be used as test cases) I am personally still a happy camper.


#11

Now I am seeing all the libraries going missing on the latest Ubuntu PPA, the version copy for reporting doesn’t work either

edit there is now an new empty sym-table-lib file in my test project directory. Other projects don’t have it.
Anybody know where this file normally lives in Ubuntu?


#12

I would guess it might live at the same place where the global fp-lib-table would go. So ~/.config/kicad/ (The one in your project dir might be simply the local sym lib table)


#13

Any chance of a more comprehensive summary of what fp-lib-table, sym-lib-table etc do and where their default locations are in various OS?
I suspect we will be getting a lot of questions about this in the next few weeks


#14

fp-lib-table is mentioned in http://docs.kicad-pcb.org/stable/en/pcbnew.html#_managing_footprint_libraries_pretty_repositories. Since sym-lib-table is new, it is not documented yet but I guess it follows the same pattern.


#15

@stambaughw, I just tried these test cases in the new nightly (2018-01-03 revision 0945c319f, installer name kicad-r9078.b1b3a89f7-x86_64.exe), and the conversion is 100% successful again. I tried both type of prepared projects as under 1. and 2. in the link I provided in my post (both only local or global libraries) . Thanks so much for the fix. Let me know if this should somehow be reported on the bug tracker (I have not found a recent bug report yet that fits specifically to this problem). None of these projects had broken library links before conversion, so no rescue dialog came up, just the remapping that executed without errors.


#16

I’ve tried the mapping process of the corrupted schematic with the Dec 5 version and Dec 3 version and this still can’t remap the symbols properly just showing lots of symbol not found errors in the process also tried the back .v4 thing and it seemed to be also corrupted.


#17

Do you have a clean backup to test if the original problem is solved? (Meaning does a clean project still get corrupted by your workflow?)


#18

Yes other clean projects still get corrupted.


#19

It even happens in todays version but now it manages to map all other non corrupted projects


#20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.