macOS Catalina Installation

It seems KiCAD and macOS is still a bit on the rough side. I attempted an install about 6 mos ago, but it was so dysfunctional I left it & installed on my Ubuntu system. That worked OK, but now my Ubuntu system is down for a motherboard issue. So - I’ve been trying the installation again.

I finally got past the initial roadblocks w/ Apple’s security & privacy, and then the strange end-around dragging the ‘kicad’ folder to ~/Library folder in a new tab in Finder. KiCAD actually starts now, but gives this dialog:

There was another answer here that didn’t help:

Which file or folder am I looking for exactly??? The default choice is greyed out for some unknown reason (did I do something wrong??), and the dialog nor the referenced answer give any clues about where or what this “global symbol library table file” is. Can someone explain this? - or clarify the opaque options here?

And why is this dialog designed to “lock” my system up such that I must summon “Activity Monitor” to “Force Quit” the app?!? That’s not right…

If my question sounds a bit “short”, please forgive me. I should say that I expect non-Apple apps to have all sorts of installation issues - because Apple sucks at openness (and other things). Nevertheless, the KiCAD install seems to be the most obstinate & confusing I’ve encountered. I’d appreciate any help on this particular issue, and I’d also welcome a “heads-up” if the macOS port of KiCAD is simply not ready for prime time… I don’t want to make a career of coaxing KiCAD to run on a platform it’s ill-suited for.

Thanks!

I wonder if it is this: https://gitlab.com/kicad/packaging/kicad-mac-builder/-/issues/367.

Getting this working seems a bit of a pain but is worth it. I have KiCad working very well on Catalina (both stable and nightly) so can confirm it works.
The libraries can be stored wherever you like. Usually they are stored in ~/Library/Application Support so that they are ‘protected’ from inadvertent user tinkering. Any alterations you make to these libraries will get hosed next time you update KiCad so you should keep your own assets in a separate area.
KiCad comes with dozens of libraries and footprints. Depending on what you are doing you may not wish to load them all - if you do analogue audio you might not want or see loads of microcontrollers, for instance, so KiCad has a mechanism to handle that.

The ones you want to load are recorded in the sym-lib-table and fp-lib-table files which should also be in ~/Library/Application Support

Clearly the blanked out ‘recommended’ is a bug and probably related to the issue that @eelik mentions.

I would suggest that you just select the blank option which should create empty tables and simply add the assets individually using the library msnager. You will need to set the library paths.

I’m on my phone at the moment but will try and send a screenshot later.

There is a useful FAQ here - it explains a lot about how to deal with tjis. If you understand the concept of will make it easier for you to understand how to set it up so that it works for you. It’s not Mac specific. Library management in KiCad version 5

EDIT added screenshots

Add the appropriate paths to where your libraries are located (Preferences -> Configure Paths …). My choice is not conventional - I am using Dropbox for my shared resources and have my KiCad assets in a non-standard location. This is just to show the principle. Normally, you would keep the Kicad assets in ~/Library/Application Support/kicad. (I seem to recall that the space causes some probs so you may need to escape it i.e ‘Application\ Support’ if you want to use the conventional location. YMMV

Add the symbol libraries you need using the 'Add existing libraries to table (the folder icon). (Preferences -> Manage Symbol Libraries …)

Do the same for the footprints. (Preferences -> Mange Footprints)

Also check that you have set the path to the 3D models (if you are using them).

Edit 2 A.actually, the path seems to be /Library/Application Support (so that the resources can be shared by several users) - I left the templates there.

I’m sorry. I read the FAQ, and I’ve read your message several times now - trying to get this set up. But it simply does not work.

One issue is the statement:

“The ones you want to load are recorded in the sym-lib-table and fp-lib-table files which should also be in ~/Library/Application Support”

These files are actually in:

~/Library/Application Support/Template

Having recognized that, I browsed to the “global symbol library table file” at that location - which seemed to placate the “Configure Global Symbol Library Table” dialog (at least it didn’t lock up & require ActMon intervention. I actually got what looked like a schematic entry page, and then tried to “Place a Symbol”. More chaos and confusion followed. The dialog box shown below insists on repeated prompts ad nauseum.

<<< Oh good grief - seems I’m being told by this website that new users are limited to only one image per post. OK - so this one will have to go - readers are asked to use their imagination. >>>

I opted out of that process after about 12 cycles, and then wound up at the following screen in which I tried to use the “Symbol Library Browser” to place a part on the schematic page. As you see I got nothing but blanks in the “Symbol Library Browser”.

As much as I appreciate you trying to help, this seems more a quagmire than an installation. As a macOS user, surely you recognize this is a mess!?!

FWIW, I feel the KiCAD project has mis-represented and misconstrued the situation claiming that KiCAD supports macOS. Having bits of code execute on a platform DOES NOT MEAN IT IS SUPPORTED. And clearly - KiCAD does not support macOS - unless one is prepared to endure hours of trial-and-error configuration, illogical user interfaces, and setting things up manually. Without having extensive experience using KiCAD on another platform, this should be classified as what it is: truly hopeless. IOW, the project should drop the claim of macOS Support until these issues are remedied.

You seem to understand the situation, John. Again, your efforts are appreciated, but it’s simply not enough. The installation & library configuration process needs more detailed documentation.

~/Library/Application Support/Template is for worksheet templates (page borders and title blocks). Not sure how you managed to get your lib-tables in there.

Anyway, you don’t have to use the automatic configuration. You can configure your paths and libraries as John details in his post.

(FWIW, I’ve never used KiCad on anything but a Mac.)

2 Likes

There are quite a lot of people using KiCad on macOS so it does work and, seems pretty reliable and solid. The library install is a once only process so once it is done, the software should run exactly as you have achieved on your Ubuntu box. I am not sure why you have hit this roadblock but I have a couple of suggestions.

I would suggest that you try and start from scratch TBH. I wonder if the old install 6mnths ago left some crud around. Preferences are preserved between installs to allow for an easy upgrade path but a mangled install might leave you in a bind. Since you have not got a functional install, I would remove the ~/Library/Preferences/kicad folder entirely along with the ~/Library/Application Support/kicad or /Library/Application Support/kicad folders, just to make sure you are starting from a clean slate.

Screenshot 2021-07-22 at 11.21.48

I would then try to install again - drag the KiCad icon into Applications. Then drag the ‘kicad’ folder into ‘Application Support’ - this will need you to authenticate. If you find you cannot drag the kicad folder onto the ‘Application Support’ folder icon in the mounted .dmg, you may need to drag it into the target directory using the finder.

This is the ‘suggested’ way to set KiCad up - but it is quite flexible and allows alternative arrangements. But with flexibility comes choices and options which can be confusing when you start out.

There is a limitation on new users to the forum on uploading images etc. This is lifted after you have viewed a number of posts - I can’t recall how many exactly but it is to encourage users to have a look around and read a few posts and the FAQ articles to get a feel of the software.

Hope this helps!

Ha ha… Well isn’t that an oddity of unusual proportion? How I got the lib-tables in there was simply by following Mr. Pateman’s instructions… In Other Words: That is where the files are located when they are downloaded from the KiCAD website. And now you can be sure :slight_smile: But of course I do hope you’ll double-check me on that. Be sure to get back with all of us here, and let us know how that crow is tasting Mr. Young.

Are you always this glib - and wrong?

John,

Starting over might make some sense. I’ll try this again if you’re prepared to put up with me. If not - I understand completely, and I’ll go quietly.

First thing is this: The Kicad folder drags happily into Applications. But the kicad folder will not be dragged into Application Support. By that I mean it does not prompt for authentication - I mean it simply cannot be done from my user account. As I indicated in my first post, I had to open another Finder window/tab, and drag it into my ~/Library/Application Support/

Which brings up a question: I do everything on my mac as a ‘Standard User’. When I need to perform a privileged action, I authenticate under my Admin account & pwd. Apple has been wishy-washy on this point recently, but I’ve always run my macOS systems this way, and it has always worked. To be clear - when you refer to ~/Library/Application Support/, are you referring to /Library/Application Support/, an Administrative user’s ~/Library/Application Support/, or are you referring to a Standard User’s ~/Library/Application Support/?

FWIW, I am the only actual user on this machine, and I’m actually not keen on running anyone’s software as an Administrative user.

Thanks,
~JM

Mr. Young is one of the main developers of KiCad and he’s rarely wrong. Even more rarely than me :slight_smile: Take a deep breath before you continue assuming things. It’s natural that you feel irritated because things have gone wrong for you, but it doesn’t help you if you communicate unpolitely.

4 Likes

OK, It might help if you understand what the KiCad install is trying to achieve. Inside the ‘kicad’ folder are the symbols, footprints, templates and 3d models supplied with KiCad. You should generally NOT futz with these files. If you redesign a symbol or a footprint and save it back to this area as your ‘improved’ version, it will get blitzed when you update the libraries. Also, these files - especially the 3d stuff - are quite large - on my system, the kicad folder takes up 5.8GB. Therefore, especially for a multi-user system the best place to store them is in an area that is shared to all but not easily writable i.e. /Library/Application Support.

If you are a single user, it really doesn’t matter where you put this file (as I indicated in my first post). Just to clarify - when I said ~ I meant your normal, home directory which is equivalent to /Users/yourusername/. For consistency, I would suggest that you put the ‘kicad’ file in /Users/yourusername/Library/Application Support. You then simply set the paths to point to this folder. No need for enhanced privileges etc. I may have inadvertently misled you in my first reply about the tables location - the fp-lib-table and the symbols-lib-table files should be stored in the kicad preferences folder i.e. in ~/Library/Preferences/kicad/

Unhelpfully, of course, macOS hides the ~/Library directory by default. You can either use the ‘Go’ menu item and enter “~/Library” or, if you would like to see this folder permanently, open a finder window in your home directory, press CMD + J (or select ‘Show View Options’ from the ‘View’ menu) and tick the ‘Show Library Folder’ box. You can then easily drag the folder into the appropriate directory.

I would suggest that you remove the preferences folder, install KiCad in Applications, the kicad folder in ~/Library/Application Support and see how that starts. You may still have to select a ‘blank’ library table and set the paths to wherever you have put the libraries. You may also have to add each library separately (can’t recall if this has been fixed).

I am not a developer but anyone who has a ‘Ki’ KiCad icon in their avatar is. FWIW @JeffYoung has made over 1600 commits to this project in the last 10 months alone. Its frustrating when things don’t go right but ad hominem attacks on a main developer is not a good look. KiCad is quite specialised software and macOS a relatively niche platform. It took me a while to understand the library system (reread the FAQ I linked previously) and there may be bumps in the road - sorting out the libraries is usually a ‘do it once’ and then forget it action.

I am indeed wrong. Template/ appears to hold the sample projects and the “pre-canned” lib tables. Or at least in 5.1. My machine only has development builds of 6.0 and 7.0, so I’m not sure how those are packaged.

Yes, I’m always that glib. And I’m reliably informed that crow tastes just like chicken. YMMV.

1 Like

Well save some for me :slight_smile:

OK - thanks for the clarifications. I’ll work through all of this when I take another shot at the installation later today. I’ll provide more feedback afterwards. BTW, I’m mostly conversant with operations on macOS.

That sounds important. I “uninstalled” KiCAD last night (deleted/trashcanned), but when I checked just now, here’s what I found:

jmoore@Dung-Pro kicad % pwd && ls -l
/Users/jmoore/Library/Preferences/kicad
total 88
-rw-r–r-- 1 jmoore staff 4790 Jul 23 00:36 eeschema
-rw-r–r-- 1 jmoore staff 1082 Jul 23 00:36 kicad
-rw-r–r-- 1 jmoore staff 742 Jul 23 00:36 kicad_common
-rw-r–r-- 1 jmoore staff 26993 Jul 21 14:05 sym-lib-table

  • I’ll guess this folder was created during my failed installation attempt yesterday?
  • I guess I should delete this folder also - before re-installing??

WRT your assertion of my so-called “ad hominem attacks”: If you think my rebuttal to Mr. Young’s post was ad hominem, then maybe you should refer to your dictionary? I’m confident of two things: 1. My post was not an ad hominem attack, and 2. Mr. Young seems capable of defending himself.

That said, I appreciate your help with the installation - really I do. I’m here because I’m interested in KiCAD, and I know I have much to learn. If things work out, I hope to contribute also. You say you’re not a developer, but it seems to me that you could make a huge contribution by writing up a competent installation guide for mac users. Our exchange here should give you an excellent start :slight_smile:

1 Like

Another way to temporarily gain access to the normally hidden ~Library folder:

Open Finder
Select ‘Go’ menu
Hold Option key, and Library will appear in the menu.
While holding the Option key, click on Library.
You can now release the key and navigate to the desired folder.

…I just realized while putting together this writeup that my Kicad addons etc. are in the OTHER Library folder - that is, /Library instead of ~/Library. Dunno if that might make any difference, but I thought I’d just throw this out for J_Moore’s consideration.

This is the key point - macOS has gotten stricter in their security system in recent versions so the old way of installing from the DMG is breaking on newer versions (we are already aware of this https://gitlab.com/kicad/packaging/kicad-mac-builder/-/issues/367). On recent macOS versions you will need to manually open the application support directory and copy/paste the folder into there using finder.

We are planning to simplify the install process for macOS in v6 by removing the need to drag that folder, but the sole packager we have for macOS has been busy finalizing the Python 3 switch and package signing workflow (so that we are considered a safe application and aren’t blocked from running).

1 Like

A coupla’ comments:

  1. “already aware…” : It’s too late for me, but a simple note to that effect on the download page could potentially save people hours of thrashing about here. Wouldn’t that be the right way to deal with a known issue? macOS Catalina was released about 2 years ago. What am I missing?

  2. And that 'manual copy/paste" is apparently not the end of the confusion. In fact, it seems to be only the “tip of the iceberg” - as much of the verbiage in this thread shows.

A note on the download page would be fine. But, it seems like the steps you went through in this thread are above and beyond the process that most Mac users seem to go through, at least from what I can tell. The KiCad installation process could be (and will be) improved to get rid of the need to manage the library folder separately, but it also appears as though the confusion between /Library and ~/Library was a factor in your case. KiCad currently expects you to place the kicad folder in /Library/Applcation Support (the global path, not the one in your home directory). You can certainly put it anywhere, including in ~/Library, as others have pointed out, but then customization of paths will be needed so KiCad can find the files.

Finally, there is one gotcha that you hit that perhaps we can improve with some kind of “reset” button somewhere, but I will have to think about it more to see what I think would be the right UX. When KiCad first starts, it checks for the presence of library configuration tables in the settings directory (i.e. ~/Library/Preferences/kicad on macOS). If these files are missing, it assumes a brand new installation and offers you the option of copying the default table, if the default table can be found. One way or another, the files will be created at first run. So, if you install the kicad folder (which contains the default tables) in a non-standard location and then run KiCad, it won’t be able to find the default tables and won’t offer that option. But, it will create the tables empty, and you wont’ ever see the option again even if you correct the location of the libraries unless you delete the empty tables in the settings directory.

Most of the time it is the end of the confusion. I think the rest of the confusion in your case came from a confluence of doing things in a certain order that led to a broken library configuration (as described above) which I agree is somewhat hard to understand and recover from today. But, if people install the kicad to the system location (/Library) and then run KiCad for the first time, it should “just work”.

2 Likes

Yeah, you’re right… this is perfect. I’m sure everyone gets this right away.