[Linux] - 2sa1015 model not found -

I am very new to KiCad and electrical design in general. I have a home electronics kit that I am working in parallel to build up the basic physical circuits + Kicad model. This is to let me more easily see signals and change parameters. I really want to have both practical and model for all of the learning circuits.

I have an issue with the 2nd circuit which has a 2SA PNP transistor.
In Eeschema I can pull up the 2sa1015 but it has no model data for me to run the simulation.

What other library’s do I need in my path beyond below to get this and all other basic components available to run simulations ? I read this help and it seems I have everything already so I am lost.

KiCad : 5.1.12
OS : Opensuse Tumbleweed (installed from repo)


This is the error from when I run the simulation

No compatibility mode selected!
warning, can't find model 2sa1015
Circuit: KiCad schematic
Error on line 6 :
q1 net-_q1-pad1_ 0 net-_c6-pad2_ 2sa1015
could not find a valid modelname
Error: circuit not parsed.

KiCad does not come with simulation models for components, other than the spice primitives (voltage/current sources, resistors, capacitors, inductors).

You’ll have to provide simulation models yourself, either from the internet (from the device manufacturer or from other people), or make them yourself.

You may want to work through a tutorial like this one: KiCad Eeschema as GUI for ngspice, tutorial for setting up the simulation - section 3 starts talking about adding external models.


Ahhh I see.
So with the known specs as I can find here I need to translate this into the expected parameters for a model.

Right, OK next step is to find a template and copy this over.

Thank you.

1 Like

Ah I found one in your link in the spice library from your link.

All works now. I have a modulated output and I can model my capacitor in series example!

Thank you!

1 Like