KiCad Extras Installation Failure on MacOS


#1

I’m trying to install kicad on my MacBook Pro for the first time. I downloaded the version for the Mac. I was able to install Kicad, but I don’t have any of the libraries or components. I downloaded the kikad-extras-4-0-7.dmg. When I double-click on it it displays a window for dragging the extras to the kicad folder, but the drag always fails and the folder goes back where it was on the left side of the window. I assume other people have installed on a Mac. Is there a way around this?


PcbNew on macOS: Where is Design Rules menu?
#2

Edit: do not follow this advice for your problem, OP.

There is some discussion on the developers mailing list about a possible incorrect building of 4.0.7 for MacOS. I’m not sure what it affects, but if you’re having problems, you might consider installing 4.0.6 for now until they’ve solved the problem.

Edit: Follow @Rene_Poschl’s advice below.


#3

That should not affect library installation but some other bugs. (After the first v4.0.7 announcement some critical bugs in the software where found. In particular one major bug in the pdf export and i think also some possible segmentation faults. This lead to a postponing of the v4.0.7 release by nearly a month.)

@stephenpjohnson you can manually download the libraries directly from github if you don’t have time to wait for an answer on how to fix your problem with the installation process.


#4

Sorry, the other answers in this thread are wrong :frowning:

Open the extras disk image, and right-click on the kicad alias. Choose “open” from the pop-up menu. You’ll likely get an error: “The operation can’t be completed because the original item for ‘kicad’ can’t be found.” Or, if you drag slowly, when the modules folder icon is over the kicad icon, the mouse cursor will change to having a circle/slash “can’t do that” glyph.

The reason: that kicad icon is an alias (a Unix symlink). if this is your first time installing Kicad, you haven’t created the folders to which that link points. If you open your Terminal and do a cd /Volumes/KiCad\ Extras/ then do an ls -la, you’ll see where the link points: /Library/Application Support/kicad/ If you dols -ls /Library/Application\ Support you won’t see a directory called kicad.

The obvious solution is to do mkdir /Library/Application\ Support\kicad but you will be told “permission denied.” That’s because the/Library directories are system directories, writable only as root. You have two options:

A) Make the directory as root user: sudo mkdir /Library/Application\ Support\kicad
You might get complaints about not being able to copy/modify things in those directories, as applications run as your user, not as root. So, instead:

B) Put your libraries in the user > ~/Library/Application\ Support (note the leading ~). That is, do

mkdir ~/Library/Application\ Support\kicad and then

cp /Volumes/KiCad\ Extras/modules ~/Library/Application\ Support\kicad (note well: no trailing slash / after modules or kicad in either of those paths).

Alternatively, from the Finder, click on your home directory in the sidebar, and look for Library. If you don’t see it, it’s because macOS by default hides it, so from the Finder menu choose View -> Show View Options, and check the “Show Library Folder” box. Now you can navigate to your user Library and use the usual Finder commands to make a new Folder called kicad in Application Support.

Go back to the kicad-4.0.7.dmg disk image. Open it. You’ll see a Kicad folder on the left pointing to Applications; you must’ve used that to install Kicad to the standard /Applications folder. You’ll see another kicad (lower-case k) folder on the left, pointing to Application Support. That Application Support directory lives in the system /Library/ directory (note leading slash).

So what you want to do:

Make sure you have a Finder view of your user ~/Library/Application Support folder. From the kicad-4.0.7 disk image view (after you open the image), drag the contents of kicad (lower-case k) to ~/Library/Application Support folder. This will copy the entire Kicad library directory structure to the proper location. Notice that it includes a modules folder, but it is empty.

Go back to the opened Kicad Extras disk image. Drag the modules folder to ~/Library/Application Support/kicad – you should be asked if you want to overwrite the existing (empty) modules folder, say yes.

Next: back in the opened Kicad Extras disk image, copy the fp-lib-table file to ~/Library/Preferences/kicad (if the directory doesn’t exist, create it). Now pcbnew will know about the footprint libraries.

Start Kicad. Open or create a new project. From the Preferences menu, choose Configure Paths. The entry for KISYSMOD should hold the path to the footprint libraries (in my case, it’s /Users/andy/Library/Application Support/kicad/modules) and the entry for KISYS3DMOD should be /Users/andy/Library/Application Support/kicad/modules/package3d).

Finally, open a schematic. Choose Preferences -> Component Libraries from the top menu. The current search path list near the bottom should contain /Users/andy/Library/Application Support/kicad/library – that’s how EESchema will know where to look for the libraries. Look at the list of libraries in Component library files. The libraries you want to use must be in this list. If any are missing, click “Add” and a file browser dialog opens, and it should start in ~/Library/Application Support/kicad/library and there just look for the name of the libraries you want. Select them, click OK.

That should do it. Yikes, that’s a lot of non-obvious set-up!


#5

Hello, I’m also a Mac user who’s having a hell of a time getting started. I can create a schematic, but assigning footprints does not work. I have installed the extras according your instructions here, and my KISYMOD is set to /Library/Application Support/kicad/modules. As you can see in the screenshot, I get an error message when I try to assign footprints to my .net file:

IO_ERROR: footprint library path ‘/Library/Application Support/kicad/modules//Capacitors_THT.pretty’ does not exist from kicad_plugin.cpp : FootprintEnumerate() : line 1801

etcetera

Note that I made a schematic according to the “help” tutorial, but I used only a single resistor connecting power and ground – simple until I get this thing working. Any help would be greatly appreciated!

Kelly

Kelly


#6

you should doublecheck your path, there is a double slash in it


#7

Thank you so much for your reply! Where do you think that double slash is being generated, given that my paths are designated correctly (see image of my configuration options)?


#8

try changing your KISYSMOD to /Library/Application Support/kicad/modules :slight_smile: aka remove the last slash


#9

Yes, I did that… and it still won’t work. Incidentally, those are the paths that were created by the default installation (following instructions exactly), so it seems that there remains work to be done on installation for Mac users. But I’m not complaining - I’m grateful to have a free PCB design tool if I can ever get it to work!


#10

can you try uploading a screenshot of PCBnew -> Preferences -> Footprint Libraries Manager


#11

Try adding ~ in front of KISYSMOD. (Not sure if osx does use the same syntax as linux. ~ under linux points to the user home folder.)
or add /User/kellyheaton

Explanation:
Currently kicad tries to find the libs directly in the root directory of your system (/Library/...)
but your libs seem to live under your users home directory (/User/kellyheaton/Library/...)


#12

Here’s a screenshot of PCBnew -> Preferences -> Footprint Libraries Manager


#13

Do you mean add ~ to the “environmental variable” KISYSMOD in my PCB Library Tables?

Note that my schematic libraries are loading just fine (without the ~)


#14

In kicad 4, the schematic libs are not relative to any environment variable. (You can set it up to use environment vars but that would require you edit a system file by hand.)

So yes set KISYSMOD to be ~/Library/... or /User/kellyheaton/Library/...


More details about symbol libs.
In kicad 4 the list of symbol libs is stored in each project file separately. (There is no central equivalent to the fp-lib-table)
You can view/edit this in eeschema->preferences->component libraries.

That dialog is split into two. The lower part holds the search paths and the upper part the lib names.
Kicad will look in every search-path and takes each lib from the first search-path where it finds it. (The order determines the priority. More details about that are in this old post of mine)
By default one of the search-paths will point to the libs that come with the kicad installation. (In default installations there will not be a environment variable is used for it.)


#15

OMG, finally!!!

So for future people installing on a Mac, you have to edit the default install paths (Preferences -> Configure Paths) to set KISYSMOD to your user name: /Users/username/Library/Application Support/kicad/modules

NOTE that you cannot edit the existing paths. You have to create a new path for KISYSMOD and delete the old path.

I suppose you have to repeat this procedure for the KISYS3DMOD pathway as well (I haven’t done this yet, but my footprints are loading at last :slight_smile:

Thanks to everyone for helping me through this!


#16

Kelly, are you opening “Finder>Preferences” to change the default install path? I am unable to find it, there, or in system preferences. High Sierra v10.13.3

Second, when I loaded the fp-lib-table yesterday, I didn’t seem to have any difficulty finding where to place it. Now, and quite possibly yesterday, there is no kicad in ~/Library/Preferences. I do know that at least the documents ended up in user/me/documents/
All uninstalled this morning due to operator error.(put at least one too many files in the trash)
Knowingly trying this time in ~/Library/Application Support/kicad


#17

Using Finder from your desktop, click on “Go” while you are holding down the alt (option) key. This will make your Library visible. Use Finder to open the Library folder and go to Application Support from there…


#18

Kelly, thanks for the reply. With your earlier post on configure paths, and Andy’s lengthly post on Nov26, I now know where you are making changes. I had thought we were trying to make a ‘root’ change as to how the os installs new software. I still am not sure in the initial install if everything is in the right folders.


#19

You’re welcome. I think it’s a user interface problem. The KiCad installer tells the user where to place folders, but does not provide the complete path (even as a text string in the README file). Because there are multiple instances of folders called “kicad,” it is easy to get confused. Also, many Mac users may not realize that Application Support is located in the Library, which is hidden from the Finder view by default … Just some thoughts.


#20

First, my default Finder view is ‘Column’, and in the home directory in the sidebar MacHD -> Users -> constantine, choosing View -> Show View Options, there is no box for Show Library. However, switching to any of the other three Finder views offers that selection. That got me lost early on.