KiCad 8 3D Models missing

Just started using KiCad 8. Trying to add 3d models (step format) to my own added footprints.
No 3d models show up in 3D viewer!

I then looked up several of the standard footprints already installed in the KiCad 8 library and every one has a red X next to the path to the 3d model.
When I pressed the folder symbol to try and add the 3d model, I navigated to the path shown and there is no such 3d file.
What happened to the standard 3d files?

Also, why don’t my added 3d step files show in the 3d Viewer?
When I add them, they do show up in the footprint editor. I have to adjust the position and rotation of them then save the selected footprint.
But when I open the 3d viewer the 3d model has vanished,as in all standard footprints too.

P.S. I got the footprints, symbols and 3D models from Digikey and Traceparts. Not all models are available, it seems. I found both for a Molex SL connector but for Harwin there was a footprint for a 4 pin but not the 8 pin, and a 3D step model for both.
I first tried adding the model files to the KiCad install folders in ProgramFiles but found they were forced into Read Only mode, causing problems.
Then I discovered a KiCad folder had been created in my C:\Users\myName\Documents\KiCad\8.0.
So I moved the files there and tried editing all the entries I had made already. Still no good.

Then I saw a forum topic about the “3rdParty” folder, so I moved them all to the 3rd Party folder.
I recreated the same type of naming that the KiCad Share folder uses; I have footprint, symbols and 3dmodels subdirectories.
In the footprint folder I have one folder for each type, so "Connector_Harwin.pretty and “Connector_Molex.pretty”. Inside those I put the mod files.
In the 3dmodels folder I created “Connector_Harwin.3dshapes” and “Connector_Molex.3dshapes”.

Inside those are the files I downloaded in a zip file. E.G a .stp and a .txt file for each connector model.
The .txt files have a lot of lines with colon-separated keys and values. Don’t know what they are for.

Post your version details from Help > About KiCad > Copy Version Info. Did you install the 3D model package? On some platforms it can be optional.

Application: KiCad x64 on x64

Version: 8.0.0, release build

wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 23 2024 02:24:15
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.7.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

(edit: by the way, my Graphic card is a Geforce and has openGL 3.3, so that should be no problem)

I thought the 3d package would be installed with everything else.
Do need to install that separately?

If so, How do I do install that?

I think it should be included in the standard Windows package, unless you chose the lite variant. But I’m on Linux and the 3D models package can be optional.

Incidentally not all standard footprints have an associated 3D model even though the 3D model path is filled in. Try a standard one like TO-92 transistor.

Ok I tried a TO92 transistor. The footprint editor shows the transistor body, but in the 3D viewer it is invisible. Only the PCB shows up.
I would attach a picture, but I am not allowed to yet.

Search the forum for footprint editor 3D viewer issues. I seem to remember this has been brought up before. It may already be fixed in 8.0.1-rc1 so check the fixed issues for this.

Edit: Might be this: Footprint library browser in Schematic Editor v7.0 vs Footprint chooser in v8.0 - #2 by Dawid_Cislo


I’ll take a look at that.
Thanks for taking a look at this so quickly.
I’ll respond tomorrow when I have some news.

I think all users are allowed to attach a (one) picture (by dragging it in the post, I think). To be able to attach another file (like zipped project) needs some work:

                     I have checked that topic but not the same; thank you though.

I have downloaded the latest 3d model set and copied all of them to the KiCad share\3dmodel folder. It took a while but there’s no difference.

I just tried the TO92 transistor again and also a battery holder that definitely has a 3d model.
In all of them ,the footprint editor shows the 3d component but the 3D viewer shows only a bare PCB.

I wonder if KiCad 8 has a hidden option that I haven’t found; maybe it needs turning on? Can’t see one so far. I thought it would be on by default anyway.

By the way, when I open the footprint editor a message does say “Could not use OpenGL, falling back on software rendering.” (Could not find shader uniform: SMAA_RT_METRICS)

However, the footprint editor does show the components,so I thought the 3D viewer would also be able to do so.

I’ll look for that 8.0.1-rc1.

Thanks everyone. ( & Piotr, thanks for help about pasting images etc. I’ll look through the help.)

You do have the buttons/ICONs toggled to show the components in the 3D viewer ?

From V7 . . .

1 Like

Hi Raptor,
My 3D Viewer looks different (version 8.0); it doesn’t have those buttons. I can’t post a picture but I really only have Enable Raytracing, rotate buttons and enable/disable orthographic projection, plus show/hide the appearance manager.

Thanks for the idea though. Interesting that they removed those buttons from v8.

Aha! I got it! it WAS a setting. In V8.0 the 3D Viewer’s appearance manager has a group of entries after the board layers and all of these have a diagonal line through them.
They are terms like ‘Through hole models’, ‘SMD models’, ‘virtual models’, and more.
I clicked the ‘Through-hole models’ item and voila! The component appeared.

I had learned the appearance manager in the PCB editor as having only board layers in it, so didn’t even think to look there.
Now that I found these, they do make sense(showing the model is about appearance) but I thought the 3D Viewer would have automatically shown the models because that is what it’s for.
I suppose the idea is that you start with the PCB only, then add in the components.

Oh well. I hope this helps others1 :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.