KiCad 5.1.0 Released


#1

KiCad 5.1.0 has been released. Please see the release announcement on the KiCad blog for more information. The installers for most platforms should be available now or in the very near future. Many thanks to everyone who made this release possible and our user community for your continued support.


Kicad 5.1 Release date
#2

One change list item may be misleading.

Pcbnew scripting support for Python 3 has been added.

This depends on the platform and compilation. The Windows package doesn’t have python3, does it? How many package/OS combinations mentioned in the download page actually support python3 by default?


#3

The Windows version can’t open the scripting console for me on Windows 10. I already reported it: https://bugs.launchpad.net/kicad/+bug/1820128. Does it work for others?
Edit: it worked after thorough cleaning up and re-installation.


#4

I believe you can build python 3 scripting support if you willing to give up wxPython scripting support. This is due to the fact that wxPhoenix (the latest wxPython version) does not build with msys2/mingw so you can’t have your cake and eat it to. If you find this problematic, please complain to the wxPhoenix project to get them to fix the issue. They seem unsympathetic to cross platform compatibility on windows building with msys2/mingw. The previous version of wxWidgets builds just fine. I don’t have time to spend fixing the wxPhoenix build system so we will have to live with python2/wxpython3 on window for the time being.


Why is Python version shown as 2.7 in KiCAD5.1.0?
#5

I don’t find it problematic. The announcement may just give impression of python3 support by default, while 5.1.0 codebase actually just makes it possible for the platforms which can support it.


#6

Great news! There might be a problem with the macOS non-10.14 download, though, in that it actually contains binaries for 10.14 instead of older versions of macOS. I will elaborate…

I have macOS High Sierra 10.13.6, and I specifically downloaded the “macOS 10.11-10.13” version from the “CERN mirror” on the official KiCad OSX download page: http://kicad-pcb.org/download/osx/ – the filename is: kicad-unified-5.1.0.dmg, and its URL was: https://kicad-downloads.s3.cern.ch/osx/stable/kicad-unified-5.1.0.dmg

I opened the DMG and dragged (i.e. copied) the respective folders to Applications and Application Support, and then went into the Applications => KiCad folder, and the macOS finder shows that all of the apps (kicad, bitmap2component, pcbnew, etc) have a “stop sign” through them which indicates that the app cannot be run in this version of macOS.

Double-clicking (say) kicad yields this dialog box:

You can’t use this version of the application “kicad” with this version of macOS.

You have macOS 10.13.6. The application requires macOS 10.14 or later.

My guess is that either the download link goes to the same download as the 10.14-specific version (but with the wrong filename) or the official 5.1.0 release for 10.11-10.13 has been accidentally built with the wrong internal macOS manifest/flags.

I can see that others have been able to run older 5.0.x versions on macOS 10.13, so with any luck this is an easy fix :slight_smile:

Otherwise, thanks for the great work!

Regards,

Anton Maurovic
algofoogle


#7

I can agree with this, I tried both the download locations - both said that they require macOS 10.14. So apparently it’s the wrong version up there. Pretty please can someone fix. :grin:

EDIT: Wow that was rude of me - Thanks to ALL the work done by ALL the contributors that worked hard to get 5.1.0 out. :+1::+1:


#8

As it happens, this is my first time trying KiCad, so until I can get a version of 5.1.0 that will run on my macOS 10.13 host, I will just use 5.0.2, which I found in the official CERN site, here: https://kicad-downloads.s3.cern.ch/index.html?prefix=osx/stable/


#9

In case people still have issues with downloads I created torrents for windows and mac versions.
If you already downloaded a binary you can help seed.

kicad-5.1.0_1-i686.exe.torrent (21.6 KB)
kicad-5.1.0_1-x86_64.exe.torrent (21.6 KB)
kicad-unified-5.1.0-10_14.dmg.torrent (23.5 KB)
kicad-unified-5.1.0.dmg.torrent (23.6 KB)

Here are md5 checksums:

$ md5sum kicad*
f70478c4de8597db9402b2517cafc89c  kicad-5.1.0_1-i686.exe
15a37828a81a4102cb0aaff50779696b  kicad-5.1.0_1-x86_64.exe
f392321af0513a5c6920bb89ca7831c7  kicad-unified-5.1.0-10_14.dmg
923c7107d8479d340a0a663f87a32441  kicad-unified-5.1.0.dmg

conCERNing download speed
#10

Thanks @qu1ck. By any chance, can you give checksums (say, md5) for those? The md5sum for the kicad-unified-5.1.0.dmg that I downloaded from the Futureware mirror is: f392321af0513a5c6920bb89ca7831c7


#11

Updated my post with checksums. It appears you are right, 10.14 build and the other one for mac are identical so it will likely be fixed soon.


#12

Great work, thanks @qu1ck :slight_smile:


#13

GitHub download links (of the installers and not the source code) added for Windows users in addition to the two existing mirrors.

macOS will get them when the packages are fixed.


#14

This is brilliant. Thanx for providing these. When I get home tonight I’ll try to remember to add these to my torrent program and leave it running for a while so I can assist seeding.


#15

Awesome news. But I am not installed. Because use MİNT 19. When kicad 5.1 ready for mint 19? Do you any ideas?


#16

For 5.0 it was exactly the same repository than Ubuntu. Try that.


#17

Of course. But KiCAD download page ubuntu contain 5.1 but mint not contain 5.1 contain 5,0,2 http://kicad-pcb.org/download/linux-mint/


#18

I meant that you could add jsreyanayd’s 5.1 ppa. Maybe it’s the same for Ubuntu and Mint but the Mint page isn’t just updated yet.


#19

Ok I understand. I will add 5.1 ppa maybe I install KİCAD 5.1 thank you.


#20

This. Use the ubuntu instructions.

This reminds me that I need to split out the the Ubuntu page as a include for Mint.