JLCPCB gives me warnings on .drill and edge cuts

I’ve always used a combined PTH/NPTH file, so I guess that exhausts my knowledge. I can’t think of a reason why one file is accepted but the other apparently not.

1 Like

I’ll combine the files and try again. I’ve done this before but not with changing the extension to .txt. Let’s see if this works…

I found some help on JLC site,, but it’s inconclusive with regard to NPTH files. My guess is they are expecting one drill file and their check flags an error on the second file.

It seems though that renaming the drill file is not necessary.


I tried a combined drill file. Got unrecognized gerber.

No idea what’s going on. I may just blow this design off to JLC and see what happens. It’s only a few wasted dollars if I get junk boards. The big problem is wasted time when I now have people that want boards.

Maybe one other thing to try, select the drill file as metric.


Same warning with metric. It’s late, time for me to sleep. I’ll play with this later.

You have some marks (fiducials?) in edge.cuts. There should be only the outline. Don’t use fiducials at all unless you really know what you are doing and why you need them and how the manufacturer would use them etc.


I downloaded the KiCad project and generated gerbers with my kicad (5.0.0). After uploading to JLC I just get the board outline warning.

The additional alignment targets on Edge cuts don’t seem to cause a problem.

Don’t use auxiliary axis as origin.

1 Like

Why not? Doesn’t make any difference…

“You have some marks (fiducials?) in edge.cuts” I have no idea what that means. I put some alignment targets outside of edge cuts so that I could align the copper layers for toner transfer. Should I remove these targeys?

Yes, manufacturers don’t like them.

It would be a good idea to reduce confusion, but it doesn’t appear to cause a problem with the analysis.

Just to be sure. It’s not needed and not useful in most cases, so I would leave it off in case of any possible problems.

You could make the exact same argument for not choosing “Absolute”. If there are no actual known issues, then advising people to select options that aren’t necessary creates unfounded folklore.

The Important thing is that the option should match between the gerbers and drill file.

For reference, this is the zip file I submitted to JLC. (112.2 KB)

I’ll backup the project and remove the alignment targets. I need to keep them for any future toner transfer boards. Toner transfer is labor-intensive, but, much faster for testing a new board than getting it from China. I can make one in a few hours :slight_smile:

I guess that there is a human at JLC who does a final check before okaying the design, but one thing I and others have found with JLC is that it is best to avoid getting into any “customer support” type email because it gets confusing very quickly!

Can you put those targets on a different layer?


I’m running KiCad version (5.1.2)-2 64 bit Windows. Should I downgrade to your (5.0.0)??

Not yet, I think I see the problem by comparing the drill files, I noticed you have some oval holes. There are different ways to specify that in the drill file. It appears JLC are rejecting the “Route mode”.

In your version, try selecting “Use alternate drill mode”.

1 Like