WRL color bug? Direct Solidworks 2018 export problem


#1

Hi guys, i’m using the 4.0.6 version on windows…

On older version of kicad, the WRL files for 3d models works flawless,

but after update, the same files don’t work at all, after export again using solidworks. they are rendered with some color errors, someone experienced that too?

I exported from solidworks 2018 again, vrml 97, milimiter unit (i still have to apply scale (1/25.4) to fit properly on the foot print…).

Waiting for v5, but worried with compatibility.

Best Regards,
Saulo Barbosa


#2

Your screenshot looks like you experience something called Z-fighting. This happens if you have two surfaces with different colors at the same position.
So you might need to remake your models such that there is no overlap between differently colored parts.

In freecad this can be achieved by using the union operator which does result in one single solid with differently colored faces. I do not know if solid works has some equivalent.

Also the best option right now to manage 3d models is by using the freecad extension kicad stepup. It allows you to export correctly scaled and nicely colored wrl models plus a step model. The later can then be used to create a detailed step model for your populated board for use with any mechanical CAD program.


#3

@Saulo
You can export your SW file as STEP and then open it in FreeCAD. From FreeCAD you can export it as WRL with a better KiCAD compatibility.
An easy exporting option is through StepUp WB as suggested by @Rene_Poschl.


#4

I tried to use Wings3D to do that (i don’t know why i have this software lol).
i already tried to use the stepUp but i failed to understand how to use it… but i will do that @maui (just use the freecad to export it).

i have a lot of 3d models and footprints, maybe i should invest more time to learn how to use the StepUp.

the kicad v5 accept step files?


#5

Yes. But if you want nice looking renderings wrl is the way to go. (It allows for adding material properties to be used by the renderer.)


#6

please have a look at


#7

Hi guys, i tried to export using FreeCad, still the same. Now i update to v4.0.7 and some .wrl from kicad appears with the same error… i believe this is something related to my renderer itself, some library…

3D model: Crystals.3dshapes/Crystal_SMD_5032_2Pads.wrl

Now i realize that kicad suggest to install wings3D to create and edit the 3D models (that’s why i have it on my computer! ), it uses some render engine from wings3d?


#8

Would you mind to share a 3d model in STEP and WRL exported by SW which is problematic for you?
Wings3d is no longer suggested as modeler for kicad.


#9

No problem, this is my last 3D model, kicad don’t render it:

Links removed!

I download this switch from the manufacturer website and converted to wrl using solidworks, it render, but with normals errors:

Links removed!


#10

You haven’t used StepUp and FreeCad with your tests, but just FreeCad have you?


#11

not yet @maui, just FreeCad --> export --> vrml format.

The 3D models that you send to me:

Thank you very much! And thanks for the advice over private message, i will edit the past post!

But it was strange that with no apparent reason my .wrl files start to be rendered like that…

Now it’s time to study how to use the StepUp! :smile:


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.