Won't allow to draw a line between 2 components

Hi there,
I’m learning Kicad as I’m using it.
I’ve done my schematic in eeschema as you can see, it’s really basic :

“Masse” stands for “ground” in french.

to be followed…

I started Pcbnew and tried to dranw the circuits lines but there are some lines he doesn’t want to draw

I can’t link the connector on the left to the others components. When I double-click to end the design, the line vanished.

Do you know how to handle that?
Best regards,

Pin 1 of your LED is unconnected in the schematic.
(There are small circles or squares around the pin end/wire end.)

Did you forget to run ERC?

Near the junction at the upper pin of R1 there is another unconnected wire

Make sure your grid is set to 50 mil when you place objects. That ensures they all line up properly on the grid. Sometimes it is easier to remove and re add them if the grid wasn’t 50 mil when you originally placed them.

No I ran ERC but it keep telling me some pins are not connected though they obviously are.

I have erased the PCBnew file and will start again.

If ERC tells you they aren’t, then they aren’t :slight_smile:

There is one really important thing in eeschema which I didn’t realise until after using Eagle for a bit:

In KiCad, overlapping wires are NOT connected

So although it “looks” like they should be connected, KiCad does not make the connection. The clue is the small square, which means the wire is not connected. When drawing the wires, make sure to terminate the wire at the connection point.

I’ve been using KiCad so long it’s second nature to me, but I can see why newbies can easily fall into some big bear traps.


Also try changing the Ref Id of the connector footprint.

This might be a good tutorial series to watch:

While it will be easier if you fix the unconnected issues in your schematic (hermit’s suggestion to increase the grid is nearly mandatory), you can also turn off the real-time checker by clicking the top tool in the toolbar to the left of your document window.

That seems like very dangerous advice. Especially now that we already know that there are multiple real problems with his pcb.

Never ever ignore DRC or ERC. They are right in most cases.

Hermit’s advice was not to “increase” the grid size but to make sure it was set to 50 mil, which it is. His problems are unrelated to the grid.

Not a wise thing to do unless you know specifically why you are turning it off.

1 Like

He he, I nearly mentioned that last part would be a religious topic, but didn’t want to invite trouble. :wink:

To be short, I’m in disagreement here. I always design with DRC off, and then run it at the end. To each his own…

IF you know what you are doing, then maybe… but bad advice for beginners who don’t.

I’m curious to know why? I’ve come to rely on the fact that DRC won’t let me route a segment that violates any of my design constraints. The last thing I would want would be to finish a layout only to run DRC and discover a multitude of clearance violations.

Mostly because I often design boards that don’t fit on screen. So I may be working on a section where a bunch of traces go off to the right. I’m not worried about exactly where yet, I’ll deal with that later. But if I don’t connect them to something and DRC is on, then it will delete them (as in the OP’s example).

Another case is when I’m re-routing something. I may need to temporarily cross traces before moving the other one. I don’t want DRC to keep squaking at me.

I also remember it getting in the way when editing zones, but I can’t remember the details.


The OP has disconnected wires in his schematic. Having a grid large enough to be above his visual acuity and manual dexterity will almost certainly reduce those. It makes a huge difference for me anyway…

This is news to me. At least in the open gl canvas i never experienced this behavior. (I use the same trick of ending traces somewhere in the middle.)
The only time kicad (to my knowledge) deletes traces is if you have “auto delete old tracks” enabled and redraw a track. Or if you use the tools global delete or cleanup. All of which are independent of the DRC.

OP’s example was that he could not connect because the pad he wants to connect to had a different net then the trace.

This might be a valid usecase. But if you encounter this you can disable DRC while doing this and enable it shortly afterwards again.

That would be surprising. Zones have their own clearance and min with settings. The zone outline polygon is also independent from everything because only the filled area is affected by the clearance and min with settings.

Well I am sure the OP is now thoroughly confused!

In general, if you are aiming to help a newbie, and feel you are about to post something that might start a “religious war”, it is really better not to post it.

Alternatively, if you like unproductive arguments, then post away. :slight_smile:

Hi there ! Thanks for your answers.
I’ve changed the settings to english so it’ll be easier for me to follow your advices.
The grill was already set to 50 mils.
I’ve tried to link the wire to the pinj 1 (which is the ground of the 555).
I use the “place wire” tool… I move my cursor to theend of pin 1 which has a small circle on it. Then I draw my lin down to the bottom wire. A junction is automatically added.
Check the ERC : still a mistake there : “err type 3 : pin connected to some other pins but no pin to drive it”.
Same for pin 8.
Any leads?

This is because these pins are defined as power input pins. ERC requires that a power input pin is connected to a power output pin.

In your case you get power via the connector J1. This connector is a generic symbol that has its pins set to passive. (Because the designer of this symbol does not know your usecase)

One solution here is to use the PWR_FLAG symbol found in the power lib. This symbol has one hidden power output pin. connect this flag to the connector pins. (one for plus one for ground)
ERC can help you better if you place the power flag near where you get the power. (You could in theory connect only the power flag to the power input pins. ERC will think everything is ok but your design will not work because the IC has no connection to power.)

Another solution is a dedicated symbol with its pins defined as power output.