Where is the passive components symbol in KiCad 6.0?

I have added Official KiCad schematic symbol libraries into KiCad 6.0, but I haven’t found the passive components - resistor, capacitor, inductor…

Did you start a new project and open the schematic editor to design your circuit?

If yes, did you press A and press left-click on a plank area?

If yes, did the window open and your symbols are not there?

Passive component symbols are located in the “Device” library. You can also find them by typing R, L, C etc. in the search box.
If you still can’t find these symbols, make sure you have added the libraries in the “Preferences” → “Manage Symbol Libraries…”

1 Like

Edit: NVM I’m being dumb

Yes, the window opened and symbols were not there.

Thanks for your suggestion -

Passive component symbols are located in the “Device” library.

I downloaded it here - Device, and then they were there.

The new question is : where is VCC, GND and pushbutton?

There are over 150 symbol libraries. Did you install them?
It is worth spending a little time exploring those libraries.

Push button is in “Switches”
VCC & GND are in “Power”.

Cheers, Jan.

I found VCC and GND here - SparkFun_SchematicComponents.lib, and pushbutton, I found it was told “CircuitBreaker” in KiCad component master library.

You said"There are over 150 symbol libraries", where are they?

Hello @MianQi

What is your OS and from where did you download?

You can copy/paste your information from: help /about kicad / top RH corner.

This is the official site for downloads: https://www.kicad.org/

The libraries should have been part of the install. You haven’t mentioned which operating system you are on. Spark Fun libraries are not part of a standard install so these must be from elsewhere. The power symbols are entered using the ‘p’ key. What does ‘Preferences’ → ‘Manage symbol libraries …’ show?

My OS is Ubuntu 20.04 LTS, ‘Preferences’ → ‘Manage symbol libraries …’ was empty just after I installed. Actually, the component library and device library were all downloaded desperately.

I saw it : "This will perform a full installation of KiCad. If you don’t want to install all packages you can use: ```
sudo apt install --no-install-recommends kicad. I have selected this, maybe this is the reason.

Correct. You just installed the program without libraries.

Probably easiest to just install again. You can omit the demos, if you wish… the last line in the shell command.

I tested it:
Since I ran sudo apt install --no-install-recommends kicad before, so merely run sudo apt install --install-recommends kicad is not enough, one should run it, then reboot, then add the library file say “power.kicad_sym” in “Preferences”, then it would work.

Sorry, I should have said delete your Kicad installation and then just reinstall the full program this time, including the libraries.

How to delete KiCad on Ubuntu?

sudo apt remove kicad

or ftom the GUI software manager (I’m not familiar with Ubuntu’s, it’s been a long time since I tried it).

I tried, these workflow didn’t get as expected:
sudo apt remove kicad*
sudo add-apt-repository --yes ppa:kicad/kicad-6.0-releases
sudo apt update
sudo apt install --install-recommends kicad

Since after that, there was still no libraries I want in “/usr/share/kicad”.

You should have usr / share / kicad / footprints & usr / share / kicad / symbols.
Do you have these?