Where is the passive components symbol in KiCad 6.0?

I have those, but I found I should downloaded libraries here as it was told here Symbols
Then unzip it and added it into Schematic Editor, then is OK.

If you had shown us the results of the commands you typed in that might have been helpful to us. For example, you would have seen some messages from apt, such as what packages it was installing, etc.

No need to unzip, just open your project, go to schematic, click on “browse symbol libraries” and you will find all the symbol libraries.
Same with footprints, but in PCB

Have you found the libraries through your schematic editor?

The thing most likely missing here, is that installing the libraries is not enough.
KiCad does not search for libraries, and only shows libraries in the GUI that are present in the library tables for schematic symbols and for footprints.

There are some FAQ entires for library management. Most are written for KiCad V5, but the differences between KiCad V5 and V6.0 are very small in this regard.

For a shortcut:
You probably have to delete (Safer: Rename or move) the sym-lib-table and fp-lib-table files from your configuration directory (Probably ~/.config/kicad and/or ~/.config/kicad/6.0)

Some subtle things have changed here with the transition from KiCad-nightly V5.99 to KiCad V6.0, and I don’t know the exact differences between these.

The simplest way to fix it is probably to just completely uninstall KiCad, make sure that KiCad’s config directory is also deleted, and then do a reinstall of KiCad.

If KiCad is then started, it asks you if it should generate the library tables, and make sure you answer with yes to this.

I think it’s right, since I found when I reinstalled it, the former link info was always there.

Libraries weren’t there until I added it manually.

I thought this thing easy, so I didn’t make screen shot, when I tried on a pc slower in net flow, it just prompted several couldn’t be fetched, and when I tried on a faster net flow pc, everything seemed OK as other installations on Ubuntu.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.