Warning: Footprint 'C1' has no assigned symbol

From PCB Editor, When using Tools → Update Schematic from PCB, I get the following errors.

I get these warnings:

Warning: Footprint C1’ has no assigned symbol.
Warning: Footprint C2’ has no assigned symbol.
Warning: Footprint C4’ has no assigned symbol.
Warning: Footprint C7’ has no assigned symbol.
Warning: Footprint C8’ has no assigned symbol.
Warning: Footprint C9’ has no assigned symbol.
Warning: Footprint C10’ has no assigned symbol.
Warning: Footprint C11’ has no assigned symbol.
Warning: Footprint C12’ has no assigned symbol.
Warning: Footprint C13’ has no assigned symbol.
Warning: Footprint C14’ has no assigned symbol.
Warning: Footprint C15’ has no assigned symbol.
Warning: Footprint C16’ has no assigned symbol.
Warning: Footprint C63’ has no assigned symbol.
Warning: Footprint C64’ has no assigned symbol.

But, when I go to the schematic, I see what I think are standard capacitor symbols for each, the same ones I chose from the standard library.

Any idea why I might be getting this?

When I go the other way, from Schematic editor Tools → Update PCB from Schematic, it places again all of the listed capacitors back on the PCB editor as if they weren’t already there, but with thin lines to the capacitors matching the Cxx name, indicating that it really does have some realization that the capacitors are already there, or maybe the pads are named the same net, somehow? Very confusing.

I’d really like to find a way to “re-connect” all these capacitors to their respective symbols on the schematic, without having to delete them all from the PCB and replace them again, so I’m a bit confused here.

Google is absolutely no help, and I don’t find any other references to that here in this forum.

I can send a link to the KiCad project files if that helps.

Thank you!

Did you associate each symbol with a footprint in the “Symbol Properties”.

See here, above the green line.

If that is the case, the warning should say “footprint”, not “symbol”

Yeah, this is where I’m confused. It’s the Footprint that’s complaining that it has no symbol, not the symbol complaining that it has no footprint. I know how to provide a footprint on a symbol, but I don’t know how to re-associate a footprint with a symbol on the PCB once they become disconnected somehow like this…

Anyone want to see the project files themselves? I’m uploading it right now for sharing

You can re-link symbols to footprints provided they have the same Ref. with “Update schematic from PCB”.
If not the same Refs. you need to place a footprint in the symbol properties.

Kicad is a one way street. Start with schematic and fill in all the details including footprint. You can then modify/change a footprint and update the schematic, but you need the original association in the schematic first.

I don’t think I have ever tried to go from pcb to schematic, and I have not installed 7.0 but this sounds about correct. Is there any way that information in a 7.0 footprint that can specify a symbol?

One thing about pcb design is that (I think it happens often) the pcb layout CAN affect the schematic. Bypass capacitors come to mind as an example. Maybe two locations on a power rail are closer or further than originally imagined, so two capacitors replace one or vice versa. Or maybe you cannot fit a 1210 so you go with two 0805s instead. But when these sort of (Is it called “back annotation”) changes happen I just do it manually.

The problem is, I already did this, and the schematic symbols still have the same footprints that I assigned them before when I did Tools → Update PCB from Schematic.

And like I said, when I do Tools → Update PCB from Schematic now, it places yet again the same footprints on the PCB in duplicate.

This is where I’m really lost. I’m certain that I inadvertently did something to these 15 offended capacitors, but I just have no idea what it could be with my limited experience.

OK, so here’s the project files, if anyone wishes to see what strange gremlin might be hidden in here causing this.


Thanks, everyone, you are all great help!

This image is from 6.0 but try playing with those checkboxes.



We are using PCB to Schematic updates to change net names. We are revers-engineering a PCB, and the schematic is updated from the net name connections we make on the PCB. This is the kind of thing that I’ll be using KiCad for extensively, as we go forward. Especially now that v7.0 has the new features for tracing images on PCBs that make this easier to rev-engineer vintage boards like this.

BobZ that’s it…thank you! That worked perfectly. I didn’t even see that option, but there it is!

Solves the problem right away.

1 Like

I am of the opinion that this sort of thing is a bit “age related”.
Of recent years, I’d sometimes swear that some nasty little gremlin has deliberately hidden stuff that I have been trying to find.
It is not just the occasional words either, stuff moves around in my shed frequently, all by itself… maybe the cat is also to blame? :thinking:

1 Like

Agree, I work the same way.
Need another, or changed capacitor, so, back to the schematic, modify that, update the PCB, then continue.

All good points. But, when the task at hand is to create an unknown schematic from an already-built board, you can see how important this “Update Schematic from PCB” can be, especially when tracing the board and then using Net names to identify how each pin of each component is connected to another. It’s the board that dictates how each pin is connected, to be updated on the schematic.

A completely different use of a wonderful tool…

Anyway, problem solved. Thank again all for your help!

Sounds like your hobby is unforgetting machines. :+1:

Some time ago I wrote:

I think the “Update Schematic from PCB” was not even available then. For some parts I just made a best guess on the schematic, then updated the PCB from the schematic and ran a DRC check. And if there were errors, then I updated the schematic, updated the PCB, and rand DRC again. It was not ideal, but it did get the job done.

In an Ideal world you could use Update Schematic from PCB" and then see ratsnest lines in the schematic, just as you can see now on the PCB. Maybe that will ever be implemented, but for now, being able to import some background images on the PCB is already a great help for reverse engineering.

Indeed it is, and I thank all of you for making it possible!

You got it! How did you guess?? Ha!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.