Via menu on KiCad 5.1.8 on Linux Ubuntu

Hi this question it to everyone who is using KiCad 5.1.8 on Linux. I am using this tool on my linux machine and when I want go to the menu about vias just pressing ‘E’ key I will not go anywhere the only thing what is happening is nothing :frowning: does anyoen has problems like this one?. For answers thank you.

The E key is intended to edit the selected item (a footprint, a via, a segment, etc.)

To edit a via, that via must be placed on the layout.

If you want to change the settings for all vias not yet placed, it can be done from the Board Setup at the top bar, second icon or File->Board Setup

If you want to change te setting of vias already placed, then Edit->Edit track and via properties.

Yes I know this but I can not edit via by pressing E key when a via is already placed on the layout.

For me hovering over a via (when nothing is selected!) and pressing e brings up the “Track & Vial Properties” window:

Does editing the properties of other things work, or do you only have troubles with via’s?

Hotkeys are also editable. Maybe you’ve re-assigned the e key to some other function, or removed it (accidentally). Check this with:
Pcbnew / Preferences / Preferences / Hotkeys

Here it works fine with 5.1.8 on Linux. Make sure the mouse cursor is on the center of the via when pressing ‘e’. Sometimes you need to zoom in a bit (I use the mousewheel).

I have checked hot keys and is under E key. When I will zoom in a little bit and press E key the via will highlight and nothing will happen :frowning:

Does the E hotkey work with footprints and tracks?
Does the right mouse button ->properties work?

Yes E key work with everything except VIA. Right button on mouse also won’t work.

It was my mistake, here I found the answer Via properties not working!, sorry for opening this topic

1 Like

There’s no need to feel sorry, I find the behavior very unintuitive and deceptive. I even commented on that other thread but didn’t remember or nor woud I have remembered the thing even if I would have accidentally changed the setting myself.