Version 6 release plan?

You can set environmental variables in KiCad. For instance, you set ${KICAD6_3D_MODELF_DIR} to
/Volumes/S2/02_Data/01_HEA_Data/_Kicad/Application Support/kicad/3dmodels on your machine. If you later move the 3d model directory you simply adjust where the environmental variable is pointing to the new location and don’t have to adjust each and every individual file.!

Thanks John, but now I understand even less, can’t get the meaning of it. Can you show this in a video?

Think of the environmental variables as a shortcut that is automatically replaced by the software. You set a ‘key’ and a substitution value - for instance, in KiCad you set these in 'Preferences -> Set paths…

Screenshot 2021-07-25 at 17.38.10

For instance, I have set KISYSMOD to /Users/myusername/EDA_Workspace/Libraries/kicad-footprints.

KiCad uses the two files ‘sym-lib-table’ and ‘fp-lib-table’ to do the bookkeeping - i.e keep a record of where the assets are stored. In my file fp-lib-table, the footprints are stored something like


The same is true of the symbol file. Every time KiCad encounters $KISYSMOD, it replaces it with the substitution value to get the full path.

If I decide to move my libraries, I only have to alter the environmental variable value (in KiCad preferences) to point to the new location.

In your case, you have hardcoded the whole path

/Volumes/S2/02_Data/01_HEA_Data/_Kicad/Application Support/kicad

which then makes it difficult to move/rename anything and makes your project less portable as any other user will not have the resources in exactly the same location.


Thanks a lot John, though that’s not the real issue here what I can see, as whatever path variables I set KiCad can not find “its own” 3-d-visuals/.step/.wrl—this problem only in Mojave, all works well from Catalina and also from Windows (which I here prefer to run via Parallels Desktop as I’m on Mac)…

Mojave does have tighter security constraints. It might be that KiCad can find them fine, but that Mojave isn’t letting KiCad read them (or perhaps isn’t even letting KiCad read the directory to find them).

Good point Jeff, but Mojave finds everything else (my own made 3d components/paths). Check the videos in case of wondering—it’s impossible to make THIS Mojave install (here) to find KiCad original 3d-parts. Again, it works very well in both Catalina and Windows on this Mac. I will now try to reinstall Mojave once again, I think that will help. If it doesn’t, I will try again…

Maybe your mojave install doesn’t mount the flash drive under /Volumes/S2 ?

Well, thanks guys, it’s time to move on here, wishing for a great KiCad 6.0, if it will be released, but until then will try to find a more easy way to do cad works until/if 6.0 is out… and below just a short successful update in this topic:


In April I decided to learn Kicad but was riddled with the choice between choosing v5 or v6. I tried for a bit the v5 but it seemed so old and in some ways different to kicad 6 so took the risk and download the nightly release and have been able to use it and learn it successfully. I have already sent files to JLCPCB for SMT assembly and they were perfectly made.

So far the best decision ever. I hope the final version is released soon.

For reference it is working perfectly in public beta release of Monterey OS in Mac M1.

Kudos to the kicad Dev team.

1 Like

Not that many Critical or High Priority issues left now and some of them are “need info”
I’m seeing about 10 commits a day recently.

My early impression of 5.99 is that it is stable, but the subtle user interface changes and extra options take some finding. Some of the defaults are opposite to the way 5.1 worked.

As far as I know, only unfinished python API for eeschema is a show stopper for release. But I don’t understand why KiCad is not released as RC1 version as currently is. All my work projects are made with v5.99, none of them was broken during 1.5 year of using v5.99. Currently, v5.1 eeschema does not have python support at all, so it makes no sense to blame pythons non existence right now. All other improvements in v5.99 are superior regarding v5.1, users could have a great benefit from v6 if it were released today :slight_smile:

A beta version would be great, but it can’t be called RC. A Release Candidate (i.e. a candidate for releasing as-is as the final) means that there are no known bugs or changes left which are scheduled to be fixed or changed before the final release. It’s usually meant for catching possible critical bugs a week or two before the final release. The difference between the RC and the final should be none, or only a few critical bugfixes which weren’t known before the RC.

There was discussion about the version naming which you can find by searching if you really want to, but I won’t give a link to it because further argumentation seems to be useless.

In any case I would appreciate an official beta version.

Thanks, yep, probably I should mention Beta, not RC in previous post :slight_smile:

Some recent bug fixes caused serious problems like this one (already fixed)

I think 5.99 is probably fit for a Beta releases now

My story almost exactly.

I can see the Python API being pushed to a new V6.1.x at this rate

How/where can I download the newest release candidate of KiCad 6? I am fully aware that there may be bugs left… But could there be bugs destroying Wndows? I assume not.
I am willing to take the risk of bugs, I will test on a simple project (more correct, a copy of it).
Windows 10, 64 bits, 24GB of memory, core-i5.

updated a few times a day as the CD builds against the latest commits

I’ve been using KiCad 5.99 on projects for most of this year, and have not hit any serious problems. I update every month or so. Can only remember hitting one noticeable bug, but by the time I found it, I simply updated to the latest and it was fixed. Your mileage may vary, but my experience has been good.

I have tried once at Windows 10 (may be 2 month ago) and I had a problem to route few tracks. I pressed ‘X’ and in 3/4 times nothing happened and in 1/4 times I just could route a track. Didn’t found the reason for such behavior.
It was at my wife’s laptop. I have 2 PCs with Windows 7 and one with Windows XP so I can’t use KiCad pre-6.