Version 6 release plan?

It isn’t. OS has nothing to do with this, your settings and paths are different, that’s it.
To debug it take one single footprint that doesn’t show up even though you have the file, look at it’s 3d model path as is in pcbnew (not library editor), check for any path variables, expand them manually using text editor and you will see a mismatch somewhere.

Tried to fix it with the paths etc. Didn’t manage to get it to work. So to save time I removed every trace of Kicad (Uninstalled in Mojave and deleted all files in Preferences/Application support etc) and reinstalled the latest KiCad nightly build and set up all the path(s) again. I also did the same in Catalina and finally also in Windows (edit below). Now the project works well in 2 out of 3 environments (here).

1 Like


May I suggest you change the title of your post?

Now it is easy to interpret as a statement for the release of KiCad V6.
It would be more appropriate to formulate the title as a question.

I changed it. ---------------

Thank you very much.
I just noticed a pencil mark behind the title. Apparently I also have the rights to change titles of posts :slight_smile:

Well, it didn’t really work well from Windows even with the reinstall (via Parallels Desktop) but it doesn’t matter so much to me as I will never use it probably this way anyhow (in windows). I have the “path” from all versions (Windows/Catalina/Mojave) to the same external USB drive, to make it more possible to work from wherever I might go (from whatever hardware/machine/software). That will continue to be the goal. It has to work “right out of the box” no matter what.

Hey everyone! I have been away for a while. I actually hoped an Alpha 6 would be available by now, but the same stuff that had me occupied seems to have affected everything, everywhere. I am not going to start where I left off. I am starting new. I am asking for the best (least buggy) latest version so I can work from a book and finish a project. I fully intend to delete all that is kicad and start all over so that nothing stands a chance of crossing over to create an issue. Not that I do not expect windows to find a way.;-). Thanks for the help folks. Glad you are still slaving for the cause.

The least buggy version will be the latest version in general :slight_smile:

HA!HA!HA! Pretty crafty answer John, I guess I asked for that one. Thanks, have a fun day.

I guess I should be more specific: earlier in the release cycle, more features get added at unpredictable times, and some new nightly might be more buggy than an older nightly.

Where we are right now, outside a few limited areas such as the Python API that is coming, a new nightly should in general only be less buggy than an older one.

Just to add to Jon’s comment, for windows, the nightlies are downloaded here:

The latest version will be at the bottom of the page (the versions are sorted in ascending date order). Also note there are 4 versions of the nightly build:

  • i686 = 32-bit build
  • i686-lite = 32-bit build without the official libraries included
  • x86_64 = 64-bit build
  • x86_64-lite = 64-bit build without the official libraries included

Generally you’ll want the x86_64 version for the first installation. You can update to a newer version each day by downloading and running the x86_64-lite. This will make overwrite your existing installation while keeping the official libraries installed and is much faster as you don’t have to also install the libraries again.


Awesome that helps a lot, Thanks guys. Back to the learning pit.

Too bad, after having to reinstall Mojave here the Path Problem is back, for another project, all 3D models works ok in Catalina, but not in Mojave, doesn’t help to do the complete uninstall/reinstall this time, so now only Catalina works for this project; the 3D components are available in “Footprint Properties” but when checking the project “3D viewer” (ALT+3), nothing there (only the models I have made myself are OK, none of the Kicad “defaults” are there). I guess this is fixable—if you know how to do it, whew!

Please report this, few of the developers use Macs and even fewer have sight of the different versions.

I notice that only the .step model is linked in the second screenshot. On my Catalina install (both 5.1.10 and 5.99), the .wrl model is the one that is linked.

Hi John, you can change that “.wrl” to “.step” and it will work the same. Here, none of these works (on Mojave), I have tried both “.wrl” and “.step” several, several times; it’s explained here: (btw I don’t know how to “report” eventual bugs…)

that library has a hardcoded path ( /Volumes/S2/02_Data/01_HEA_Data/_Kicad/Application Support/kicad…) as oppose to the variable expansion ( ${KICAD6_3D_MODEL_DIR} ) how and where did you get those libraries?

it might be work a re-install and a deletion of the kicad settings directory as something isn’t setup correctly

1 Like

As I think I mentioned earlier, I moved the Original Libraries (the path setting in Kicad also) to an external USB drive to be able to access THE SAME libraries from whatever OS/Version of Kicad one of us can prefer to use. Also, again, it works from both Windows (at my place via parallels desktop) and also from Catalina – all set to the same path which still is that external USB drive. Here it’s showed again (just tested) in Catalina:

I get that, but it might be worth fully reverting to confirm there isn’t any other problem

Then it would be better to manually set kicad6_3d _model_dir from the project manager rather thanhand crafting every entry

Thanks and my apologies if I don’t really understand what you mean with this.