Version 5.0 woes

I’m super happy that Version 5.0 is out, however, it seems to have some teething problems, at least with my install.

  1. Upon the first use of the program, I foolishly selected Graphics Acceleration, thinking that my i7 Laptop would be OK. Now, when I open KiCad, I often get an error for wxWidgets. This can be triggered in PCB New by accessing the Tools menu particularly. I have since uninstalled and re-installed, hoping it would give me the graphics option again but sadly not. Is there anywhere I can set this manually?

  2. Upon opening PCB designs from v4.0.7, the top layer copper pour covers the component silk screens and pads etc. Can I get back to the v4.0.7 type display so that I can work with both top and bottom pours with silk screen on top? I haven’t had a chance to try a new board yet to see if it is a ‘feature’)

Many thanks for any help.

When asking about problems, always tell what your system is. Copy the version info from Help->About dialog.

“Works for me”, but on the other hand I don’t know what kind of error you are talking about and what exactly you do to trigger it.

May be this already reported bug ?

F12 -> fallback (non accelerated) modern toolset
F11 -> accelerated modern toolset
F9 -> legacy toolset

or in the preferences menu of pcb_new / footprint editor.

This is also documented in the FAQ of this site: Pcb_new: What is a canvas? (default [legacy], open-gl [accelerated] and cairo [fallback]) Is there a difference?

1 Like

You can minimize the Window and click “Cancel” on the Error Window.

With the layers manager, make the F.SilkS the “active” layer and the front silkscreen will be shown over the copper.

@Efcis Yep, that is indeed the one. Thanks for pointing me at the workaround.

@Sprig Yes, that does work but I really want the familiar transparent type of display in v4.0.7 I found it much easier to understand what was going on with that.

Ah ha! @Rene_Poschl That sorts that one out. I’m very used to the Legacy Toolset view - Many thanks for effectively restoring it for me :slight_smile:

Apologies, I was in a rush and I’m not used to forum etiquete. I appreciate everyone’s help though. I’ll remember for next time.

You can also adjust the transparency of the currently active layer. (I forget the menu command, but I think the keyboard commands are “[” and “]” (without the quotation marks)). The way it works is if you have front copper selected it will be brought forward of all other layers presumably because the program thinks you are interested in that layer because you selected it as active. You can adjust it’s transparency and that transparency level will be remembered until either you change it or you close pcbnew. But the you select the back copper. That will then be brought forward and block view of all other layers. Again adjust the transparency so you can see the other layers behind it. Now, until you close pcbnew you should be able to see through the front copper and the back copper when you have them selected.

For me, personally, three taps of the “more transparent key” (I forget which one that is off the top of my head, and don’t currently have access to KiCad to check) seems to be about good. Sadly, I don’t know of a way of setting a default layer transparency level. See the following message from @Rene_Poschl on how to change this setting more permanently.

1 Like

You can even permanently set it in kicad 5 modern toolset. Middle click on the colored square next to the layer name and you can choose the color and transparency of that layer.

1 Like

Sweet. Thank you for that.

@Rene_Poschl & @SembazuruCDE Awesome guys, great stuff :smiley:

Double clicking on the colour swatch works too (at least on OSX).

1 Like

Works in linux as well (at least under fedora)

1 Like

Beware that the Legacy toolset is probably going away… next version or so. At least that is what I seem to recall being said about it.

I do find the Modern (OpenGL) toolset to bit a little awkward at selection compared to the old one but it is usable at lest compared to before where I couldn’t really get anything done in it on 4.x.

Not sure why you’d have issues with integrated graphics… I have a 3540M with HD 4000 graphics and it works here. I did install it on XP in a VM just to see if it worked and the raytracer crashed but everything else worked.

That would be a shame. I find the Legacy Tookit colours/transparency very easy to use and the modern tookit extremely awkward. I’ve set transparency on the copper layers but that doesn’t help a lot. I think I’ll be sticking to v4.0.7 at the moment.

I’m not sure the wxWidgets has anything to do with the graphics. That was just my assumption having seen graphics glitches in the past.

Can you give screenshots or even, and preferably, a screencast of what you want? For me it’s hard to find it out from the text only.

@eelik I’ve got to a place that’s useable now. I just cancel the error when it happens and carry on.

I much prefer the Legacy display though. I can’t even get close to it with the modern toolset.

1 Like