Various shortcuts don't work


I’m trying to learn a few shortcuts and I’m referring to the following page

  1. I would like to change the trace size from a particular point. I press x to be in trace mode, then press w. Nothing happens. I just found out that pressing Q works. Q for width. OK, I can live with it… Did the shortcuts change for some reason?

  2. The trask posture doesn’t work. Not always. In some cases, it does, but right now I’m trying to change the way the trace leaves a pad. I would likt it to go first horizontally and then at 45degrees, and it does the opposite. Pressing / doesn’t have any effect.

  3. Change the router settings. In routing mode, (after pressing x), I have right clicked, and the context menu tells me I can change the router settings by pressing “ctrl+,”. I have tried to press ctrl and then , while holding control. Doesn’t work. Just in case, I have tried to press + while holding ctrl. Doesn’t work.

Well, it’s an endless quest of shortcuts, and only few of them seem to work. Is there another link where I could find a really working set of shortcuts?

I have also noticed that my setting disabling center and warp cursor on zoom comesback every now and then. Is there any way to get it frozen forever? Same for pan when approaching border.



Firstly what graphics mode are you in

The whole shortcut/hotkey thing is crappy IMHO. It probably depends on your keyboard layout or OS or both or some combination of them. Ctrl+, didn’t work for me, either, at one point. (Now it seems to work with the latest self-compiled code. Or it was in Windows and still doesn’t work, I don’t remember.) And no international application should ever use any non-alphanumeric characters as hotkeys (quick shortcuts) because what is quick and easy for American keyboard needs Shift or AltGr for many other keyboard layouts. Not mentioning the confusion which arises when you have / behind Shift+7 - is it / or Shift+7? Or what would Shift+/ mean if it’s already behind Shift?

The developers have already recognized the need for better and more flexible way to define shortcuts. But it means quite much work. Unless you have a really good library engine behind the shortcuts (which KiCad apparently doesn’t) you have to create your own, and it’s not simple, otherwise it would already be good.

There has been discussion that documentation is lagging behind the code and more effort will go into documentation once 5.1 comes out.

Thanks for your replies.
As for the graphics mode, it’s the modern toolset (accelerated) mode.
OK, documentation lags, but anyway I could verify that making a PCB is faster than with the tools I was used to, so I think I’ll stay with Kicad for my next designs. I will still have a lot of questions…


1 Like

If you start the router, you can change the interactive router settings by pressing Ctrl+,. Here, you need to unselect Optimize pad connections to let posture change how you exit pads.

The mnemonic Ctrl+, means press and hold Ctrl then press , in addition to that. Do not press the + key. When you right-click, you will also notice the context menu and you can select your preferences there. If the key-combination does not work for you, I would recommend editing your hotkeys. There you can re-map the command to the same key combination but KiCad will tell you what it sees when you press Ctrl+, It may be that your system is mapping the keys to something unique (laptop keyboard maybe?) and asking KiCad to remap the hotkeys will show you what.


KiCad has 3 differnt canvases with two different distinct tool sets.

The modern toolset will be the future of kicad while legacy represents the past.

Some tools are very different in the modern toolset than in the old legacy one. Routing is an example for that. In legacy you had very little support by kicad.

Everything needed to be routed manually. In the modern toolset we have the interactive router. I would describe this as a semi automatic router.

The interactive router has 3 modes:
In walk around mode it is a semi auto router for the currently placed trace. In shove mode it is a semi auto router for the already existing traces that are pushed away.
To get the old manual way in the new toolset you need to switch to highlight collision mode. (This is not an exact reimplementation of the legacy toolset but an approximation of it.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.