V6 No Libraries available


In a folder
…Documents > Kicad > 5.99 > footprints

I have found two folders called located
‘My Custom Library’ dated 2nd Feb 2021
‘My Custom Library.pretty’ dated 28/11/2021

My ‘Custom Library’ is empty
In ‘My Custom Library.pretty’ there are my various footprints with the ‘.kicad_mod’ extender

I know I have added components to ‘My Library’ within the last month. I did the upgrade to v6 on o around the 28th Nov.

I have also found a file ‘My Library.lib’ (1KB) in my download component folder dated 24/10/21 (not sure)
and a ‘My Library.bak’ (6KB) dated 29/11/21

I cant remember the history or time line of ‘My Library’ it might have been the first try at setting up a library structure following a tutorial before the proper one - I dunno???

10Km out of a country town Clunes, Victoria, Australia.
Most towns and the adjacent 5Km radius have fibre, but outside that you’re usually stuck with ADSL on copper or satellite.

My download failed tonight. Will try again in the morning, but I’m pretty sure if a new download includes the Kicad libraries my personal ones are deleted and I have to reinstall them through the symbol manager.

It looks like your libraries are really gone though. Not much information in1KB or 6KB. :slightly_frowning_face:

A suggestion for future library management:
Find a place on your computer, create and name a folder "libraries (or whatever) then create files in that folder for your symbols and footprints then, using the method I described above, install them via the library manager.

I keep my libraries on a separate data drive. At the moment I have 8 PCB files and 10 Schem. files. (probably about 500 symbols and footprints… I never use stuff from Kicad libraries directly. Always copy and often modify into my own libraries.
A typical library path looks like: /media/Jan/JanD/kicad_libraries/1a6_ICs/schem_kicad_sym.

My OS is Linux but Windows would be similar except media & / I think.

So it seems that you haven’t lost your libraries after all, you only need to add them to your installation:

If you open KiCad, in the project manager Preferences->Configure Paths you will get this window:

there you should add the NAME and PATH to your libraries, in my case I use USER_FOOTPRINTS and USER_SYMBOLS for the environment variable names and its paths.

once done that, you are still not able to use them in your projects until you add them to your library lib-tables (footprints and symbols)

For the footprints in PCB Editor (PCBNew) you should go to Preferences->Manage footprint libraries and then click on the folder button to add your libraries to the table.

after clicking ok, you should be able to use your custom footprint in your projects,

hope this helps

This are the relevant FAQs for the topic, however, they are slightly different because they were done with v5 in mind, but still give you a pretty good idea how all works.

Still No!

I cannot get my ‘old’ stuff into v6 as a block. I have to setup a new library / path structure in v6 and go to Symbol Editor or Footprint Editor on the main screen then import them individually into the new libraries.
Thanks guys don’t waste too much time over this - there is a workaround solution after all

Oh just started up v6 and now the components I entered in the newly setup library have disappeared from the ‘Add Symbol’ system in the schematic.

I’m nuking v6 and v5.99 will probably end up reproducing in v5 and wait till v6 is more stable and let it update conventionally - shame there’s nice feature and GUI in nightlies

And yes I have scanned with Kaspersky etc

Thank you all once again

While you are free to do this if you’d like, there are no known stability issues that would cause the problems you’re having. What has happened is either a matter of user “error” (in quotes because clearly we could do a better job of explaining to users how to make things work properly) or (less likely) a bug that is not reported at the moment and therefore will not be fixed.

I’m not quite following all the steps you’ve taken and what you’ve tried, but so far it sounds like you have misplaced the location of your old symbol library. Unfortunately I’m not sure what to suggest about that – I certainly don’t think it’s likely that KiCad somehow deleted your library file.

To sum up, here is my recommended way of upgrading KiCad versions (from 5.1 to 5.99, 5.99 to 6.0, or 5.1 to 6.0)

  • Start with default settings if coming from 5.1. If coming from 5.99 to 6.0, importing settings is fine but do not select the option to import library configuration.
  • When you first start the schematic or board editors, choose the option to copy the default global library tables
  • After doing so, go to the library table configuration and re-add any custom libraries you were using in your old version

There are shortcuts and “power user” tricks that can make the above steps faster/easier, but this way is the most likely to work without any confusion for new users.

HI @Docara

When you get to this recommendation:

Create new empty personal libraries using the method both I and @der.ule mentioned. THEN find your symbols from wherever you can and enter them into your new personal libraries.

Hi craftyjon
I think it was a matter of user error, however , ‘something’ went wrong and it would be nice to know what.
You are not alone I’m not following the steps I took LOL - what started out as, perhaps, a simple question has balloon somewhat.
So as far as I can remember this is the sequence of steps I took

  1. Was running v5.99 (look above for build code) quite happily until I started to layout PCB

  2. thought I’d try a standalone install (new location) of the latest (Saturday) v6. When first run prompted for upgrade blah blah which I declined it case it buggered up my project.

  3. Was impressed with the progress of (now) v6 so uninstalled standalone and went ahead with a ‘proper’ fresh install opting for defaults paths etc. This time no upgrade prompt on first run (which you helped resolve)

  4. No ‘My Custom Library’ of my components, went hunting tried Configure paths, etc all the places you’d expect to configure a library. Found a folder named as expected, tried to add it to library structure and I think I clicked a button which said something like ‘migrate legacy library’ or something (bottom right of window)

  5. Gone around the houses trying different things from cutting & pasting, pointing to locations etc still lost previous configuration. As mentioned previously here I can see files in a folder but v6 refused to see them let alone import them and use.

  6. lastly today I realised a lot of the settings didn’t take hold unless I completely restarted v6 (surprisingly) by which time I’ve made too many changed to go back to the line drawn in the sand just after upgrade.

I think I just need need to start afresh with all crap removed - clearly it will have to be a later version or I wont be able to access my existing project (I realise i’ve done too much tweaking of components and footprints to go back to v5.1.x)

What is the best way to wipe my system of Kicad to start again - clearly uninstall leaves things behind.

Thanks again

Right I have completely removed v5.99 & v6
Installed the latest v6 nightly

So what is the relationship between configuring paths and adding new libraries to ‘Manage Symbol Libraries’ & ‘Manage Footprint Libraries’?

If I setup, say, a folder called ‘My Library’, do I then setup 2 subfolders called, say, My Symbols & My Footprints. Then just point the two new libraries to to these locations?

I’ve been around this game for over thirty years it shouldn’t be this obscure to do a basic task

You would need to delete the folder %APPDATA%\kicad to wipe everything; the uninstaller does not delete this.

Configuring paths is not necessary to add new libraries. It is necessary if (1) you want to use a non-standard configuration of the default KiCad libraries, or (2) you want to add new libraries using an environment variable (which you will see some people recommending but is not required)

To add an existing custom library, use the Manage Symbol Libraries or Manage Footprint Libraries dialogs.

If your library does not exist yet, you can’t add it this way. Instead, go to the Symbol Editor (or Footprint Editor), choose File > New Library, and when prompted, choose to add the new library to the global library table.

No, you can’t add a library by just creating folders in your file manager* – you need to create them inside KiCad using the symbol/footprint editors. Once you have created them, or if you get a library from somewhere else, you can add the existing library to a new KiCad installation using the library manager dialogs.

*well, you could technically, but you’d have to create some very specific folders and files by hand, and that is not how we’d recommend doing so.

1 Like

Thank you craftyjon this is SO helpful.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.