V6 No Libraries available

Working on a project using v5.99 but was curious to see what v6 brought to the party. So I chose to install v6 as standalone as I could and opted NOT to upgrade the v5.99 libraries when prompted just in case there was a problem and I couldn’t go back.

Subsequently I noticed v6 had sorted out a problem with v5.99 routing problem I had and decided to go forward using v6. So I uninstalled v6 and reinstalled using it’s defaults expecting the import libraries option to reappear - it didn’t. I am now left with no libraries or footprints available in v6. I have tried using ‘Configure paths’ and ‘Manage Libraries’ to point to my old libraries etc buy nothing

So question how do I invoke the v6 library upgrade to bring in my 5.99 libraries or get v6 pointing to my old ones?


I will not be able to provide your answer…but it sounds like you are using the KiCad standard libraries? I pretty much stay with my own custom libraries. Last night I spent maybe 1 hour fighting to correct paths; mostly to eliminate some listed libraries which were not working but which I did not need anyway. I would have a tough time to tell you exactly what I did but it was all eventually done from footprint manager.

Yes I am using the standard libraries from 5.99 with 1 additional custom library.

I’ll look around footprint and symbol importing see if theres anything there


What OS are you using?

Note that V6 is not out yet – you are still using a nightly build.

Hi Craftyjon

Downloaded ‘latest’ nightly on the weekend
Win10 64bit

Application: KiCad (64-bit)

Version: (6.0.0-rc1-170-g6652e5acf4), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 18363), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Nov 27 2021 00:00:09
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

OK. On Windows, open the folder %APPDATA%\kicad\6.0 in an Explorer window and delete the files fp-lib-table and sym-lib-table. Next time you open KiCad, it should offer to copy the default global library tables – take that option and you should be OK.

1 Like

Worked flawlessly thank you

Additional, I had a custom library setup called ‘My Custom Library’ which has now disappeared from both 5.99 & 6.0. In trying to add the handful or so custom components back in to v6 (using ‘Symbol Editor > File > Import Symbol’ I now get an error ‘Symbol Library (whatever) is not writable’ which is different behaviour to 5.99

any thoughts?

If you have a custom library, you should be adding it to your library table, not trying to import symbols from it into one of the existing (read-only) libraries. Use the Manage Symbol Libraries dialog in Preferences menu.

1 Like

Yeah I do try all the options before I post.

I have found a folder with in 5.99…>footprints with the .pretty extender which contains the files I recognise (they all have .mod extenders) . Now I cant find anthing similar containing my symbols which was why I was tying to add via import in Symbol Editor

Is there anything posted anywhere which explains files and file location?
I have a working system in 5.99 just cant duplicate in 6.


Compare the symbol library table configuration between the two, you might spot the issue. Likely you have an entry in your 5.99 table for your custom library, and it is missing from the 6.0 configuration.

I’ve been doing what you’ve suggested but like I said it disappeared from the 5.99 configuration as well - thought there might have been an easy fix ah well !!!

One final quick question - other than reference to 5.99 and 6.0 in the file structure are all other files the same essentially the same so cutting and pasting etc should be fine?

What I am referring to is they were talking about changing the actual structure/format of the file itself and different versions of the nighties might not open others, guessing all this has been finalised by now y/n

Yes (at the moment, at least)

Hi @Docara
Did you look, in 5.99, at the very bottom (under all the Kicad libraries) of “Manage Symbols Library” under “Preferences” for your missing library?

Hi Jmk

Thanks for the suggestion but unfortunately yes - that’s where the were.
I have done a complete system search for my custom library but the only files I recognise are the new ones I created in v6. I just can’t get my original library or library structure back even now in v5.99

They only way left open to me using v6 is to import each symbol and associated footprints piecemeal into a new library. Luckily I haven’t created many new components just lots of downloaded ones.

Its really frustrating I can find them in file explorer just not in Kicad - I have tried copying and pasting or pointing to them via ‘configure paths’ or manage XXXXX etc in preferences v6 just will not show them unless created fresh within v6.
even though

Ah! well!!!
Thanks again both for your input


If you can find them in file explorer you should be able to access and enter the file by clicking on the black folder icon at the bottom of Preferences/Manage Symbol Libraries/Symbol Libraries. This takes you to everywhere on your computer, then, when found, just do a bit of mouse clicking.

Alternatively, create a new library folder (same Symbol Libraries page) by clicking the + button, double click on the empty library path box, then click on the black folder symbol that appears. You get the same result as above.

Don’t forget to fill in the other blank boxes.


I’m sure that what I was trying to do. However I will need to check ‘Dont forget to fill in …’ just to make sure.

Interestingly (I wonder if this is related) I have since found out that both my active project AND included sample projects are ‘Read Only’ and ! I have tried to change DRC settings but v6 won’t let me.

It does seem v6 RC has issues that the previous versions didn’t !!
Is there anyway anyway to completely nuke Kicad from my system and start again? (leaving v5.1.11)


5.1.11 is 5.1.12 now and both are completely independent of 5.99 now 6.0.RC
Exterminating 6.0.RC will have no effect on any 5.xxx

Did you manage too find your library folder via the folder in the symbol library?


My original configuration which I had and was working is gone (for both v5.99 & v6) after I installed v6.

I can find my folder with all my downloaded files containing symbols, footprints, 3d but the Kicad ‘library’ that I was using in the various editors across Kicad with v5.99 has effectively gone. Whilst I did find a file name named as the original library there’s now nothing in it (0bytes) after accepting the option to convert or something similar.
All associativity from the schematic to the (in progress) PCB has been lost because there is no longer a library they point to. I’ve tried recreating it but Kicad doesn’t recognise the new name so I have to recreate symbols and footprints across my (albeit small) project in an new libraries.

Sorry I cant be more descriptive I’ve tried SO many obvious things that I’ve forgotten what I did or didn’t do and not that conversant with Kicad’s library structure.

The bottom line for me is, when I upgraded to v6 from v5.99 the second time and accepted the choice to import or convert (whatever the wording was) using my original library setup - the library has gone for both v5.99 & v6.

The only choice I have is to recreate everything I had from scratch and associate / update components on an individual basis as needed.

Other than issues in the PCB Editor (which was why I tried the upgrade), for me, the version I was running (below) had a far better user experience than the latest v6 - there’s something strange going on with v6
Strangely, after the umpteenth time of opening up Kicad, just tried again and it no longer says the project is ‘Read only’ when trying to change board settings so there is some progress!!!

Version: (5.99.0-9294-gd3cf97847e), release build

Version: (6.0.0-rc1-170-g6652e5acf4), release build

Ah well the joys of running a nightly LOL

Did you know where your personal library lived before your disaster?

I’m at this moment downloading the latest 6. whatever and I’m pretty sure every time I download I have to re-install my personal libraries in both my symbol and footprint libraries… I’ll let you know in a while when the download is complete. We live way out of town so are still on ADSL2 rather than Fibre.

Ooooh good question

Let me look around PC in case initial frustration caused major brain fart and ended up talking BS
Will be back in 10 or so - hopefully before you spent too much time your end.

Oh just curious where do you live (ADSL)