Uploading file production issue


#1

recently i tried to order my pcb but one of the files has the issue as follow. anyone how to fix it?

B.SilkS.gbo:File format can’t be recognized(They’re not Gerber 274x or excellon files)


#2

Does the Fab support Bottom silk screen, not all do?
Does the file look sensible in a text editor?


#3

Might be you use settings in the gerber export dialog that are different than what your fab expects.

Does your fab give any details over gerber version and “dialect”?

The easiest difference can be in the file names. Kicad can export files with different file names/endings. From your name “B.SilkS.gbo” i suspect you enabled “use protel filename extensions”. Maybe try without this enabled.


#4

It might not be your problem but the other day I tried to submit my gerbers to the manufacturer I always use and it came back with all kinds of errors which didn’t seem to make any sense. Finally when I went to check the gerber plots on the manufacturers site half of them where blank. When I looked at the same gerbers with Kicad gerber viewer they all appeared fine. Turned out that in one of the latest nightly releases X2 attributes were added for gerber generation and those where checked by default! As soon as I unchecked those everything worked just fine.


#5

I haven’t encountered it myself, but comments on this Forum indicate that the “X2” extensions are not yet widely supported. Even worse, as your experience shows, a Gerber file containing X2 commands is not backwards compatible with some older Gerber software. See previous threads at :
Gerber X2 in Nightly , and
RS-274-X Gerber

The consensus of those threads is that the X2 option should default to “OFF” for now. Before making a Bug Report, can somebody who is running a very recent Nightly build verify whether the X2 option defaults to “ON”, or “OFF”?

Dale


#6

I tested it on a fresh ubuntu install (within a new virtual machine, new empty project).
It does default to OFF.

Kicad version info:
Application: kicad
Version: no-vcs-found-9413793~61~ubuntu16.04.1, release build
Libraries:
wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.10.0-42-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.58.0
Curl: 7.47.0
Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON


#7

The bug (defaulting to X2) was fixed quite a while ago:
https://bugs.launchpad.net/kicad/+bug/1733876


#8

Yes, @Rene_Poschl verified that the fix is in the recent Nightly. Based on the report from @ArtG (in Post #4, this thread), I was concerned that the bug had emerged from hibernation.

Dale