Unexpected errors with simple opamp

I recently installed KiCad 7.0.0 under Linux Mint Vanessa and am getting unexpected errors when running a SPICE simulation with a simple opamp circuit. I can get expected results with just resistors and power supplies. The Opamp I’m using is the simple SPICE opamp.

Below is a copy of the NETLIST:
KiCad schematic
.save all
.probe alli
.dc V1 200m 2.5 250m
V1 Net-R1-Pad1 Net-U1– AC 1 SIN( 0 1 1k 0 0 1 )
XU1 GND Net-U1– Net-R2-Pad2 Net-U1-V+ Net-U1-V- OPAMP
R1 Net-R1-Pad1 GND 47k
R2 GND Net-R2-Pad2 100k
V3 GND Net-U1-V- 5
V2 Net-U1-V+ GND 5

I get the following error message when running the simulation:

Background thread stopped with timeout = 0
Warning: there is no circuit loaded.
Command ‘remcirc’ is ignored.
Note: No compatibility mode selected!
Circuit: kicad schematic
Error: unknown subckt: xu1 probe_int_gnd_xu1_1 probe_int_net-_u1–__xu1_2 probe_int_net-_r2-pad2__xu1_3 probe_int_net-_u1-v+__xu1_4 probe_int_net-_u1-v-__xu1_5 opamp
Error: there aren’t any circuits loaded.

I don’t profess to be an expert in this, but the error does not appear to line up with the circuit I’m working on simulating. Also, the compatibility mode is selected to SPICE.

Is this a “cockpit error” on my part or something amiss with the software? If more information is required, please let me know.


Post the project, then we can contribute.

Not sure how to upload the project. When I click on the upload icon, I get a message that says new members cannot upload attachments.


Limitation for new users (spam avoidance). I’m sure a moderator will step in here.

Done. OP can upload.

VR_Amplifier.kicad_sch (25.6 KB)

The netlist tells me that you did not attach any spice opamp model to your U1 opamp symbol. This needs to be done manually and is required for the simulation.

You may find models at Spice models and model parameters for ngspice circuit simulator in the basic model parameter set.

Can you provide some more detail.

When I get to the Symbol Properties page and select the Simulation Model button, the “Built-in Spice Element is selected and the Device shown is: Raw Spice Element”. There are no drop-downs for Type.

Does an actual model need to be selected in the "SPICE model from the file area?


Indeed you will have to grab one of the OpAmp models, and load it by ‘Spice model from file’.

Then you have to check the ‘Pin Assignments’, because symbol and model pins may differ (same number of pins hopefully, but potentially a different sequence)…


Thank you for your patience.