Unable to make any wire connection in schematics

Hello,
This is my first Kicad schematics, and I am unable to to connect anything through wiring. Now, I only have two resistors in the schematics, and one wire connection, and after the ERC test I get errors like “Wire not connected to anything”
I changed the grid size so many times from small to large, but got same result.
The strange thing is that the wire is actually connecting the two sides, and if I drag any resistor, the wire is extended with it. Also, the two resistors are sitting on grid lines.
I also used “Align elements to grid” feature.
Could the ERC utility be giving erroneous result (maybe at the beginning) !
I reinstalled Kicad 6.0.6, and I cannot believe I spent hours on such a silly thing. Why is it so difficult to draw a wire to connect two elements in Kicad ? This is not supposed to be a rocket science !!!
I’ve used other schematics before, and even electrical circuit simulators, and I do not remember I ever struggled to draw a wire !
Thanks for any suggestion.

I don’t use ERC so I’m not sure, but as you have only one wire then may be KiCad tries to tell you that other resistor ends are not connected.

You should not change grid size. Work with grid set to 50 mils.

The ERC puts an arrow at the location of the error, and it is always the second resistor.
Currently, my “Current grid” size is 50mil
And Grid1 + Grid2 (in the Fast switching" are both 50mil.

I just fixed it by clicking the “Annotate schematics” tool.
This is really so weird !
What does the “annotation” have to do with “wire not connected” ?
Anyway, thanks folks for your suggestions.

Show us the schematic. The ERC error messages are sometimes a bit misleading.

It does say in the ERC that elements not annotated, but annotation is something you do at the end of schematics, so I ignored it, and instead concentrated on trying to fix the issue of “wires not connected”.
Here is the image:

Try naming the resistors, eg, R1 and R2 instead of having them both as R?.
ERC doesn’t like that.

As I said, the problem is resolved by “Annotation”.
But still, in my opinion, the ERC should not give “Wire not connected” error just because components were not annotated and have same name !
It should just give an annotation warning.
This misdirection caused me to waste few hours !

Perhaps, but not due to KiCAD. Rather due to bad design practice. Not giving parts references and then running an ERC check is bound to fail.
Lesson learned, I hope.

1 Like

Why then KiCad allows this, if it’s bound to fail? KiCad should outright refuse to run ERC without proper annotation.

Why are you asking me? I’m just a user, not a developer. But as I wrote earlier, the ERC error messages are not the best.

I do not agree with this:

In KiCad V6 all parts (even wires and junction dots) have an UUID.
My preference is that KiCad uses these UUID’s for all internal actions including ERC and the Footprint Assignment Tool, and the RefDes is only used as a convenience for humans who can’t remember UUID’s.

This would allow all those tools to work properly without having to run the annotation after each small edit.

The only consequence of this would be that you can get ERC messages like

R? (uuid 400a0984-7cdc-4340-bad5-2c10a9f277a2) is not connected.

I regularly run ERC as a schematic grows from an initial design into maturity and having to run the annotation after addition of each schematic symbol is a bit of a nuisance.

Not only that. I use to copy and paste text from inside the schematic and also, duplicating things in the files system directly for a bunch of non-standard ways of speeding up things. Then in this case those UUIDs are also pretty complex to keep checking since the anotation can be easily recreated using Kicad.

You will only see the UUID’s for parts without a proper RefDes, No normal human would prefer to work with names like 400a0984-7cdc-4340-bad5-2c10a9f277a2, but you will never see them if you run the annotation.

I would also be happy if ERC would just show something like:

R? is not connected.
and then jump to the right resistor if I click on it.

I definitely expect to see ERC and DRC improved. That ocean of “the same looking” lines of a big project that is starting to get in shape is so hard to understand quickly. Everything there looks equal.

There is no way to sort things or search for things. They are also not grouped or folded by the related type.

For instance, I use to tackle each similar problem at the same time. So the process is easier. I learn to solve something, and then I apply it to everything I can. Then I pass to the next type of problem.

Ah, I could remember an issue that I found today. Every time I run ERC, it focuses on the first item. This is crazy annoying. Since I am in a page/spot, then I run ERC again to see if I could fix it, and then it throws me to another place in the project. I hate that. This is definitely a bug.

That is interesting, @marzk, I am part-way through a new schematic (lots of pins not connected / many open wires so squares and circles everywhere) and after reading this topic I clicked the ERC tool.
I’m running KiCad v5.1 at the moment.

image

The dialog shows the first component it found with no annotation and stopped.
That’s better (in my view) than being given a longer list of errors and warnings which do not apply: it tells me not to use this tool yet, because I haven’t finished a necessary previous step.