"Wires are not connected to anything" error

Almost every wire throws the error - wires are not connected to anything - when I preform ERC on KiCAD 6.0.4. I saw the issue was reported in 6.0.3 (Issue 11164) but it still happens on 6.0.4. Is there a fix or workaround? KiCAD is practically unusable if I can’t get the wire to connect.

note: this is NOT a grid issue - every component and wire are aligned on the same grid as shown in the zoomed in image


EDIT
**I upgraded to 6.0.5, deleted the wires and redrew them but the problem persist with no change. I attached here the archived project with just a few components and wire **
DK_Bridge_A01.zip (5.9 KB)

I don’t know the reason, but 6.0.5 is available since more than month.

Can you share your schematic?
Delete everything else away from this region if you want

1 Like

First: upgrade to v6.05, save schematic, open schematic, run ERC and check if your problem is solved.

Additional sidenote:

note: this is NOT a grid issue - every component and wire are aligned on the same grid as shown in the zoomed in image

A zoomed image is good. But it tells not everything - if a wire is 0.00000000000001 off the grid this could not be seen on the image - but the connectivity is broken (ok, to be honest, on a non-connected wire there should be a square on the wire-end).
So it’s better to additionally upload the archived (zipped) project (Kicad-manager–>File–>Archive project). If there are confidential-issues you could delete all symbol except the USB-connector and surrounding wires (I think these symbols are very standard - so no confidentiality needed).

1 Like

See edit. I upgraded to v6.0.5 and redrew the wires but the problem remains. Like you said if the connectivity is broken I should see a square at the ends but there isn’t. So I’m quite intrigue as to what’s causing this issue

Yep. Just did. Please see edit and the project file.

I get the same error on latest 6.0.5++ Testing
When i annotate the schematic, it goes away
ERC need annotation to be done

1 Like

running ERC directly after schematic-opening gives the “not connected”-warning you showed. But there is also a warning-message in the ERC-dialog-window itself: “Schematic is not fully annotated. ERC results may incomplete.”

So run annotation first, than run ERC.

edit: I should update the browser-window prior to my reply - david had already given a good answer :slight_smile:

gosh… I forgot to annotate before running ERC. Thank You!

To be honest, even though KiCad warns about incomplete annotation, the messages are misleading, especially if there are tons of them. One warning gets easily lost.

Recently automatic annotation of newly placed items was added the unstable development version. When it becomes available for wider audience, I would turn it on, which saves from headaches. IMO the need for manually triggering the annotation process is an unnecessary step.

2 Likes

I find this behaviour of KiCad a bit incomprehensible.

Each schematic symbol has an UUID, and those UUID’s are normally also used for matching schematic symbols with the footprints on the PCB. This error would not have surfaced if ERC just used the UUID’s instead of the RefDes.

In my opinion, UUID’s work better in the software, while the RefDes is easier for humans. The software could simply always use the UUID, but show the RefDes if it’s available, or something else if the schematic is not fully annotated. Maybe show the UUID in those cases, or somethig with coordinates such as: “R? @(2300, 2500)”.

1 Like

Automatic execution without warning won’t be the best solution either. Sometimes I have a piece of the schematic that is numbered and I want to keep it, and I want to have the remaining fragments numbered with consecutive numbers in local fragments. To get this I spread the fragments far beyond the page for the time of numbering.

It’s optional, and it doesn’t re-annotate automatically. It just adds a number to a newly added symbol instead of leaving it “?”. It’s possible to re-annotate from scratch later, it just makes it possible to not care about annotation at all if the numbers aren’t interesting to you.

1 Like

OK. Good.

I know, but if that would happen automatically I would get numbers in different order than I want and probably can’t reverse the operation. But fortunately it is not automatic.

Yes, the first state of every circuit you create in Kicad is the "Wires are not connected to anything” state. Yes, indeed, you might call it the primordial state of every circuit in Kicad.

I get the same results as davidrsb.

I do get errors like “Wires not connected to anything” and “Duplicate Items”, but also a big warning on top tht ERC does not work properly because the schematic is not annotated.

When I run the annotation before the ERC, then all the weird errors go away and only some sensible errors remain.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.