Unable to download kicad version 4.0.4 or 4.0.3 using ppa for Ubuntu


#1

I want to install older version of kicad, prior to 4.0.7 for Ubuntu 16.04, and I’m unable to do so using ppa instructions provided on download page. I even downloaded the .deb file for 4.0.4 and 4.0.3, upon trying to install those through terminal, it downloaded kicad 6 instead. Please help. Thanks in advance, I have a 64bit machine running Ubuntu 16.04


#2

Why? 4.0.7 is identical to all 4.0.x versions but has fewer bugs.


#3

That’s some terminal you have there since it can download binaries from the future.

Kicad 6 doesn’t exist yet, can you post where you got those .deb files from and what command did you try to run to install them?


#4

You are right. But current nightly reports itself to the user as version 6.


#5

I am aware of that (actually it reports itself as 6.0.0-rc1) but it’s kinda hard to stumble into nightly when you are trying to download 4.0.4 .deb.


#6

We have a custom library of components and it’s conflicting with the existing kicad libraries of 4.0.7. I won’t be able to explain it in short. In conclusion, I need to install 4.0.4 to verify whether the problem I’m facing is consistent with all versions of kicad or there’s an error on my end.


#7

Welcome to the club, I wasn’t aware that nightly built is represents as 6. Regardless, I’ll post the link soon


#8

You know that you can use 4.0.7 without the official libs right? You can even install any version of the official lib. (Not with an installer but by downloading said lib from github and putting it somewhere on your system. Then point kicad to that place instead of the system directory version of the libs.)


#9

I’m unable to delete the path /usr/share/kicad/library

https://launchpad.net/~js-reynaud/+archive/ubuntu/kicad-4/packages

This is the link where I downloaded the .deb files from


#10

Command used was sudo dpkg -i kicad_4.0.4+e1-6308~48~ubuntu15.10.1_amd64.deb
I realise I’m using 16.04 and the deb file was for 15.10 but I believe it should be compatible. Correct me if I’m wrong.


#11

This is because that is a system path. You need root access for it. (In other words: Do not touch this if you are not 100% certain you know what you are doing.)

Your personal libs should not be in this path!! (These libs will be managed by the kicad package.)

Running kicad without libs is done by removing footprint libs from the fp lib table (library manager in pcb_new). For symbols such an option does not exist in version 4. Symbol libs are assigned to the project. So you can only influence what libs are assigned to new projects (My suggestion: Do not start new projects with version 4. Switch to version 5 for new stuff.)

But if you insist on creating new projects with version 4 then you might need to edit the system template project to remove symbol libs for new projects.


Or you simply take care of library preiorities and make sure your personal symbol libs have higher priority than the system ones: Any conflict with names of modules and libraries? This should remove any conflict between your personal libs and the system libs as your lib takes precedence in the case of a conflict.


#12

install gdebi via terminal & then try & install .deb via gdebi (right click deb & select open with)
it’ll show if any dependency/version is not matching…

easier alternative is try 4.0.7 windows version via wine… so your current ubuntu installation won’t be disturbed…


#13

Thanks Apurv.
This worked.


#14

Hey Rene, thanks for all your help. I modified the installation script and I am removing the conflicting kicad libraries before installation. The component selection was conflicting due to library priority like you had suggested. Also I will stick to 4.0.7 as it has fewer bugs.


#15

You are not along :slight_smile: . But I keep switching to 5.x back and for.
For Pcbnew - I can use vim for search and replace to fix the “at” (in m) vs. “offset” (in inch) easily.
For eeschematic - I just stay edit with 4.0.7, and view only on 5.x because it is too much of search and replace I have to do since they introduce a MUST library name in front of every symbol !


#16

Transferring from v4 to v5 should not be done with a text editor! Kicad has a tool for that (the remap dialog) Converting KiCad version 4 projects to version 5 (Remap a project)


#17

The moment you use the remap. There is no going back. It only useful when your intent is remove 4.0.7 out of your design history.


#18

The same is true if you use search and replace with a text editor to add the lib names.


#19

That why I said, 5.x for read only on schematic, 4.x will do the modify. I were hoping the 5.x feature was extend in this manner instead of enforce to incompatibility. Like accept both styles of specify lib name, or not.
PS: I know by now the hope is hopeless.


#20

Please note that the developers are not aware of these bugs. And if they are not reported to https://bugs.launchpad.net/kicad they may never get fixed. We’re pretty friendly over there. Please take a moment to record bugs in 5.x that you experience to the tracker. We would greatly appreciate your help in making KiCad better!