Ubuntu 21.04 Kicad Broken, can't assign footprints ?!

Hi,

New to the forum. Just installed Ubuntu 21.04 yesterday, then installed Kicad that came with it, it’s version 5.1.9 apparently.

Problem : I drew my schematic, no problem. Then I went to assign footprints to every components… and it the foot print browser doesn’t work. Every time I click on a component category, say “Diodes_SMD” as an example, I get an error message saying it nowhere to be found on the hard disk. I checked… it IS there… just with a slightly different spelling. 99% of the time the footprint browser uses a plural form, but the libraries on the disc use singular form… typo. So the browser sees no match and reports the library as “missing”. So I created a symlink to correct the spelling problem… now I don’t get the error any more, great. I can now select that category in the browser but… it’s still not working right : it shows ZERO footprints in that category ! So there must be something else wrong… but it’s out of my league now.

Basically Kicad on Ubuntu 21.04 does not work.

I assume it affect anyone on Ubuntu 21.04 so must be a well known problem ? Is there a fixed deb package we can download from somewhere ?!

Thanks very much in advance…

Vince

The plural in the name implies that Kicad version 4 was once installed on your machine. The current supported libraries all use singular in the names - for example the smd diode footprints are installed in /usr/share/kicad/modules/Diode_SMD.pretty/ on my machine. Check that you don’t have an old library path set on your machine.

Update : I uninstalled 5.1.9 that came with Ubuntu , and instead installed the latest 5.1.10 from Kicad’s own repository, apparently made for Ubuntu as well, even 21.04 specifically… however still no luck, same exact problem :-/

I do notice that 5.1.10 still comes with an old 5.1.9 Footprint package, though… so might be a clue ?

https://forum.kicad.info/t/i-had-kicad-4-installed-previosly-now-i-updated-to-v5-now-i-have-some-problems-with-the-library-setup/11932/2

1 Like

Thanks a lot Pedro, problem fixed ! :slight_smile:

I deleted the old v4 fp-lib-table config file in my home/user partition and all works fine now…

1 Like