Thermal reliefs for vias

I cannot get thermal reliefs to work. I am new to Kicad and have left settings at default. In copper zone properties. Clearance 0.508mm, min width 0.254mm, antipad clearance 0.508mm, spoke width 0.508mm. When I look at the various planes I cannot see the thermal reliefs around vias. The Pad connections box appears to be gray although I can select Thermal relief. I am using version 4.0.7. platform windows 8, 64 bit but my windows is actually 10.

The KiCAD copper pours do not place thermal reliefs around vias. Thermal reliefs are only placed around pads.

(The purpose of a thermal relief is to make it easier to solder a connection - especially when soldering is done manually. Pads exist to make soldered connections; vias are only for electrical continuity between layers in a board. Since vias are usually NOT intended to receive solder, there is no reason for vias to have a thermal relief. That is also why KiCAD’s default behavior is to cover vias with soldermask - often called “tenting” the vias.)



Thanks that makes a lot of sense. I still have a problem however when I look at through holes. I have top layer for ground connection GNDA but I cannot see the thermal relief on a through hole. Also when I bring up Copper zone properties I would expect to see the attached net for each layer. For instance when I click on F.Cu the GNDA Net is highlighted as it should be but when I click on In1 Cu and In2 Cu they also have GNDA highlighted but they are connected to other power nets. If I change the Net to that shows for all nets. There seems to be no association shown. The association must have worked when the plane was set up because the connections are correct but i cannot easily check the layer net connection. Thanks again for your help… Mike

I don’t think I’m following your description of what you see. Which canvas are you using? Can you annotate a screen shot or two to point out what you’re seeing?

The settings and parameters listed in your first post all seem reasonable.

Here’s a board I recently did, with copper pours on both top and bottom side. I have never done a 4-layer board, and all the zones on this board are the same net (i.e., GND). And, I’m running a Nightly build from last February, so the images may not correlate well with what you’re seeing.

Here I’m displaying only the top copper and top silk. You should see a thermal relief on both a surface-mount pad, and a thru-hole pad; a via completely enveloped in the fill zone; as well as clearance around tracks and pads.

Here’s the entire (front-side) zone, highlighted after being selected.

And here are the parameters and settings for the zone.

Finally, here’s the back-side copper pour, showing clearance and thermal relief around all of the thru-hole pads.

Remember that thermal relief can be specified on a pad-by-pad basis, as well as for a whole footprint, and for the fill zone. I’m fairly certain the preference for the pads takes precedence over the other two, and footprint over-rides the zone option. Check these settings for your board.


Thanks Dale for you comprehensive help. I got it working in the end. I was actually fixing someone else’s board. What made it work was going back to library edit of one of the through hole parts. I found it was not set to thermal relief. When I changed that setting and ran a fill all the reliefs appeared. When I tried to change the pad without going back to edit the part in the library editor it did not work for me.
Regarding Coper zone properties I think it works ok to set the net connection but does not show the net that has been set when opening later.
Thanks again for your help… Mike

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.