The grid settings of the "Schematics" are "constantly changing" somehow to value different than the default 50 mils. This is really annoying. Is this a bug? Is there someone else experiencing the same issue?

I am having a lot of issues with the grid.

The project I am working on was created a long time ago, and I may have custom symbols off-grid, which is fine since I can fix them on demand. This may happen in these collaborative projects over time.

But it is pretty hard to work on this project for some unknown reason.

I don’t know if this is a bug with this latest version of Kicad. Neither resetting the grid settings work.

What is the best way to fix these grid issues and reset it to the original and fix the positions of everything on this project?

Then after doing this sanity check I would be able to tell if there is a bug with the grid or not.

Application: KiCad Schematic Editor

Version: 6.0.5-a6ca702e91~116~ubuntu22.04.1, release build

	wxWidgets 3.0.5
	libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.11

Platform: Linux 5.15.0-30-generic x86_64, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
	Date: May  3 2022 08:42:29
	wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.5.2
	Curl: 7.83.0
	ngspice: 36
	Compiler: GCC 11.2.0 with C++ ABI 1016

Build settings:

In KiCad, the sensible things to do for a schematic is to work on a grid of 50mils (which is also the default).

And (old) schematic that got misaligned can be “fixed” by first resetting the grid to 50 mils, and then selecting everything (Drag a box around the whole schematic, or [Ctrl + A], then right click and select Align to Grid from the popup menu.

It’s also possible you’ve turned Schematic Editor / Preferences / Preferences / Schematic Editor / Display Options / Grid Options / Snap to Grid off (probably accidentally). KiCad pretty much relies on coordinates to match attachement points of pins to the ends of wire connections and turning the snap to grid off is not a good idea.

1 Like

Well noted. I particularly never change grid settings, then connecting symbols always works for my projects. But since this is a collaborative project someone may have changed something in the past.

Alright. This “Align Elements to Grid” helped me. I was not using it, but moving parts around with drag (G) to have them fixed. My solution was not good enough as your solution. Ah, and the snap to the grid was on already.

Well, thank you!

1 Like

Hey guys, something strange is still happening. Every time I open the design the grid is different, I believe. It is a bit annoying. Maybe it is a bug related to multiple/hierarchical pages design.

Unless there is an unknown shortcut (for me) that I keep hitting by mistake every time, that is changing grid settings.

Is someone else having a hard time with grid settings? I just want to use the default 50 mil grid… But it keeps changing somehow.

What grid settings do you see?
Does it change to a different value each time, or does it always go to the same “faulty” value?

There are also shortcut keys for switching between different grids:
Schematic Editor / View / Grid Properties

It 's a bit weird and redundant for the schematic.
I thought it was just the same dialog as in the PCB Editor, but that one is very similar, but a bit different because it also has a grid origin.

I’m having similar issues.
I’m working on a chip that is 1.6mm x 1.6mm.
I had to set the GRID size to very small, now when I’m working on the SCH, the wires aren’t snapping to the GRID.

Any solutions please?

@camerart you should always keep the grid in the schematic set at 50mil because symbols are typically designed on a 50mil grid and wires will not connect if they are on a different grid.

In the pcb editor, you can set the grid to whatever makes sense for your layout.

I understand you are working with a small chip (1.6mm x 1.6mm), and therefore it makes sense to use a small grid in the pcb editor. But the physical size of your chip does not make any difference in the schematic, so it should not mean that you need to use a small schematic grid size.


Hi G,
I had to make a new SYMBOL, where the PINS are 0.4mm apart, so I used the smallest setting.
When this is in the SCH, wires don’t match up.

So, does what you suggest still apply?

Let us see what you are doing:

  1. Set the grid in the schematic to 50mil (so we have a reference).
  2. Post a screenshot of the schematic with your symbol on it.

To (very likely) fix your problem:

  1. Open your symbol in the Symbol Editor.
  2. Set the grid to 100mil.
  3. Move all the pins, so they align on the grid.
  4. Add a new outline for the schematic symbol.
  5. Save it in your library.

6. Go back to the schematic.
7. Replace the faulty symbol with the repaired version (or delete the old and place the new one).
8. Connect the wires on a 50mil grid.

You should never use a grid size for SYMBOL PINS other than 50 or 100 mils. Nothing in mm, no smaller value than 50 mils.

Honestly, this has been so common problem for years and years that IMO KiCad should make it almost impossible to put symbol pin on other than 50 or 100 mil grid. As it is now, it’s too easy to create problematic symbols.

I could not track what is going on. If I am mistakenly hitting some hidden shortcut or if there is a bug. However, I’ve never seen this problem before.

Also, Alt+1 and Alt+2 are a combination of keys that are not easily hit by me since they use keys far from each other. I was thinking that maybe a single key shortcut was doing that.

As I could see some values of the grid that are randomly appearing are: 25 mils, 20 mils, 2 mils.

Most of the time, I reset everything to the default (50 mils) grid. And also I do reset the Grid Sizes.

For instance, now this window is like this

Fast Switching values are empty for some reason. And I don’t see “Reset Grid Origin” as it is shown in your post.

I posted two screenshots. In the schematic you can not reset the grid origin (nor define an offset). Those functions only are for the PCB editor.

There is no reason to make a schematic symbol with pins 0.4mm apart. That would be too small to see on a schematic. Schematics, first and foremost, should be drawn to be easily readable by humans. As stated earlier, due to the way KiCad’s schematic editor and symbol libraries are designed, pins should always be placed on a 50mil grid (or 100mil, or a larger multiple).

Your part needs a PCB footprint with pads 0.4mm apart, perhaps. There’s no reason that the pins in the schematic symbol need to be placed with the same spacing as the pads in the pcb footprint.

The schematic symbol is for humans to read. The PCB footprint is for a PCB fab house to manufacture and for a physical part to get soldered onto.

Ah, alright. The issue I am having is with the Schematics.

Maybe we need to ‘rename’ the units in the schematic portion to “nothings”. Well “units” might be better. :wink:

1 Like

What does this mean?

You mean what Hermit says? This has been discussed before. The actual units in the schematic is meaningless, it could be called schematicunits or woodenlogs or lightyears or anything.

Holding the Ctrl key down while using the mouse will knock anything off grid.
Maybe that key was accidentally used instead of the Shift key?

I tried this here. But it is kind of hard to trigger this one. But I will keep my eye open to track if this shortcut is happening.

Also, where is this grid setting stored? Which file? Maybe it is being changed externally somehow.

Tried what?

Trigger what?

What setting?