The exported wrl file is matched in KiCADStepUp but not matched in KiCAD Footprint Editor


I have dealed with a step file which is sent from another one to me using KiCADStepUp and A2plus plugin in FreeCAD to let 3D file match the footprint. The assemble is very well in FreeCAD(KiCADStepUp), it is shown like this inf FreeCAD:

But when I import the wrl file into KiCAD footprint editor, it’s shown like this:

The 3D model is much larger then footprint.

Because I use KiCADStepUp and A2plus plugin of FreeCAD to deal with the 3D model and then export it to wrl file, so I don’t know which step cause this issue.
Here is the footprint file:
PEL012401.kicad_mod (2.8 KB)
Here is the wrl file:
assemble-PEL012103_01_001.wrl (2.2 MB)
Here is the FreeCAD version:
OS: Windows 10 Version 1909
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24267 +99 (Git)
Build type: Release
Branch: Branch_0.19.3
Hash: 6530e364184ce05ccff39501e175cf2237e6ee4b
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.3
Locale: English/United States (en_US)

Here is the KiCADStepUp version:
kicad StepUp version 10.2.0
Here is the A2plus version:V0.4.54b
Here is the KiCAD version:
Application: KiCad 封装编辑器 (64-bit)

Version: (6.0.0), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 18363), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 24 2021 19:17:02
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

hi @xzf16

  1. you have missed to attach the stp file (or a source where to download it)
  2. your wrl file is in scale 1:1… kicad pcbnew needs a scale 1:0.397
  3. you are missing some tools in StepUp to export your models in wrl already with the right scale factor
  4. as in your previous post, to align correctly your model to your footprint, it is recommended to have offset, scale and rotation to zero in your fp file
    (offset (xyz 0 0 0))
    (scale (xyz 1 1 1))
    (rotate (xyz 0 0 0))

please have a look at here and to stepup cheatsheets ap pg4:

Hi Maui,

Thanks for your reply.

Here is the stp file:
connector.stp (609.9 KB)

I used KiCADStepUp export tool to export it, the size is matched.

The thing I was confuse is: if I load the step file directly in KiCAD footprint editor, the size is matched, but when I load it to FreeCAD and use FreeCAD default export tool, the size will not be matched.

please find attached a board with the footprint reviewed and with the two 3d models (wrl & step) aligned to the right position
I used FC, Manipultor WB and StepUp WB (exporting the 3d model with the ksu internal button) (721.3 KB)

Hi Maui,

Thanks very much.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.