System variables and Windows nightly installer change

1 Like

The latest available nightly build package ATM is r19903 (git hash a69a4be853) but it doesn’t seem to have that change, so it should be in the next.

Now I have to change Running several KiCad versions on the same Windows machine. It’s mostly obsolete.

1 Like

The post was removed??

Very odd.
Not being able to parallel install released versions and testing next release has always restricted adequately testing the next major release until too late, so this versioned install is very desirable

My guess would be some things are still in flux and the post will come back with accurate information.

Yes, some things are still in flux.
Note that lib tables and footprint model references in library masters have been updated to use the new variables, so please update both.

We needed to de-publish the post for a bit while we work out a more user-friendly migration suggestion for the 3d model variables. We’ll have it back up soon.

image

image

Outcome: doesn’t work at all. I don’t know where it was installed; Program Files\KiCad has only the old 5.1.

Also the next one has the problem. r19930.7e58f1aa9f-x86_64-lite

Windows installer issues go here https://gitlab.com/kicad/packaging/kicad-win-builder/-/issues

It has already been discussed in https://gitlab.com/kicad/packaging/kicad-win-builder/-/issues/98.

The latest nightly build works!

There was a small problem (which was probably related to the one mentioned by Seth above): I installed with the lite installer and left the 3d models uninstalled. The new path variables were added but the new 3d model path pointed to kicad\ folder instead of kicad\5.99. This means that if I wouldn’t have noticed it and installed the library later, KiCad 5.99 wouldn’t have found the library or would have found it in the wrong place.

Re-installing from scratch with all libraries (also deleting the old 5.99 user configuration from %appdata%\kicad\5.99) helped. I recommend that for easy transition. It takes care also of the library tables which was mentioned by chschlue above.

If you install 5.99 for the first time alongside 5.1 or start from scratch, remember to uncheck the “Import library configuration” option if you want to import 5.1 settings. Otherwise you’ll get the wrong library tables and may use 5.1 libraries with 5.99.

image

image

However, there’s still a problem with the 3D libraries: in old designs the footprints embedded into the board file refer to the old library path. You may need to add the old KISYS3DMOD variable and point it to the wanted 3D library folder. (I think this is why the original blog post announcement was taken down for a while. Let’s see what kind of instructions they’ll give us later.)

I just installed the latest Windows Nightly on a machine that has, and has only ever had, 5.1 installed on it. It all went well except that the Installer warned me that

image

That’s not strictly true as 5.99 isn’t installed and now goes into its own directory, so my existing 5.1 install shouldn’t be touched (and wasn’t).

I’m guessing this is just triggered by the presence of any version of KiCad, but is slightly worrying as this is supposed to allow for parallel installations.

A relatively minor detail, but one that probably aught to be corrected to stop any confusion.

@marekr, does your recent commit https://gitlab.com/kicad/packaging/kicad-win-builder/-/commit/f6156519edf27fcc3e34d55a6817d67ca73a8eb7 affect this or should @Chris_G report this in https://gitlab.com/kicad/packaging/kicad-win-builder/-/issues ?

We’re trying to implement some way of fixing this automatically (in most cases) so that we don’t need to ask people to follow special instructions.

1 Like

Yes

The latest installer doesn’t warn anymore if the same x.y version isn’t installed.

Well it fixes the 5.1 and 5.99 conflict, the next 5.99 build will then warn about 5.99

Confirmed. Works as expected, thanks.