Symbol ref and value don't stay placed as intended


#1

In KiCad nightly. After placing the symbol reference and component name in Symbol Library Editor above the symbol. In the schematic they’re moved elsewhere. It doesn’t happen to all of the symbols and if I turn the option off in Eeschema > Preferences > General Options > Editing it still happens. Is this a bug, how to get the text to stay in place?

39694878-abe03ff4-51e0-11e8-8d96-ace437644d9039694880-ae2df580-51e0-11e8-9579-37e123998056


#2

I just checked, and my nightly version of KiCad does this too.

I’m not that skilled at checking for existing bug reports to know if it has already been reported, but I’d bet a nickle that the Devs are aware of this “feature”.


#3

It is the autoplace fields feature. It can be turned of somewhere in the preferences dialogs.

It is however necessary if you ever want to rotate or mirror your symbols. (And if you have a symbol with multiple units that have different sizes as you can not define the field placement differently for each unit.)


#4

Yes. And, I quickly figured out why I left these checked as soon as I hit the “r” key.

Maybe it would be nice to “move” that feature setting to the symbol? Devices like ICs are not likely to be flipped or mirrored, unlike resistors and capacitors.


#5

I don’t get it. Whether “Automatically place symbol fields” is ticked or not the fields rotate together with the symbol. If the fields are placed at the top in the symbol editor they shouldn’t randomly move to somewhere else (e.g. to a side) when adding the symbol to the schematic.


#6

Do you have a screen-shot to show this?

And, why did you decide it was worth the extra effort?


#7

There is an effort to make Eeschema as robust as PcbNew. Give the Devs a little more time to work out the quirks.

I’ve learned, and always move the text after the layout.


#8

I don’t need a screenshot. The symbol lib format simply has only one definition for every field (including its position)

So if your units are not totally identical you can not use the symbol editor to define a position for the text fields separately for every unit.

This has been in kicad longer then i used it. So only very old kicad users might remember a time before this feature. And again if you don’t like it, turn it off.

Would require a file format change. Will not happen before the new file format is implemented. (I am not sure what the full capabilities of the new file format will be. You can ask over at the bugtracker)


#9

I figured as much. I thought the idea worthy of discussion anyways.

Remind me the link to the bugtracker?


#10

#11

Reported as bug 1770039


#12

Okay, I’ve unchecked the auto-place option and the symbols are placed fine - with the text as it is in the library. I must have been confused by having the option ticked. When it’s ticked it places the text differently to how it is in the library.


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.