Symbol Library Editor KiCad 5

I’m attempting to make some symbols in KiCad 5 and I’m not sure if my installation is borked or if the method has changed without documentation update. I am on Windows 10 64-bit. The below screenshot shows my Symbol Library Editor main toolbar.

In comparison with the documentation, I seem to be missing some options. Namely the “Create a new symbol from the currently loaded symbol.”

The problem is that I am trying to save a symbol into a specific library, but it doesn’t seem possible to select a “working” library and then save it to that library.

Let’s see if I can get you started.
Find a symbol that you want to start with and highlight it.
Then, right click.

Okay, I right clicked and the following menu is shown:
Double clicking seems to be the same as “Edit Symbol”

i guess the documentation still referring to v4 (not sure)…

what i do in v5 is -
copy the symbol I want to edit, paste it in my own library, rename it & edit it in my own library…
I don’t change/overwrite original library…
note that if original symbol has alias, they’ll be copied to your own library as well… but they are not separate symbols just list of names referring that single symbol…

Im using kicad
Version: 5.0.0-fee4fd1~65~ubuntu16.04.1, release build
Downloaded about 15 mins ago,

and I’m still confused.
I have the same question as to OP.

  1. Inset a symbol from a read-only lib that came with kicad
  2. Want to make change to symbol and save the new version to my local lib
  3. position cursor over symbol in the schematic editor.
  4. right-click, select properties/edit with lib editor

The symbol editor opens up with the symbol showing and the reader say read-only.

I can not figure out how to “cut and paste” into my library.
There use to be a way to select active lib, I can not find that either.

If I try to add an existing lib, it says lib already exists.

In summary:
How so I make a change to an existing symbol and save it to a new library?

1 Like

Maybe needs to have an FAQ, since a lot of people find it non-obvious.

  1. Create a new library (File->New library)
  2. You right-click to “Copy symbol” to clipboard
  3. Then right-click “paste symbol” into the new library
  4. Then edit the symbol
1 Like

OK I think I figured it out.

  1. After the symbol editor opens up with the symbol selected in the schematic editor
  2. in the left hand window, position your cursor over the symbol, usually highed in red, and right click.
  3. left click on “copy symbol”
  4. now using the left hand window, scroll up or down until you find the library that you want to save the symbol in
  5. position your cursor over the desired library
  6. right click and left-click on save symbol.

Now you can edit the symbol. and save it into your library.

Then go back to the schematic editor and delete the symbol you were trying to edit.
Insert the new symbol and reapply any customization you did on the symbol for the current project.

I’m not sure this is an improvement over, edit symbol, select active lib and save.
At the very least, provide a button to collapse the left hand menu, some libs have lots of symbols and scrolling to find your lib is tiresome.

Over-all I like the new version 5, much improved over ver 4.
Thanks for all your hard work.

above that part of the symbol editor there is a text entry field. It can be used to filter the resulting list (enter the name of your lib instead of scrolling)

I started to learn KiCad (4.0.7) a few months back, and admittedly if was a sporadic effort. Then along comes KiCad 5.0 so I thought I would take it from the top and redo the Getting Started in KiCad tutorial so as to not assume anything. BTW, I am using the 5.0.0 release build for Windows 10.

When I got to the bit about creating a simple connector for the circuit I initially went the Symbol Library Editor route to create the connector symbol from scratch. That is when I hit a problem with trying to create a symbol.

Apparently the ground-truth of the software is different because I can’t bring up the Pin Properties window to start the symbol creation. When I click on the Create New Symbol icon I get a list of the libraries to select; not the creation of a symbol.

I was able to make the symbol using quicklib and I suspect I could have also copied a similar part from a library and edited it to make the requisite symbol. That said, I should be able to create part from scratch.

Please advise if I’m missing something.

Kicad needs to know in which lib you want to put your new symbol. Of course it asks first.

Thank you, this worked for me. A quick question about this: is there a method in the GUI to change the symbol name? I ended up manually changing it in the .lib and .dcm file.

Yes, I think perhaps we should compile an FAQ for some of the KiCad 5 changes that aren’t yet updated in the documentation and aren’t obvious to those coming over from 4.0.7.

As I am going through the motions of laying out my first board with KiCad 5, I am running into additional woes that don’t match with the docs and will probably be posting questions about them soon.

Yes it is however well hidden. Open the symbol such that you see it in the main part of the symbol editor.
The value field should be shown and filled out as the symbol name. Edit that fields content to change the name. (right click it -> edit or press e while your mouse is on top of the field)

1 Like


Thanks for the information. I thought that might have been the case but I tripped myself up somewhere that made me doubt that workflow.

I tried to create a new symbol library first, just for the exercise, then attempted to reference the new library when creating the part. I must have missed something because I couldn’t find my library in the list.

I am away from my computer this weekend but will try the steps you indicated when I get back. Hopefully I can create a symbol from scratch without further issues.

Best Regards,

After creating a library you need to add it to the library table for kicad to know about it.

When you create a lib you are asked by kicad if you want to add it to the global or local table. (local means only visible in the current project)
If you chose to press cancel than this step got skipped.

I just tested creating a new symbol in a new lib. The steps are as follows:

  • press new lib button (leftmost button in the top toolbar)
  • browse to the file system location where you want to store your lib
  • enter a lib name and press ok
  • now kicad asks if it should add the lib to the local or global lib table (choose what fits your needs)
  • press the new symbol button (the opamp button, 4th button from the left in the top toolbar)
  • kicad asks into which lib you want to add your new symbol. There is a filter input field to help you with that. (enter the lib name you used for your newly created lib. It should then be easier to find it)
  • Select the lib and start working on your symbol.


Thanks for the quick follow-up and the step-by-step list of actions.

I thought I created the new, temp library and added it to Local, but perhaps that’s where I fat-fingured something and lost the new library reference. Unfortunately I don’t have any remaining “forensic evidence” to see the error in my ways as I cleaned up for a fresh start.

I’ll check this out ASAP when I’m back.


there is also a library manager in the preferences menu that you can use to check if you successfully added a lib

Yes, I’m familiar with the Library Manager as well. I thought it indicated my new library was in local, but no telling what I might have fumbled from that point on Ward.

Hopefully all goes well with a fresh start.

BTW, not rag on the documentation because I fully understand the volunteer effort involved, but I do believe the Getting Started tutorial has some errors or at least missing the steps you described for using the Symbol Library Editor in Section 7.1. I realize the tutorial is probably not a high priority, but it could use a review and clean up at some point.


The getting started tutorial needs a lot of rework. But there is just nobody willing (or able) to put time into it.
You can also take a look at the FAQ section of this forum as we also have a lot of stuff in there that can help.

Why using a different wording from the library table dialog where the “local libraries” are called “Project specific libraries” ? It can only lead new users to confusion.

Understood; documentation tends to be the “step child” of most projects, especially volunteer projects.

I tried as many things as I could think of to figure a solution before resorting to the forum. Thankfully there is a forum and there was even a thread on related Symbol Library Editor issues. More importantly there are knowledgeable people on the forum.


1 Like